mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Attiny 13 mit STK500 brennen


Autor: Uwe John (dl4zbb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo AVR-Gemeinde,

ich brauche mal kompetente Hilfe. Hier im Forum werde ich nicht fündig.
Habe mir ein STK500 gekauft und ne Stange Attiny 13 Chips. Bascom, 
AVR-Studio, PonyProg ist alles installiert. Ich kann aber nichts in die 
Chips schreiben. Egal welches der Programme ich nehme. Die Fuses werden 
angeblich gelesen, ändern kann ich diese nicht. Da bekomme ich immer 
wieder ne Fehlermeldung das ich die Spannung überprüfen soll, bzw. 
erhöhen soll (AVR-Studio). Die ist aber ok und liegt bei 5,1 Volt.

Signatur auslesen ist auch nicht möglich. Ich glaube mal das ich 
irgendwo einen Fehler/Denkfehler habe oder das Setup des STK500 stimmt 
nicht.

Mir wäre schon mal sehr geholfen wenn mir jemand schreibt wie ich das 
STK500 für den Attiny 13 konfigurieren muss. Wo muss ich welches Kabel 
wohin stecken, Jumper usw. Bin zwar nach Anleitung vorgegangen, aber es 
tut nicht...

MfG Uwe

...Guten Rutsch ins neue Jahr

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Uwe

Also gemäss Beschreibung muss der Atiny 13 in den SCKT3400D1(blau) slot.

Dann eine Verbindung auf dem STK  SPROG1 --> ISP6PIN.

Dann stellst du im AVR Studio den Programmingmode auf ISP und wählst mal 
die tiefste ISP Frequenz ein.

Dann soltest du zumindest mal die Signatur lesen können.

Wenn du die Atiny neu ab Presse vewendest sollten sie auch internem 
Clock laufen.



Gruss Michael

Autor: Uwe John (dl4zbb)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Michael,

vielen Dank für Deine Antwort.
Das habe ich alles so gemacht wie von Dir beschrieben. Damit geht 
nichts...
Erst wenn ich von PortE/Aux RST eine Verbindung nach PortB PB5 gesteckt 
hatte ( Resetleitung o.s.) konnte ich einen Chip lesen. Das hat auch nur 
1x funktioniert.
Ich krieg hier bald die Kriese. Meine Vermutung geht dahin das ich die 
Fuses falsch gesetzt habe und mich die Chips nun aussperren. Angeblich 
gibt es dafür aber auch ne Lösung mit serial HV-Programming. Da bekomme 
ich dann die Fehlermeldungen vom STK500. Ich habe die mal angehangen.

Gruß
Uwe

Autor: Guest (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

schau mal hier :

http://kaasxxx.wordpress.com/2008/02/11/programmin...

Vielleicht gehts mit Bildern besser. Ansonsten stehts auch in der Hilfe 
von WinAVR drin. Funktionieren tut es grundsaetzlich jedenfalls. :-)

Autor: I. E. (anfaenger69)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mach mal ein Bild vom STK500...
Ich will mir mal anschauen, was Du so alles gesteckt und plaziert 
hast...

Autor: I. E. (anfaenger69)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh, Guest war schneller :c)

Autor: Guest (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jepp, zu schnell ...

Statt WinAVR sollte in dem Posting natuerlich AVRStudio stehen. :-)

Autor: Uwe John (dl4zbb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

so wie es scheint funzt es !!! Mit dem Bildband bin ich zurechtgekommen. 
Danke !!!
Mir fehlte die Leitung XT1 PortE nach PB3 PortB. Zumindest konnte ich an 
2 Chips mal die Signatur lesen ohne ne Errormessage und flashen ging 
auch ohne Fehler. Ok, dann baue ich mal die Testschaltung auf und schau 
mal ob`s tut.

Gruß
Uwe

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.