mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Masseproblem: ATMEGA8 + Transistor + Relais


Autor: Phillip P. (phillip)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Eins vorweg: Ich bin blutiger Elektronik-Anfänger und bastle gerade an 
meinem ersten Projekt. Ich werde versuchen, meinen Testaufbau so kurz 
wie möglich zu beschreiben... Also, ich habe:

1. Eine Platine mit einem Atmega8, der u.a. den Basisstrom für einen 
Transistor liefert. Stromversorgung: derzeit 5v Netzteil

2. Eine Platine, auf der ein Transistor (mit allen nötigen Bauteilen) 
sitzt, der ein Relais (2fach Umschalter) schaltet. Stromversorgung für 
Relais: derzeit 9v Batterie (über Spannungsregler auf 6V)

3. Ein Gitarren-Effektgerät, in welches ich anstatt des mechanischen 
Fußschalters das Relais eingebaut habe.

Zweck des ganzen: Ich will eine "Fernbedienung" für meine 
Gitarren-Effektgeräte bauen. Teil 1 kommt in ein Fußschaltergehäuse und 
liegt vor mir auf der Bühne. Teil 2 mit den Transistoren etc. liegt 
hinten auf der Bühne und schaltet die Effekte in/aus dem Signalweg.

Mein Problem: Es funktioniert bis jetzt alles perfekt, AUSSER dass ich 
auf meinem Gitarrenverstärker einen starken "Brumm" habe, sobald ich die 
Platine mit dem Atmega an die Stromversorgung hänge. Obwohl ich wie 
gesagt voller Anfänger bin, leuchtet mir das nicht so ganz ein, da das 
Relais ja nur den mechanischen Schalter ersetzt, und das Gitarrensignal 
ja eigentlich von der ganzen Schalt-Elektronik entkoppelt sein müsste, 
nicht?

Ich habe die Masse der uC-Platine mit der Masse der 
Transistor/Relais-Platine verbunden. Kann mir jemand einen Tipp geben, 
warum es brummt?

LG und danke,
Phillip

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Deine Platine mit dem Relais hat offenbar eine Verbindung zwischen der 
Masse des Transistors und dem GESCHALTETTEN Kontakt.

Die Platine ist also das Gegenteil von dem was eine Relaisplatine sein 
soll, nämlich eine galvanische Trennung.

Du musst die Verbindung finden und auftrennen. Schau halt einfach, wohin 
noch Leitungen gehen von den beiden Relaiskontakten des Schaltkontakts. 
Sie dürfen nur zu den beiden Leitungen gehen, die an dein 
Gitarreneffektgerät zur ehemaligen Schalterposition gehen und nicht noch 
sonstwohin.

Mach ein Photo von der Platine auf der man genug sieht, inklusiver 
deiner Kabel, wenn du selbst das nicht findest.

Autor: Phillip P. (phillip)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier ist mein Testaufbau ...

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Phillip P. (phillip)

>      test-aufbau.jpg
>      1,5 MB, 0 Downloads

>Hier ist mein Testaufbau ...

Patsch

Und hier die prompte Ohrfeige wegen Faulheit beim Umgang mit 
Bildformaten.

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also am Relais liegt es erkennbar nicht,
und so wie das Bild sie zeigt, sollte die Schaltung brummfrei 
funktionieren,
aber was ist das für eine schwarze Buchse für Klinkenstecker da?
Von DER hast du kein Sterbenswörtchen gesagt.
Es würde mich nicht wundern, wenn es brummt, wenn dort was eingesteckt 
wird.

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Irgendwie sieht die Beschaltung der Relais-Kontakt komisch aus. Was ist 
das für ein Typ? Besser Datenblatt.

MfG Spess

Autor: Phillip P. (phillip)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falk Brunner schrieb:
> @  Phillip P. (phillip)
>
>>      test-aufbau.jpg
>>      1,5 MB, 0 Downloads
>
>>Hier ist mein Testaufbau ...
>
> *Patsch*
>
> Und hier die prompte Ohrfeige wegen Faulheit beim Umgang mit
> Bildformaten.

PATSCH-PATSCH

Und hier eine Doppel-Ohrfeige wegen Faulheit im Umgang mit 
Forums-Nutzern.
Wenn ich etwas falsch gemacht habe, dann sag zumindest auch dazu, was.

1,5 MB sind meiner Meinung nach durchaus tragbar. Falles es hier im 
Forum ungeschriebene Gesetze für Auflösung/Dateigröße von Bildern gibt, 
werde ich mich natürlich gerne daran halten, sofern ich diese kenne.

Autor: Phillip P. (phillip)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ MaWin (Gast)

> aber was ist das für eine schwarze Buchse für Klinkenstecker da?
> Von DER hast du kein Sterbenswörtchen gesagt.
> Es würde mich nicht wundern, wenn es brummt, wenn dort was eingesteckt
> wird.

Welche "Buchse" meinst du? Meinst du das Ding links oben im Bild, das an 
der Platine mit dem Mikrokontroller dranhängt? Das ist keine 
Klinkenbuchse, sondern das ist die Buchse für die Stromversorgung (5V 
Netzteil).

@ spess53 (Gast)

> Irgendwie sieht die Beschaltung der Relais-Kontakt komisch aus. Was ist
> das für ein Typ? Besser Datenblatt.

Das Datenblatt findest du hier:
http://www.finder.de/comuni/pdf/S30DE.pdf

Die Beschaltung sieht für dich wahrscheinlich komisch aus, weil du den 
Anblick eines doppelten Umschalt-Relais nicht gewohnt bist, kann das 
sein ;-)?

LG!

Autor: Walter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
warum brauchst du eigentlich eine atmega für die Fernbedienung??
Reicht da nicht ein Schalter?

Autor: Phillip P. (phillip)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
spess53 schrieb:
> Hi
>
> Irgendwie sieht die Beschaltung der Relais-Kontakt komisch aus. Was ist
> das für ein Typ? Besser Datenblatt.
>
> MfG Spess

Hier nochmal die Beschaltung des Relais (vielleicht hab ich ja was 
übersehen).

A1: +6V (vom Spannungsregler)
A2: wird vom Transistor auf Masse gezogen

21: Gitarren-Signal Eingang
11: Gitarren-Signal Ausgang

Kriegt das Relais keinen Strom, geht das Gitarrensignal über die Brücke 
zw. 22 und 12 direkt wieder auf den Ausgang. Kriegt das Relais Strom, 
dann geht das Signal vom Eingang (21) über 24 in das Effektgerät, und 
kommt dann über 14 zurück und geht auf den Ausgang (11).

Müsste stimmen so, oder? LG

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>Die Beschaltung sieht für dich wahrscheinlich komisch aus, weil du den
>Anblick eines doppelten Umschalt-Relais nicht gewohnt bist, kann das
>sein ;-)?

Eigentlich seit mehr als 35 Jahren nicht.

Mit dem Datenblatt macht es natürlich Sinn. Hast du das Brummen auch, 
wenn du das Relais z.B. mit einer Batterie schaltest?

MfG Spess

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Phillip P. (phillip)

>Und hier eine Doppel-Ohrfeige wegen Faulheit im Umgang mit
>Forums-Nutzern.
>Wenn ich etwas falsch gemacht habe, dann sag zumindest auch dazu, was.

Ist der Herr Krösus mit dem Umgang des Mediums Internet nicht vertraut? 
So es denn seine Zeit und gesellschaftlicher Status erlaubt, so clicke 
er auf die gar lustig blauen Worte, vulgus Links. Versuche er es doch 
gleich nochmal mit dem Beispiel Bildformate.

Vorzüglichste Grüße an Eure Durchlaucht

Autor: Phillip P. (phillip)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Walter schrieb:

> warum brauchst du eigentlich eine atmega für die Fernbedienung??
> Reicht da nicht ein Schalter?

Hallo Walter,

die Frage ist berechtig :-), aber es gibt mehrere Gründe:

1. Dies ist mein "Jungfern-Projekt", mit dem ich den Einstieg in die 
uC-Welt schaffen will - deswegen musste es ein atmega sein. Der Zweck 
ist also nur ein Vorwand, mich mit Mikrokontrollern zu beschäftigen ;-).

2. Später sollen bis zu 8 Relais geschaltet werden. Fußtaster sind 
billiger als Fußschalter, d.h. 8x Fußtaster plus ein Atmega8 (1,20.- bei 
Pollin) sind viiiiiiel billiger als 8x Fußschalter (je 6,50.-, wenn man 
was ordentliches nimmt). Ich könnte natürlich auch Fußtaster und 
Flip-Flop Module verwenden, aber das ist viel aufwändiger und braucht 
viel mehr Platz als ein Atmega8 (im Fußschalter-Gehäuse ist es eng!)

3. Ich möchte später vielleicht bestimmte Taster mit Sonderfunktionen 
belegen (z.B. ein Taster schaltet alle Kanäle auf "0"), oder aber 
Schaltzustände programmieren können (z.B. ein Schalter schaltet Relais 
2,4 und 5 ein).

4. Ich möchte später vielleicht eine serielle Verbindung zw. dem 
Fußschalter-Modul und einem anderen uC aufbauen, damit ich nicht für 
jedes Relais eine eigene Schaltleitung benötige...

LG, Phillip

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Was ist nun, wenn du eine Batterie benutzt?

MfG Spess

Autor: Phillip P. (phillip)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falk Brunner schrieb:

> Ist der Herr Krösus mit dem Umgang des Mediums Internet nicht vertraut?
> So es denn seine Zeit und gesellschaftlicher Status erlaubt, so clicke
> er auf die gar lustig blauen Worte, vulgus Links. Versuche er es doch
> gleich nochmal mit dem Beispiel Bildformate.
>
> Vorzüglichste Grüße an Eure Durchlaucht

Hmmm... sehr geistreich. Ironie und Sarkasmus sind ja angeblich Zeichen 
von Intelligenz. Nun denn...

Mit dem Medium Internet bin ich insofern vertraut, als dass ich 
hauptberuflich damit arbeiten. Zum Thema "Bildformate" halte ich derzeit 
eine Vorlesung an der Uni. Ich hätte das Bild locker auf 200-300KB 
bringen können, mea culpa.

Was ich allerdings nicht so schätze, ist ein abfälliger Unterton, weder 
im Internet noch im realen Leben. Mir ist positiv aufgefallen, dass sich 
die in deutschen Foren allgemein so verbreitete Klugscheißer-Kultur in 
diesem Forum sehr in Grenzen hält. Es gibt hier viele nette Leute, die 
einfach nur helfen wollen und einen Anfänger sachlich auf seine Fehler 
hinweisen, ohne sich dadurch profilieren zu müssen. Dafür bin ich 
dankbar.

Autor: Phillip P. (phillip)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ spess53

> Was ist nun, wenn du eine Batterie benutzt?

Ich schalte die Relais ja derzeit mit einer Batterie (?).

War es richtig, die Masse der uC-Platine mit der Masse der Batterie 
(bzw. der Transistor-Relais-Platine) zu verbinden?

LG

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> sondern das ist die Buchse für die Stromversorgung (5V Netzteil).

Hmm, dann gibt's da kein Brummproblem, definier ich mal....

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>> Was ist nun, wenn du eine Batterie benutzt?

Das war meine zweite Frage.

MfG Spess

Autor: Phillip P. (phillip)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
spess53 schrieb:
> Hi
>
>>> Was ist nun, wenn du eine Batterie benutzt?
>
> Das war meine zweite Frage.
>
> MfG Spess


Du meinst, wenn ich sowohl den Atmega8 als auch das Relais mit Batterie 
speise? Das kann ich leider z.Z. nicht ausprobieren, weil ich da erst 
eine Spannungsregelung (5V) für den Atmega zusammenlöten muss...

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>Du meinst, wenn ich sowohl den Atmega8 als auch das Relais mit Batterie
>speise? Das kann ich leider z.Z. nicht ausprobieren, weil ich da erst
>eine Spannungsregelung (5V) für den Atmega zusammenlöten muss...

Nein. Nur einfach nur das Relais (ohne den Rest der Schaltung) mit einer 
Batterie schalten.

MfG Spess

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.