mikrocontroller.net

Forum: PC Hard- und Software Grafikfehler, VRAM testen


Autor: suho (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe leider ein Problem mit meinem Notebook. Ich denke, dass 
irgendein VRAM Chip defekt ist.

1. Der Notebookmonitor wird nicht automatisch beim Anschalten des 
Laptops eingeschaltet, sondern ich muss das manuell über die speziellen 
Tasten auf der Tastatur tun.
2. Ich habe im ersten Grafikmodus (EGA denke ich) Grafikfehler, soll 
heißen manche Buchstaben werden in einer falschen Farbe (Lila) 
dargestellt.
3. Sobald der Grafikmodus in eine höhere VGA Auflösung wechselt und der 
nvidia-Treiber geladen ist, wird der Bildschirm komplett schwarz. Wenn 
ich unter Linux den vesa-Treiber verwende, sehe noch wie der X-Server 
startet aber nach einer Zeit friert der Bildschirm dann auch ein, 
lediglich den Mauszeiger kann ich noch bewegen, alles andere wird nich 
angezeigt.

Ich kann das Gerät jedoch immernoch als Server verwenden, denn die 
Linux-Konsole funktioniert ohne Probleme, abgesehen von den Farbfehlern.

Ich finde jedoch, dass Grund 1 nicht unbedingt zu meiner Vermutung 
passt, denn das würde bedeuten, dass eine Stelle im Speicher defekt ist, 
an der die Grakka Systeminformationen ablegt. Würde in solch einem Falle 
sich der Rechner überhaupt zum starten bewegen? Leider weiss ich keine 
Möglichkeit wie man auf den VRAM direkt zugreifen kann um ihn zu testen. 
Außerdem sind die 8 DDR2 Chips per Flip-Chip-Verfahren aufgebracht 
sodass es wohl nicht möglich ist diese auzulöten und auszutauschen.

Könnte das Problem auch andere Ursachen haben, vielleicht das 
Grafikbios?
Wobei ich der Meinung bin, dass in diesem Fall alle Buchstaben lila 
dargestellt werden würden.

Danke für eure Hilfe.

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Außerdem sind die 8 DDR2 Chips per Flip-Chip-Verfahren aufgebracht

DDR2-Speicherchips sind im BGA-Gehäuse untergebracht. Das ist nicht ganz 
dasselbe, aber ebenso schlecht reparierbar.

Das geschilderte Problem klingt in der Tat wie ein Speicherdefekt, 
allerdings kann es auch ein Defekt des Graphikcontrollers selber sein, 
manche Nvidia-Chips sind in minderwertigen BGA-Gehäusen untergebracht, 
die nach einiger Zeit Kontaktprobleme aufweisen.
Ein Defekt des BIOS hingegen kannst Du recht sicher ausschließen, da 
würde das Gerät komplett die Funktion verweigern, da BIOS-Erweiterungen 
mit einer Prüfsumme versehen sind, die vom Haupt-BIOS-Code ausgewertet 
wird.


Da wirst Du nicht viel machen können, es sei denn, Du hast Zugang zu 
jemandem, der BGA-Chips auslöten, mit neuen Lötzinnkügelchen versehen 
("reballen") und wieder einlöten kann.

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
suho schrieb:
> Ich kann das Gerät jedoch immernoch als Server verwenden, denn die
> Linux-Konsole funktioniert ohne Probleme, abgesehen von den Farbfehlern.

Wenn Du den weiter dafür verwenden möchtest, wäre das ein Notbehelf wenn 
die Graka immer mehr aussteigt.
http://www.pollin.de/shop/dt/MjI5OTcyOTk-/Computer...

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Software/Treiber-Problem ist ausgeschlossen?

Mal Bios resetted? (Load Factory Defaults...)
Mal Windows gebootet (wg. der besseren Treiberversorgung)
Mal verschiedene Linux-Live-CDs gebootet (auch ältere?)

Ansonsten: Kabelverbindungen (Board->Monitor) checken.
Mit externem Monitor ausprobieren.

Autor: suho (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@rufus
BGA sagt mir jetzt nicht viel, aber die Gehäuseform ist so wie ich das 
sehe TQFP.
>Da wirst Du nicht viel machen können, es sei denn, Du hast Zugang zu
>jemandem, der BGA-Chips auslöten, mit neuen Lötzinnkügelchen versehen
>("reballen") und wieder einlöten kann.
Also wird sowas nicht per Flip-Chip gemacht, sondern es werden 
Lötzinnkügelchen (ähnlich der stud-bumps beim Flip-Chip) aufgebracht und 
dann die Kontakte auf der anderen Seite der platine erwährmt? Davon hab 
ich noch nie was gehört muss ich zugeben.

@Εrnst
> Mal Bios resetted? (Load Factory Defaults...)
> Mal Windows gebootet (wg. der besseren Treiberversorgung)
> Mal verschiedene Linux-Live-CDs gebootet (auch ältere?)

Alles schon ausprobiert ... ich denke das Teil wird als kleiner Server 
enden, eigentlich gar keine so schlechte Idee, nen Laptop hat ja recht 
gute Power-Saving Features.

@mhh
Danke für den Tipp, werd mir das überlegen, denke aber nicht das ich 
sowas brauche. Bei mir werden Server ohne Monitore betrieben ;)

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> aber die Gehäuseform ist so wie ich das sehe TQFP

Bei DDR2? Unwahrscheinlich. Das DDR2-Timing ist mit so langen 
Anschlüssen, wie bei TQFP vorkommen, kaum in den Griff zu bekommen. 
SDRAM und DDR (ohne 2) gab es im TSOP, da ging das noch, aber DDR2 nicht 
mehr.

Wenn es TQFP sein sollte, was lässt Dich dann "flip-chip" vermuten?

Damit wir uns richtig verstehen, TQFP hat seitlich an den Gehäusekanten 
Beinchen, BGA ist ein rechteckiges oder quadratisches Plättchen mit 
Lötbällen darunter.

Was ist das für ein Notebook, was für ein Graphikchip ist darin, was für 
ein Chipsatz ist verbaut?

Kannst Du ein Photo von der Platine hier hochladen?

Autor: suho (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@rufus
Sorry, habe mich leider verguckt ...
Gehäuse ist: P-TFBGA-84. Da ich den Notebook schon wieder 
zusammengesetzt hab konnte ich nicht nochmal schnell nachgucken, hatte 
bloß irgendwas mit TF aus dem Datenblatt im Kopf. Tja, dann kann ich das 
Wechseln wohl vergessen zumahl ich dann auch 8 Chips tauschen müsste, 
das ist den Aufwand wohl nicht wert.

Autor: suho (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@rufus
Notebook ist ein 2 Jahre altes ACER mit nvidia 7600 und 256 MByte 
Grafikspeicher.

Autor: Icke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So Mitte 2008 wurde bekannt, daß nVidia eine Serie fehlerhafter 
Notebook-GPUs ausgeliefert hatte. Vielleicht ist dein Gerät davon 
betroffen.

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
suho schrieb:
> Danke für den Tipp, werd mir das überlegen, denke aber nicht das ich
> sowas brauche. Bei mir werden Server ohne Monitore betrieben ;)

Bei mir auch. Hin und wieder braucht man aber auch mal ein Bild  :)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.