mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATtiny 2313 mit AVRISP mkII


Autor: bjnass (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Habe hier einen frischen Attiny 2313, er lässt sich nicht programmieren 
über AVRISP mkII. Hab es auch schon mit externen Takt über XTAL1 
versucht.

Nun die Frage, kann es vorkommen das defekte Atmega ausgeliefert werden 
oder werden die im Werk geprüft.

Habe das Teil das erste Mal auf dem Brett.

Gruss bjn

Autor: Michael B. (planlessmichi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

also ich habe - u.a. genau diese Kombination - schon zig-Mal benutzt und 
keine Probleme gehabt. Vielleicht postest Du mal ein paar Infos (Foto 
vom Aufbau; Schaltplan; welche SW benutzt Du und und und). Dann könnte 
man mehr helfen. Generell ist es "natürlich" möglich, dass so ein Ding 
kaputt ist, aber ein 6er im Lotto zu haben und das Woche für Woche bei 
der gleichen Person ist "natürlich" auch möglich :-)
O.k., ich will jetzt nicht so klingen wie viele Autoren hier, die lieber 
schimpfen, als zu helfen, aber bisschen mehr Info wäre schön :-) Hast Du 
"Probleme" mit dem mkII (2313 anders schon mal programmiert)? Ist der 
neu? Hast Du damit schon andere MC programmiert? Welche LEDs leuchten 
bei dem Teil? Gibt es (Fehler-)Meldungen?.....

Viel Erfolg,
Michael

Autor: bjnass (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo und Danke für die schnelle Antwort

Den Attiny steckt im Brett mit VCC  GND  RESET mit 10k Ohm an VCC und 
natürlich SCK/MISO/MOSI gemäss Datenblatt.

Der Programmer ist ein USB AVR-Lab mit dem AVRISP mkII drauf.

Bis jetzt nur Atmegas8 dran ohne Probleme.

Die Leds leuchten normal wie sonst. Blau und Grün.

Geflasht wird über das AVR Studio. Der gibt mir einen ISP Mode Error.

Autor: H.Ratlos (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und welchen Fehler? Wie sagte Didi Hallervorden immer? "Details! 
Details! Ich brauche mehr Details!" :-)

Autor: Michael B. (planlessmichi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Grins :-) Ja, Details, Details... Schöner Film. "Der Doppelgänger", 
gelle?
Aber zurück zum Problem. Also blau und grün irriterit mich jetzt. Ich 
habe die rot und grün (bzw. in Kombi orange) im Kopf... Blau hat da bei 
mir - glaube ich fest - noch nie was geleuchtet. Reden wir von dem 
gleichen Teil?

Aber wenn ein Atmega8 ging... Ist das verwendete ISP-Kabel hier 
vielleicht länger als beim ATmega8? Ich gehe davon jetzt einfach mal 
aus, weil's vermutlich eh logisch ist, aber Du hast sicherlich keinen 
anderen 2313, oder?

Autor: bjnass (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nur diesen "ISP Mode Error"

Und im Ausgabefeld unten "Entering programming mode.. FAILED!" Alle 
anderen OK.

Das hatte ich auch schon bei einem verfusten Atmega8, aber beim Attiny 
wurde nichts verfust.

Autor: bjnass (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Leider hab ich keinen anderen, sonst hätt's ich schon versucht.

ISP Kabel ist dasselbe (man kann umstecken).

Mein Programmer leuchtet blau für USB OK.
und grün für Mikrocontroller OK.
Nur beim Flashen ein bisschen Rouge.

Autor: bjnass (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi und Juhee

Hab den Fehler gefunden. Hatte ein Beitrag gelesen wo der 
Auslieferzustand erwähnt wird. 8 Mhz und CKDIV8. Also Takt geteilt durch 
8 sind 1 Mhz.

Bei meiner Unkenntnis habe ich die ISP Frequenz auf 1 MHZ gestellt, also 
weniger als ein 1/4 Takt des Prozessor.

Richtig ist 250 MHz bei 1 Mhz dann hat's funktioniert. Wenn der CKDIV8 
deaktiviert wird kann die ISP Frequenz wieder höher sein.

Danke an Alle.

mfg bjn

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.