mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Motorenansteuerung


Autor: Tim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe ein riesen Problem. Ich habe bei einem Atmel (at89c5131) über 4
einzelne Portausgänge versucht, vier Motoren anzusteuern. Die
Ansteuerung erfolgt durch PulsweitenModulation. Hinter dem Port ist ein
BCY59 mit zusätzlichem PullUp (10kOhm). Am Collector des BCY59 ist eine
Lasttransistorstufe (IPS021) und ein Pullup von ebenfalls 10kOhm an
VCC. An diesem IPS021 hangt der Motor.

Wie kann ich verhindern, dass die Motoren die Schaltung so
beeinflussen, dass die Schaltung ständig resettet oder macnhmal sogar
stehen bleibt? Ich messe an den Ports keinerlei Spannungsspitzen oder
was anderes. Bin ratlos!

Tausche ich die Motoren mit Widerständen klappt es wunderbar.

Danke für Eure Hilfe!!

Autor: Tobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
überall kondensatoren an den versorgungspins?

Autor: Tobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
und freilaufdioden?

Autor: Tim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Freilaufdioden sind vorhanden. Sogar mehrere! Kondensatoren auch ein
paar.
Der IPS021 sollte laut Datenblatt auch Rückspannungen verhindern. Aber
irgendwie geht es nicht.

Autor: Patric (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du eine getrennte Versorgung für die Motoren und die Steuerung?

Autor: Winfried (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Herzlich Willkommen im Club der Leistungselektroniker! Jetzt bist du mit
all den Problemen konfrontiert, die Leistungselektronik so an sich hat.
Ein Thema, wo selbst Experten nach 10 Jahren Beschäftigung damit noch
nicht ausgelernt haben.

So pauschal kann man bei diesem Thema wirklich nicht weiterhelfen. Da
gilt es, erstmal viel Grundlagen zu studieren. EMV-gerechtes
Gerätedesign, richtige Masseführung, gute Trennung zwischen Signal und
Leistung, Stützkondensatoren/Spulen an den richtigen Stellen,
Freilaufdioden, Abschirmung, Grundlagen von magnetischen und
elektrischen Feldern usw.

Problem ist einfach, dass bei großen Strömen große Felder entstehen,
die beim Schalten auch noch hohe Frequenzen aufweisen, die sich dann
sehr gut  überall einkoppeln. Und wo große Ströme fließen ist bei
entsprechenden Frequenzen ein Stück Kupferleiterbahn sehr hochohmig.

Mein konkreter Vorschlag: Schau dir mal deine Masseführung an. Masse
der Leistung und der Signalelektronik muss sauber getrennt und an einem
Sternpunkt zusamemngeführt werden.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.