mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Suche nach CML-IC CMX469A


Autor: Uwe Neubert (Firma: Privat) (djuwert)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi! Ich suche schon lang nach einem bestimmten Baustein, kann ihn 
nirgends zum Kauf finden. Es handelt sich um ein FFSK-Modem und heisst 
CMX469A. Dies ist der Nachfolger des FX439. Beide kommen vom Hersteller 
CML mit der Page www.cmlmikro.com. Dort gibt es die Obsoleteliste, in 
der der 469A als Austauschtyp steht. Wo kann man dieses Teil denn nuin 
kaufen?
Google spuckt nur Datasheets aus. Hat jemand ne Ahnung?

Gruss, uwe!

Autor: Thi Lo (flothi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich schließe mich meinem Vorredner an, ich suche auch schon die ganze 
Zeit nach nem Händler.

VG

Florian

Autor: Steffen H. (mc_sho)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja, das Problem hatte ich auch bei der Beschaffung meiner CMX869B und 
MX614P. Ich habe auch keinen Shop gefunden, der die Dinger hatte. Ich 
habe dann die Teile über meine Firma direkt bei:

http://www.spezial.de/index.php

bestellt. Vielleicht könnt Ihr auch über eure Firma (AG) bestellen ?

Autor: Neubert Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe meine 469 nun auch dort bestellt, aber ich komme technisch nicht 
mit ihnen klar. Wie ticken die Teile? Bekomme kein Signal raus :-)

Autor: Abdul K. (ehydra) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gar kein Signal geht kaum. Was geht denn nicht? Versuche mal einen 
Loopback.

Autor: Uwe Neubert (Firma: Privat) (djuwert)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Loopback??? :-)  Also, ich meine mit "kein Signal", dass ich das zu 
demodulierende NF-Signal anlege, daraufhin geht die angschlossene 
Detect-Led an. Jedoch spuckt mir der IC am Ausgang mit 4800baud, nur 
00000000 aus. Ich hatte die Kiste so verstanden, dass das demodulierte 
Signal in welcher auch immer- Form über den Ausgang des ICs seriell 
ausgegeben wird. Die 4800baud ergeben sich aus dem Quarz und er 
Einstellung der Pins nach Datenblatt.Da ich die SMD-Variante des IC 
verwende liegen die Pins jeweils anders als zu der DIL-Variante. Die ist 
aber recht genau über das Datenblatt gemacht worden.

Nochmals zum Verständnis: Ich versuche damit ein FMS-Protokoll aus einem 
4m-Band BOS-Funk zu erkennen.Der Vorgängertyp wurde in einem sehr alten 
Projekt dazu eingesetzt (FX439L) und damit ging das wohl:-)

Autor: Abdul K. (ehydra) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Loopback???" klingt nach absolut keine Ahnung. Sorry. Googeln würde 
helfen. Das ist absolute Grundlage in Sachen Datenkommunikation.

Deine Fehlerbeschreibung klingt nach 'Selber vor Ort' nachschauen. Wird 
schwierig dir so zu helfen.

Bist du dir sicher das der 439 und der 469 beide die gewünschte 
Modulation überhaupt verstehen?

Vielleicht kommst du mit dem Scope an den analogen Teil des Demodulators 
ran. Für genaueres müßte ich mir auch erstmal das Datenblatt genau 
ansehen. Letztendlich würde ich erstmal nach schnöden Fehlern suchen. 
Die exakte Taktfrequenz ist der erste Kandidat. Quarz ist nicht gleich 
Quarz. Vielleicht sendet das andere Gerät auch nicht ganz normgerecht.

Kopf hoch!

Autor: Uwe Neubert (Firma: Privat) (djuwert)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wegen dem Loopback, ich habe mich bisher recht wenig mit Datenkom 
befasst, eher mit uC der Atmel-Familie. Der 469 ist in der Obsoleteliste 
als genau der Nachfolger des FFSK-Modems angegeben. ich verwende zum 
Testen eine Software zur Ausgabe von Statussendungen. Eventuell liegt 
schon da der Fehler. Zum Quarz: Ich habe ganau diesen schiefen Quarz mit 
4,032Mhz verwendet und ihn mit 33pF belastet. So stand es auch im 
Datenblatt.

Währe schön wenn jemand auch Erfahrungen mit dem Bauteil sammelt und mir 
helfen könnte.Ich kann auchmal nen Schaltplan zeichnen, nur um zu sehen 
ob ich denn die Attribute richtig gesetzt hab. Unter "High" sind doch 
immer 5V gemeint und unter "Low" Masse. Naja, mal sehen... Gruss, uwe!

Autor: Abdul K. (ehydra) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn du das Sammeln der Erfahrungen mit einem ganz spezifischen IC 
bezahlst, dann wird sich sicher jemand finden. Ansonsten ist sowas aber 
eher unwahrscheinlich. Ist nicht gerade ein sehr bekannter 
Hersteller/IC.

Messe als erstes die Quarzfrequenz und zwar nicht am Quarz. Eventuell 
schwingt das Teil bereits auf seiner 3. Oberwelle...

Ja, im Allgemeinen ist 'positive Logik' heutzutage gängig. Dann stimmen 
deine Angaben.

Ich kann dir das Teil zum Laufen bringen. Allerdings nicht kostenlos.

Autor: Uwe Neubert (Firma: Privat) (djuwert)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe eben gemerkt, dass ich den falschen Ausgang belauscht habe, es 
muss der serielle Ausgang an Pin 11 (unclocked) bzw mit Clock an Pin 12 
genutzt werden. Weiterhin verwende ich zum Testen einen Pegelwandler zum 
Rechner. An dieser Stelle zeigt nun H-Term eine nachvollziehbare 
Zeichenfolge, soll heissen es ist reproduzierbar. Wohin der Pin "rx 
enebale" hingehört ist noch schleierhaft. Hab ihn an 5V gehangen und 
schätze er ist als direkte Enable gedacht, ob demoduliert werden soll 
oder nicht. >>> Es steht dazu nichts im Datenblatt ?!

Danke für das Hilfsangebot, jedoch meinte ich das eher an Leute die 
denselben IC verwenden möchten und das Projekt mit begleiten. Als 
Erfahrungsaustausch, nicht komerziell.

Gruss, Uwe!

Autor: Abdul K. (ehydra) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
An der überwältigenden Anzahl von Kommentaren siehst du schon wieviele 
Leute mit diesen Chips arbeiten ;-)

Naja, diese Firma tut ja auch alles dafür das die Leute angewidert sich 
woanders umsehen. Nicht mal ein Datenblatt gibts ohne Registrierung zu 
sehen.


Doch, zu RX_Enable steht im Kapitel 1.5 General Description schon, daß 
er den Empfänger aktiviert und was er sonst so macht, und auch welcher 
Pegel notwendig ist. Muß auf HIGH.


Ich bin ja für meine Meckerei bekannt, aber dieses Datenblatt ist 
ordentlich. Sogar die Bitfehlerrate-Kurve ist angegeben.


Gruß -
Abdul

Autor: Uwe Neubert (Firma: Privat) (djuwert)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh, dann muss ich nochmal genauer hinschauen ins Datenblatt. Dieses gabs 
auch ganz ohne Reg. beim googeln :-)
Danke soweit! Ich schreib weiter über die Fortschritte. Gruss, Uwe!

Autor: Abdul K. (ehydra) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Womöglich war das bereits dein Fehler??

Autor: Uwe Neubert (Firma: Privat) (djuwert)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Genau, nicht genau gelesen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.