mikrocontroller.net

Forum: PC Hard- und Software [WLAN] Keine Verbindung wenn Sicherheit aktiviert


Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe bei mir im Wohnzimmer einen Wlan-Router installiert, das sich 
ebenfallls im Wohnzimmer befindliche Laptop kann darüber eine drahtlose 
Internetverbindung herstellen.
Anders sieht es bei dem Computer im Nebenraum aus: Egal, ob WEP, WPA 
oder WPA2 ich erhalte keine Verbindung. Das höchste der Gefühle ist die 
Meldung "Netzwerkadresse beziehen", dann bricht die Verbindung ab, wird 
versucht wieder aufzubauen usw.
Sobald ich aber keinerlei Sicherheitsoption im Router konfiguriere, 
erhalte ich problemlos eine Verbindung mit besagtem Rechner.
In der Umgebung (Nachbarn usw.) gibt es noch mehrere WLANs, da aber ohne 
Sicherheit eine Verbindung aufgebaut wird, schließe ich diese als 
Ursache aus.

Was läuft denn hier falsch ?

Autor: Oliver Stellebaum (phetty)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht der Netzwerkschlüssel?
Manche router interpretieren das nicht als Passwort sondern als 
HEX-Code.

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
MAC-Filter aktiv?

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab jetzt mal WPA-PSK mit aktiviert mit der Zeichenfolge "00000000" als 
Passwort, sollte ja dezimal wie hex dasselbe herauskommen. Versuch war 
leider erfolglos, keine Änderung zum bisherigen Verhalten.

Ja, Mac-Filter ist aktiv, aber die Karte vom Rechner im Nebenraum ist 
mit aufgeführt. Ansonsten würde ich auch ohne Sicherheitsaktivierung 
keinen Zugang erhalten, sondern der Router würde mich rausschmeißen.

Autor: spacedog (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"00000000" ist hexadezimal 30 30 30 30 30 30 30 30.

Autor: Icke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welches Betriebssystem? Welche WLAN-Hardware? Welcher Router?

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> "00000000" ist hexadezimal 30 30 30 30 30 30 30 30.
?? Wie dem auch sei, im Konfigurationsprogramm des Routers gebe ich als 
Kennwort "12345Berlin" ein (also meine PLZ+Stadt). Bei Verbindungsaufbau 
mit dem Laptop fragt mich dieser nach dem Kennwort und ich gebe es wie 
gehabt ein und es wird dangenommen. Beim anderen Computer funktioniert 
das so nicht.

> Welches Betriebssystem? Welche WLAN-Hardware? Welcher Router?
Win Xp mit SP3, Router von Netgear, WLAN-Karte im Rechner von MSI, 
WLAN-Karte im Laptop keine Ahnung. Genaue Bezeichnungen muß ich heute 
abend heraussuchen.

Vielen Dank schonmal für die Ratschläge !

Autor: Icke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich meinte eigentlich die genauen Typenbezeichnungen. "Router von 
Netgear" ist ungefähr wie "Auto von VW".
Apropos Netgear, deren WLAN-Router habe ich vor Jahren komplett von der 
Einkaufsliste gestrichen. Unter anderem auch wegen genau solcher 
Probleme. Aus nicht nachvollziehbaren Gründen bekamen einige WLAN-Geräte 
keine IP-Adresse zugeteilt. Die Probleme können natürlich auch an 
anderer Stelle liegen. Versuche es als erstes mal mit einer festen 
IP-Adresse auf dem WLAN-Adapter.

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist bei der WLAN-Karte im Rechner nur deren Treiber installiert oder 
auch noch zusätzlicher WLAN-Krempel? Falls ja, entferne den, denn der 
ist unnötig. XP hat seit SP1 oder SP2 einen eigenen WLAN-Assistenten, 
der ausreichend gut und zuverlässig funktioniert - Selbstbaulösungen der 
Kartenhersteller sind seitdem entbehrlich bzw. oft sogar Störquellen.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Computer im Nebenraum
-älterer Softwarestand ? als XP SP2 j/n
-andere Störer auf gleichem Kanal ??

Stell mal den Router direkt neben den Kummer-PC um herauszufinden ob es 
ein Software- oder Empfangsproblem sein könnte.

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, wieder mal ein Konfigurationsproblem gelöst... ;-)

Vorweg:
Router ist Netgear WGR614GR
WLAN-Karte im Laptop ist Atheros AR928x
WLAN-Karte im Rechner ist MSI PC54G2 (von Anfang 2004!)

Rufus hatte recht, wenn ich nur den reinen Treiber ohne die 
Zusatzsoftware von MSI installiere funktioniert es. Da der Treiber aus 
dem Jahr 2004, und somit aus der Anfangszeit von WPA, stammt, habe ich 
den aktuellen Treiber von der MSI-Homepage runtergeladen und installiert 
(naja, auch der ist von Mitte 2006). Damit funktioniert sogar WPA2 !
Im Netz fand ich zudem den Lösungsvorschlag den Treiber des 
Chipherstellers zu installieren, findet sich auf 
http://web.ralinktech.com/ralink/Home/Support/Windows.html

Das Router von Netgear einen schlechten Ruf haben, wußte ich nicht; 
hatte mich an den Bewertungen bei amazon.de orientiert, dort steht er in 
der Käufergunst ganz oben.

Vielen Dank nochmal für die Ratschläge!

Autor: Icke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Das Router von Netgear einen schlechten Ruf haben, wußte ich nicht;
>hatte mich an den Bewertungen bei amazon.de orientiert, dort steht er in
>der Käufergunst ganz oben.

Bewertungen, wo auch immer, muß man mit gewissem Abstand betrachten. 90% 
der "Tester" sind zu objektiven Aussagen gar nicht qualifiziert, weil 
sie nur alle paar Jahre mal EIN Gerät kaufen. Wenn das dann nur 
irgendwie funktioniert, egal wie gut oder schlecht, und vor allem 
obendrein noch BILLIG war, dann ist es "guuuuut". Aufgrund fehlender 
Vergleichsmöglichkeiten können die Leute gar nicht beurteilen, welche 
Qualität das Teil besitzt. Und nicht zuletzt würden 90% der 90% 
keinesfalls einen Fehlkauf eingestehen, sondern trotz aller Mängel bis 
aufs Messer verteidigen.
Wenn ich Bewertungen lese, dann such ich gezielt vor allem solche, wo 
Mängel beschrieben werden. Sind diese Mängel sachlich begründet, dann 
hat das um Größenordnungen höhere Aussagekraft als 100 Lobgesänge.

Ob Netgear nun einen schlechten Ruf hat, weiß ich nicht. Das waren 
einfach meine persönlichen Erfahrungen. Jede Technik hat irgendwelche 
Fehler, das läßt sich kaum vermeiden. Bei den Netgear-Routern nahmen die 
Probleme jedoch überhand und ließen sich mit keiner Maßnahme beseitigen. 
Kann durchaus sein, das sich der Zustand inzwischen gebessert hat, aber 
"ist der Ruf erst ruiniert..."

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Bewertungen, wo auch immer, muß man mit gewissem Abstand betrachten. 90%
> der "Tester" sind zu objektiven Aussagen gar nicht qualifiziert,
Das stimmt schon, aber wonach soll man sich richten ? Bewertungen von 
Laien wie bei amazon sind fraglich, andererseits werden 10 
professionelle PC-Magazine bei Test und Bewertung ein- und desselben 
Gerätes zu 10 verschiedenen Urteilen kommen... Das ist wie beim 
Zahnarzt, wenn Du da 10 verschiedene Ärzte aufsuchst, werden Dir 10 
unterschiedliche Behandlungsmethoden empfohlen :-(


> Wenn ich Bewertungen lese, dann such ich gezielt vor allem solche, wo
> Mängel beschrieben werden.
Ja, interesant ist zu lesen, was zwischen den Zeilen steht. Außerdem der 
Vergleich der Kommentare zwischen mehreren Produkten.

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Druckerzeugnisse, in denen Tests abgedruckt werden, unterscheiden 
sich in ihrer Qualität. Das aus der norddeutschen Triefebene stammendes 
Zentralorgan hat vor einigen Jahren bei WLAN-Routern deren 
DNS-Unterstützung untersucht und festgestellt, daß die bei komplexen 
Anfragen, wie sie z.B. bei der Nutzung von eBay auftreten, zu Fehlern 
führen können.

> Das DNS-Drama
>
> Was ein Router-Programmierer alles falsch machen kann, zeigt
> sich am scheinbar einfachen DNS-Relay, das inzwischen in fast
> allen Routern steckt. Es soll die DNS-Anfragen der PCs entgegen-
> nehmen, an den DNS-Server des Providers weiterleiten und die
> Antworten zurückreichen. So braucht kein Client die gelegentlich
> wechselnde Adresse des Provider-DNS-Servers zu kennen, was den
> Wartungsaufwand bei den LAN-PCs verringert.
>
> Fehler im DNS-Relay führen zu kuriosen Problemen: So stürzen manche
> Router beim Ansteuern bestimmter eBay-Seiten ab. Das liegt am dort
> verwendeten Kundenbeobachtungssystem, das nicht wie sonst üblich
> Cookies benutzt, sondern die Kundendaten in DNS-Anfragen verschlüsselt.
> Es fragt dabei Namen ab, in denen einige Labels - die durch Punkte
> getrennten Namensbestandteile - bis zu 63 Zeichen lang sind. Das
> entspricht zwar dem DNS-Standard von 1987 (RFC 1034), aber nicht der
> Erwartung mancher Router-Programmierer im Jahr 2004, die weniger
> Speicherplatz für Labels vorsehen - die Folge: Buffer Overflow und
> Router-Crash.
>
> (...)
>
> Von den 19 Geräten im Test warten nur acht mit einem
> einwandfreien DNS-Relay auf.

(c't 23/2004)


Sicher, das ist ein alter Test, aber schon ein Zeichen dafür, daß 
zumindest vor fünf Jahren in der Triefebene nicht nur Hochglanzprospekte 
gewälzt wurden.

Autor: Icke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Das stimmt schon, aber wonach soll man sich richten ? Bewertungen von
>Laien wie bei amazon sind fraglich, andererseits werden 10
>professionelle PC-Magazine bei Test und Bewertung ein- und desselben
>Gerätes zu 10 verschiedenen Urteilen kommen...
Ja, das ist wirklich ein Disaster. Den Tests in Zeitschriften vertraue 
ich schon gar nicht, denn deren Objektivität ist m.E. fragwürdig, da sie 
hauptsächlich von Werbung leben. Und wer beißt schon die Hand, die einen 
füttert. Einzig die c't testet noch nach halbwegs praxisnahen Aspekten, 
aber auch dort stimmen die Ergebnisse nicht immer mit meinen praktischen 
Erfahrungen überein.
Für Leute, die nicht in der Materie stecken, ist die 
Entscheidungsfindung natürlich noch sehr viel schwieriger. Wie schon 
gesagt, am besten orientiert man sich an Negativaussagen, aber nur dann, 
wenn diese auch sachlich und nachvollziehbar begründet sind.

Autor: Icke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>> Von den 19 Geräten im Test warten nur acht mit einem
>> einwandfreien DNS-Relay auf.
Und das war vermutlich ein LANCOM.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.