mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik MOC3041 + TIC246M


Autor: Ephraim Hahn (ephi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich möchte mir einen 230V switch auf basis eines TRIACs bauen.
Nach einiger Suche habe ich auch ein paar passende Bauteile gefunden.

Ich habe nun eine Schaltung mit dem MOC3041 und dem TIC246M aufgebaut. 
Es ist exakt die selbe schaltung, die im Datenblatt des MOC3041 auf 
seite 4 oben beschrieben ist. 
(http://www.datasheetcatalog.com/datasheets_pdf/M/O...)

Ich bin im Umgang mit 230V~ ein wenig vorsichtig, und habe alles auf ein 
Holzbrett mit plexiglashaube berührungssicher verschraubt. Als Last 
hängt testweise eine normale 40W Osram glühbirne dran (Die letzte die 
ich im Keller finden konnte ;)).

Das problem ist nun, das der TRIAC immer zu zünden scheint (Lampe 
leuchtet immer) egal was für ein Pegel am MOC3041 anliegt. Ich dachte 
erst, im eifer des Gefächts hätte ich irgendeine Lötbrücke oderso, also 
habe ich alles nochmal stück für stück aufgebaut und getestet. Das RC 
Glied zur Filterung bei induktiven Lasten aus den 39 ohm und 10nF ist 
ok, der triac ohne ansteuerung zündet auch nicht. Aber sobald ich die 
330ohm zwischen Zündung und N Leiter anschließe zündet er (was ja auch 
irgendwie logisch ist, wenn dann Spannung an der Zündung anliegt). Mir 
ist deshalb auch der Sinn dieses Widerstands etwas schleierhaft, kann 
ich den einfach weglassen?

Sorry wenn ich irgendwas grundlegendes übersehen habe, aber ich bin mit 
Triacs und Netzspannung noch nicht ganz so vertraut.

Gruß

Autor: Sascha Weber (sascha-w)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

du hast sicherlich die beiden Anoden des Triac vertauscht.

Sascha

Autor: Ephraim Hahn (ephi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tatsächlich, daran lags. Jetzt tut alles wie es soll.
Ich wusste nicht, das deren Polung relevant ist, außerdem war im 
schaltplan nicht ganz ersichtlich welche wohin kommt (oder ist die 
gegenüber der Zündung immer A1?).

Danke Dir!
Gruß

Autor: Sascha Weber (sascha-w)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
naja die Bezeichnung ...

zum Zünden muss das Gate auf alle Fälle mit dem gegenüberliegendem 
Anschluss (im Schaltbild) verbunden werden. In den Datenblättern von 
Triacs die ich gerade hier habe ist das immer der Anschluß 2 (A2, MT2, 
T2).

Sascha

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.