mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik 485 mehrere zuhörer


Autor: jamest (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
moin,
ich habe folgendes Problem und hoffe mir kann jemand helfen...
ich habe vom PC aus eine RS485 Verbindung, welche an 2 Mikrocontroller 
nen String sendet. RS485 geht also auf nen 485-TTL Pegelwandler 
(75LBC173A).
Der Pegelwandler hat 4 Kanäle, also leg ich das signal auf 2 eingänge. 
Von dort aus gehts dann gesondert zu menien µCs (Atmel At90can128 auf 
DEVK90CAN1 Board).

Nun wird aber plötzlich der gesendete String nicht mehr richtig 
übertragen. Mit einem einzigen Mikrocontroller hat es immer normal 
geklappt aber nun gehen merkwürdigerweise ständig lange Stücke des 
Strings einfach verloren. Das ganze ist Simplex, also PC sendet nur und 
µCs empfangen. Hab ich irgendwas falsch gemacht? Kann das so evtl gar 
nicht gehen?

Autor: Zorc (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich wuerd mal die Signalformen mit einem Scope nachmessen.

Autor: bkd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
wie lange sind deine Leitungen? Endwidestand?

grüße
BK

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.