mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik TOP2049 kann keine EPROMs brennen


Autor: Ingolf O. (headshotzombie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein hier über das Forum erworbenes neuwertiges Multiprogrammiergerät vom 
Typ TOP2049 wollte ich dieser Tage erstmalig zum Brennen einiger 2764 
nutzen, was sich allerdings als unmöglich herausstellte.
Der Blank-Test erfolgte, aber bei der Adr. 0183 war Schluß mit dem 
Brennen, der TOP hing fest.
Die ca. 400 geschriebenen Bytes sind eigentlich mit dem Originaldump 
identisch.
In der Folge genutzte andere 2764, aber auch 27128 und 27256 werden 
genauso mit Missachtung gestraft. Die selben EPROMs funzen aber 
anstandslos auf einem Prommer anderer Bauart.
Die Vpp bei gestecktem EPROM gemessen, betrug die gefoderten 12,5V.

Das war die Stelle, wo ich mich dann zur Hilfesuche entschloß!

Hat jemand Lösungsansätze für mich, womit es mir u.U. gelingt, eine 
Funktion wieder herzustellen und wenn ja, welche? ;-)

Autor: Thomas R. (tinman) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Neueste software installiert und rebooted ?
Was sagt self-test ?
Netzteil benutzt oder nur über USB versorgt ?
Sind es wirklich 12.5V typen ?

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Thomas R. schrieb:
> Sind es wirklich 12.5V typen ?

Nur die 27Cxx Typen und der 27512 sind meinee Erinnerung nach sicher 
12,5V Typen.
Beim 27256 gab es nur wenige Hersteller mit 21V Typen (Intel?), beim 
27128 viele und ob es den 2764 überhaupt als 12,5V Typ gab, weiß ich 
nicht mehr.

PS: Ach ja, die schöne C64-Zeit und die EPROM-Karten, um die wichtigen 
Programme auch schnell zu starten...

Gruß aus Berlin
Michael

Autor: Ingolf O. (headshotzombie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also, Thomas, zu Deinen Anschüben:
- Ja, externes NT bringt keine Änderung des Problems
- Neueste SW-Version, in diesem Fall v6.20, ist installiert.
- Selbsttest? Muss ich nochmal in die Tiefen des Menüs abtauchen...
- Ja, da die gleichen EPROMS auf einem Zweitgerät anderer Bauart auch 
korrekt programmiert werden - es sind A-Typen!
- Testweise an einem anderen PC den TOP drangehangen, ergab identische 
Reaktion.

Autor: Ingolf O. (headshotzombie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, der self test im TopWin v6.20 bringt:
The programmer allright test!

Diese Aussage muß ich allerdings stark in Zweifel ziehen.

Autor: Thomas R. (tinman) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ingolf O. schrieb:
> So, der self test im TopWin v6.20 bringt:
> The programmer allright test!
>
> Diese Aussage muß ich allerdings stark in Zweifel ziehen.

der selftest beim top2049 ist eigentlich gut genug um kontakt / hardware 
fehler zu erkennen.

Bid jetzt hatte nur probleme mit M5Mxxxx (oder MBMxxxx?) eproms, alls 
andere ging sobald die spannug und typ gestimmt hat.

Du kanst natürlich was anderes proggen (atmega / sram ), auch wenn der 
selftest gut ist, bedeutet nicht das es 100% alle eigene bauteile prüft.

Autor: Ingolf O. (headshotzombie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas R. schrieb:
> der selftest beim top2049 ist eigentlich gut genug um kontakt / hardware
> fehler zu erkennen.

Na ja, die Praxis vor Ort, läßt da aber deutlich andere Schlüsse zu.
Zumal ich einen self test ohne gestecktem Referenzbauteil, also 
praktisch ins Leere gehend, doch nicht allzu ernst nehmen kann.

Autor: Michael Buesch (mb_)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ingolf O. schrieb:
> Ein hier über das Forum erworbenes neuwertiges Multiprogrammiergerät vom
> Typ TOP2049 wollte ich dieser Tage erstmalig zum Brennen einiger 2764

> Die Vpp bei gestecktem EPROM gemessen, betrug die gefoderten 12,5V.

Welcher EEPROM Hersteller ist es denn? Ich finde beispielsweise einen 
2764 EEPROM von NEC, der 21Vpp braucht.

Autor: Ingolf O. (headshotzombie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Michael,
lass mal das Problem, dass es an den EPROMs liegt beiseite.
Erstens habe ich definitiv den korrekten Typ aus der Devicelist 
ausgewählt und Zweites ließen sich ja alle EPROMS, die im TOP2049 nicht 
zu brennen gingen, auf einem völlig anderen Prommer programmieren - bei 
ebenfalls 12,5V Vpp.

Autor: Michael Buesch (mb_)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ingolf O. schrieb:
> Hallo Michael,
> lass mal das Problem, dass es an den EPROMs liegt beiseite.
> Erstens habe ich definitiv den korrekten Typ aus der Devicelist
> ausgewählt und Zweites ließen sich ja alle EPROMS, die im TOP2049 nicht
> zu brennen gingen, auf einem völlig anderen Prommer programmieren - bei
> ebenfalls 12,5V Vpp.

Naja, es ging mir eher darum herauszufinden welchen EPROM du genau 
verwendest um selbst das Original Datenblatt durchzulesen. ;)

Ich bin ganz einfach der Meinung, dass es ein Topwin Softwareproblem 
ist. Ich habe auch einen Mikrocontroller, der zwar als unterstützt 
gelistet ist, aber trotzdem nicht funktioniert. Es ist ziemlich sicher 
ein Softwareproblem.

Derzeit bin ich dran den TOP2049 auseinanderzunehmen und eine opensource 
software zu schreiben. 
http://bu3sch.de/joomla/index.php/toprammer-top2049
Ein EPROM hört sich jetzt prinzipiell nicht besonders kompliziert an und 
es sollte machbar sein den Programmieralgorithmus in angemessener Zeit 
neu und korrekt zu implementieren.

Autor: Ingolf O. (headshotzombie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Info zum opensource-Projekt hört sich ja gut an, zumal die Software 
chinesischen Ursprungs äußerst mangelhaft ist, da sie eine Vielzahl 
oberflächlicher Fehler enthält. Wie tief die reichen, keine Ahnung!
Ich werde mal morgen die genauen Typbezeichnungen der EPROMs hier 
reinschreiben, allerdings will mir momentan so gar nicht in den Kopf, 
dass Allerwelts-EPROMS älteren Ursprungs heutzutage noch Probleme 
bereiten sollten...

Autor: Thomas R. (tinman) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ingolf O. schrieb:

> Na ja, die Praxis vor Ort, läßt da aber deutlich andere Schlüsse zu.
> Zumal ich einen self test ohne gestecktem Referenzbauteil, also
> praktisch ins Leere gehend, doch nicht allzu ernst nehmen kann.

Ingolf,

es geht auch ohne "Referenzbauteil", aber zurück zum thema.

Die software ist nciht der hit, funktioniert aber - mindestens solange 
Jungo Windriver nicht spinnt. Ich muss immer umschalten zwischen den 
drivern, da ich leider zu viele geräte habe die lustigerweise immer 
unterschiedliche Windriver versionen brauchen (mögliche fehlerquelle bei 
dir?).

Du kannst im Config fenster die delay vergroessern, hilft beim älteren 
bausteinen - die sind manchmal etwas "zäh". Ich musste einge mal 
"überbraten" - also 3-4 mal den selben buffer reinprogrammieren, ohne 
blank check natürlich, damit alle bits am ende passen.

Die selben eproms gingen gar nciht im Batronix Barlino, und eigentlich 
durch die sehr genaue auflistung/unterstüzung der bauteiletypen sollte 
der Batronix funktionieren.

Du hast den top2049 von jemande hier im Forum gekauft, ehm, sicher das 
der vorhin ging? Hast du andere bausteine schon getestet ? (um den 
fehler einzugrenzen).

Autor: Ingolf O. (headshotzombie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Thomas,
speziell Deine Aussage zum Jungo kann ich als in der Tat problembehaftet 
bestätigen. Ich konnte auch nicht die drei TopWin-Versionen v3.xx, v5.xx 
und v6.20 parallel installieren und nutzen, und da habe ich mich 
letztendlich für die neueste entschieden. Ansonsten gab´s einen 
Bluescreen mit windrv6.sys-Fehlermeldung.

Den Tipp mit dem delay werde ich aufgreifen und auspobieren.

Beim Kauf (der Deal ist sicher noch nachzulesen!) des TOP2049 bin ich 
gemäß der Beschreibung natürlich von einem vollfunktionsfähigen Gerät 
ausgegangen!
Will allerdings auch nicht so recht glauben, dass dieses Problem 
Auslöser des Verkaufes war.

Werde einen 3. Versuch starten und den TOP an einem NB mit XP betreiben, 
wo ich mal die Erstinstallation mit der TopWin v5.xx vornehme.
Dann werde ich mal paar EEPROMs und Flash-ICs suchen und testen.

Las eben Deine Verkaufsofferte und das Du den TOP3100 vorliegen hast. 
Dazu gleich mal die Frage, stammt der aus dem mir gen. Ebay-Shop und was 
hast Du an Zoll bzw. überhaupt hinlegen müssen? Kannst auch per PN 
wieder antworten! ;-)

@Michael Buesch
Die gescheiterten Brennversuche wurde mit nachfolgenden ICs vorgenommen:
- M2764AFI von ST / 3 Stück
- M2764AFI von SGS / 1 Stück
- TMS2764-25JL von TI / 2 Stück
- D2764A von Intel / 2 Stück
- Am2764ADC 1 Stück
- M27128AFI von ST / 2 Stück
- M27256FI von ST / 2 Stück

Autor: Ingolf O. (headshotzombie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag:
Meine aktuelle Testkombination (TOP2049 am NB unter XP und TopWin v5.93)
hat prinzipiell keine Änderung des Problems gebracht!
Allerdings ist mir ein Zusammenhang zwischen Delay und Anzahl 
programmierter Bytes aufgefallen - je kürzer das Delay, um so mehr Bytes 
werden gebrannt.
Bei 1ms brennt er bis ca. 0400, bei 10ms 006C.
Da die Vpp aber nicht zusammenbricht, könnte das u.U. ein therm. Problem 
sein?

Autor: Thomas R. (tinman) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ingolf O. schrieb:
>
> Las eben Deine Verkaufsofferte und das Du den TOP3100 vorliegen hast.
> Dazu gleich mal die Frage, stammt der aus dem mir gen. Ebay-Shop und was
> hast Du an Zoll bzw. überhaupt hinlegen müssen?

nur Einfuhrumsatzsteuer 19%

> @Michael Buesch
> Die gescheiterten Brennversuche wurde mit nachfolgenden ICs vorgenommen:

M27643FI
M27128AFI
NMC27C64Q
U2716-C35 (die sind wirklich alt, ceramic mit gold pins)

die habe gerade getestet mit dem top2049 und wie schon gesagt, keine 
probleme gehabt (mit standard delay settings).

Ist das der den du gekauft hast ?
[Beitrag "Re: [V] Programmer Top2049"]

Autor: Ingolf O. (headshotzombie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, Thomas, das ist er!

Du schriebst ausserdem, dass Du Deinen TOP nachgelötet hast. Kann das 
als generelle Empfehlung gelten oder war Deiner Montagsproduktion?
Nachdem ich den Tipp las, das Gerät zu öffnen, um Lötperlen und 
Zinnreste zu entfernen, bevor Schaden entsteht, habe ich das Siegel mal 
verletzt.
Ausser Staub fand ich aber nichts Bemerkenswertes, nur einige wenige 
Lötungen, die nicht optimal aussehen und deswegen sicherheitshalber 
nachgelötet werden. Mag aber kaum glauben, dass es das war...

Autor: Thomas R. (tinman) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich mag zwar sehr die topxxxx geräte, allerdings ist und war es immer 
deren problem zu bestücken/löten (die machen es selber ...)

Der top3100 ist etwas besser, fpga und µC sind von hand gelötet (und 
sauber), alles andere aber die übliche "top" qualität (also nachlöten).

Da du eh nicht zurückgeben kannst, löte einfach alles nach, und dann 
gucken wir weiter.

Autor: Michael Buesch (mb_)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ingolf O. schrieb:
> Ebay-Shop und was
> hast Du an Zoll bzw. überhaupt hinlegen müssen?

Das kommt ganz drauf an wie der Händler das verschickt. Wenn er es als 
Geschenk verschickt und der Zoll es glaubt ohne es zu öffnen, dann hast 
du Glück. Das ist mit Sicherheit nicht ganz legal, aber ich hab es ja 
nicht in der Hand wie der Händler es versendet. :)

> @Michael Buesch
> Die gescheiterten Brennversuche wurde mit nachfolgenden ICs vorgenommen:
> - M2764AFI von ST / 3 Stück
> - M2764AFI von SGS / 1 Stück
> - TMS2764-25JL von TI / 2 Stück
> - D2764A von Intel / 2 Stück
> - Am2764ADC 1 Stück
> - M27128AFI von ST / 2 Stück
> - M27256FI von ST / 2 Stück

Ok, hast du auch schonmal mit einem anderen Bauteil wie einem Atmel 
Mega8 probiert? Der sollte ohne Probleme funktionieren.

Autor: Michael Buesch (mb_)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas R. schrieb:
> Ich mag zwar sehr die topxxxx geräte, allerdings ist und war es immer
> deren problem zu bestücken/löten (die machen es selber ...)
>
> Der top3100 ist etwas besser, fpga und µC sind von hand gelötet (und
> sauber), alles andere aber die übliche "top" qualität (also nachlöten).
>
> Da du eh nicht zurückgeben kannst, löte einfach alles nach, und dann
> gucken wir weiter.

Ich kann bestätigen, dass out-of-the-box sehr viele kalte Lötstellen in 
meinem TOP2049 vorhanden waren.

Autor: Michael Buesch (mb_)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, ich habe mal schnell den Algorithmus fuer den m2764a mit 12Vpp in 
toprammer zusammengeklöppelt.

Ich habe wie gesagt kein solches EPROM. Deshalb kann ich es auch nicht 
testen. Aber ich habe die Signale kurz im Scope geguckt und es schaut 
recht OK aus.

Also wenn du es ausprobieren möchtest:

Download von toprammer mit GIT:
git clone http://git.bu3sch.de/git/toprammer.git

Dann zum Auslesen des EPROM:
./toprammer -b ./bit/m2764a.bit -B -V2 -e eprom.img

Zum Programmieren:
./toprammer -b ./bit/m2764a.bit -B -V2 -E eprom.img

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.