mikrocontroller.net

Forum: Platinen Eagle Fehlerliste


Autor: Guido Kraft (brezinzke)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Den Schaltplan habe ich fertig in Eagle eingegeben
Beim Starten sagt Eagle Schaltplan und Board konsistent
Ist gut und schön aber er zeigt noch 26 Fehler an.
Wie z.B " mehr als ein Output Pin an Netz INT1 u.s.w.
Ich weis nicht wo ich noch suchen soll.

Autor: Kevin K. (nemon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
in der Kommandozeile gibst du run find.ulp int1 ein. Dann wird das Netz 
int1 gesucht und hervorgehoben. Du hast scheinbar zwei Bauteile mit 
deren Ausgangspins an das Netz angeschlossen, wenn du dir überlegst, was 
das bedeutet, siehst du, was daran merkwürdig ist.
Du hast zwei als Quelle fungierende Kontakte, die beide das Potential im 
Netz bestimmen wollen. Das geht solange gut, wie sie exakt das gleiche 
Potential herstellen wollen. Ansonsten hast du mehr, oder weniger große 
Probleme, da Ströme von einer Quelle in die andere fließen.

Autor: Gregor (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Guido,
nicht für ungut, aber der Stromlaufplan ist noch lange nicht fertig...

Ich habe einmal einige Warnungen bearbeitet, u.a. fehlende Junctions,
Überlappungen (gerade im rechten Bereich) bereinigt, Bauteile sinnvoll 
verschoben, Powersymbole verwendet usw. Keine Garantie auf Richtigkeit.

Es gibt 48 Warnungen, die Du durchgehen solltest. Diese wären:
- Bauteilewerte nicht vergessen
- R31 nur an einem Bein angeschlossen (R31 löschen?)
- Nur ein Pin an Netz xyz (Pins in der Luft!)
Die letztgenannten Warnungen bedeuten, das dass angeschossene Pin 
praktisch in der Luft hängt und somit offen ist. Gerade im linken 
Bereich sind alle Gatter offen, wenn dort eine Stiftleiste o.ä. 
angeschlossen werden soll, muss diese natürlich auch platziert werden.
Die o.g. Warnungen sind VOR den Fehlern zu beheben. Alle anderen 
Warnungen checken, ob diese auch behoben werden müssen.
Nun zu den Fehlern:
- INT: Der INT bei beiden Bauteilen als "Ausgang" erstellt worden (ist 
auch richtig lauf Datenblatt). Beide sind miteinander verbunden, was 
eigentlich nicht sein sollte. Vorlage überprüfen (wenn vorhanden)
- RES: Am Gatter IC8C ist der Ausgang Pin8 mit dessen Eingang Pin9 
verbunden. Geht also auch nicht. Habe das Netz an Pin8 gelöscht und in 
den Bus integriert (M1RES).
- Nur input Pins an diversen Netzen: D.h. auch hier liegen dann alle 
Eingänge in der Luft und müssen dann zumindest an eine Stiftleiste 
angeschlossen werden.

Gibt es dann zu dem Board Unterlagen? Müsste dann genau verglichen 
werden.

Weiterhin frohes Schaffen, im Anhang die Version M00-V01.

Autor: Guido Kraft (brezinzke)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Tut mir leit aber ich fange erst an mit Eagle zu arbeiten
Danke erstmal für Ihre hilfe.

MFG

Autor: egberto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
seufz.....das ich das noch erleben darf....hatte ich das letzte mal im 
Studium...oder bin ich doch noch nicht so alt und so was wird noch 
verwendet ?! ;-))

Autor: Jörn Paschedag (jonnyp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, unter anderem fehlen da noch die Steckerleisten. Was für Typen sind 
das, VG-Leisten? Das net (Verbindungsleitungen) werden immer nur bis an 
das Bein des Devices gezogen, nicht darüber hinaus, das gibt 
overlapping. Netnamen werden mit label dargestellt. Gleiche Namen werden 
miteinander verbunden.
Wenn du mir den Leistentyp gibst zeichne ich die da schnell noch mit 
rein.
Dann kriegste das Ding zurück und kannst noch die kleinen Fehler 
debuggen, dann lernste noch was dabei ;-)

Autor: Guido Kraft (brezinzke)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Danke nochmal für die Hilfe .
Unten an der Leiterplatte sind Leiterzüge wie bei einer ISA-Karte vom PC
Ich sende mal ein Bild mit wo es zusehen ist .
Sowas habe ich auch nicht in Eagle gefunden .

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Unten an der Leiterplatte sind Leiterzüge wie bei einer ISA-Karte vom PC
> Sowas habe ich auch nicht in Eagle gefunden .
Nimm ein SMD-Pad und lass es Vergolden.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Guido Kraft (brezinzke)

>      M001-PIO_2.jpg
>      2 MB, 8 Downloads

Ach ja, 2MB für nostalgischen Schrott . . .
Mit kurzer Lektüre des Artikels [Bildformate]] wär das nicht passiert . 
. .

>Unten an der Leiterplatte sind Leiterzüge wie bei einer ISA-Karte vom PC
>Ich sende mal ein Bild mit wo es zusehen ist .
>Sowas habe ich auch nicht in Eagle gefunden .

Gibt es auch nicht, musst du selber machen. Ist ja nicht wirklich 
anspruchsvoll. Entweder direkt im Layout zeichnen oder als Bauteil 
erstellen. Schau dir die Bibliothek con-pc an, dort sind gute Vorlagen 
drin.

MfG
Falk

Autor: Jörn Paschedag (jonnyp)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Der INT ist zwar ein Ausgang, aber einer mit open Collector, d.h. man 
kann die problemlos zusammenschalten (wired-or). Der Fehler liegt in der 
library. Ich hab jetzt mal im sch ein bischen rumgewurschtelt und die 
gröbsten Fehler raus gemacht (hoffe ich) ;-). Ein modifizierter 
Edge-connector liegt in der beiliegenden lib. Als Ausgangsconnector habe 
ich eine VG-Leiste verwendet, aber lt. dem Foto ist das verkehrt. Na ja, 
bischen was mußt du ja auch noch zu tun haben ;-)

Autor: Guido Kraft (brezinzke)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Nochmals danke für Ihre Arbeit sieht ja wirklich super aus.
Da werde ich wohl noch bisschen üben müssen um das so ordentlich 
hinzubekommen.
Es ist ja noch kein Meister vom Himmel gefallen.

MFG.

Autor: Jörn Paschedag (jonnyp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na ja, super ist was anderes und ob alles richtig ist hab ich auch nicht 
geprüft. Für dich ist also noch genügend Arbeit drin ;-)
Der RB0-Schalter rechts im Modul Plan fehlt. Erst in deinem Foto habe 
ich gesehen das es nur Solderpads für eine Lötbrücke sind. Das Device 
der Doppeldiode SAL41B ist mit Sicherheit auch falsch, weil ich ein 
Datenblatt nicht gefunden habe. Die XM-Leiste ist eine modifizierte 
Kopie einer IBM-ISA-Karte. Da wirst du wohl noch die Ränder im bord ein 
bischen verschieben müssen.
Das alte Projekt wird hier im Forum niemanden interessieren. Wenn du 
also noch Fragen hast oder Tips brauchst oder auch noch ein paar files 
hin und her schieben willst, dann kannst du mich auch ruhig privat 
anbaggern;-)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.