mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme beim Programmieren


Autor: Ronny (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

ich hab da ein Problem. Ich hab mir nen ISP-Programmer gebastelt. 
(normaler Dongle für STK200 und die paar Leitungen an den 8515 
gebastelt) Nun hab ich mit AVRISP versucht das Teil zu programmieren.
Der Device Health Check wird erfolgreich abgeschlossen (Device passed 
HealthCheck) Aber wenn ich den Flash programmieren will kommen Fehler 
bei ca. 87%. Hab schon langsamere Taktraten (2.??Mhz) probiert, nutzt 
aber nix. Den Eeprom programmierts ohne Fehler (manchmal zwar erst im 2. 
Anlauf aber er programmierts) Das Kabel zum Paralellport is max. 30cm 
lang. Versorgungsspannung nehm ich vom STKboard ab. (kann den plcc nich 
direkt ins stkboard stecken) hat jemand ähnliche probleme gehabt und 
eine lösung parat? bin für jeden tipp dankbar.


mfg ronny

Autor: Ronny (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
achso nochwas. die fehler treten zwar immer bei 87% programmierstatus 
auf aber nicht an den gleichen speicheradressen

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Holla Ronny,
lege mal die Leitung SCK am Controler über 560pF - 1nF an Masse. Hilft 
manchmal und ist abhängig vom verwendeten PC.

Gruß,
Günter

Autor: Ronny (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo

mysteriös. weder arvisp noch ponyprog haben ihn programmiert. das kleine 
tool von http://www.yampp.com hat ihn ohne probleme programmiert und ein 
danach durchgeführtes verify mit avrisp bzw ponyprog brachte keine 
fehler.

komisch aber naja

mfg ronny

Autor: der andere (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
welches programm hast du von der benutzt um den eeprom und so 
zubeschreiben? ich finde es nicht auf der seite ;)
ich hab das problem dass ich den eeprom garnicht beschrieben bekomme,
ponyprog sagt das eeprom beschrieben wurde, aber wenn ich das prüfe is 
wieder nicht drinne...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.