mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Über Triac fließt geringfügig Strom bei wenig Strom über Gate


Autor: Robert R. (robertr)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

ich habe ein Problemchen mit meinen Triacs und Transistoren. Da die 
Bauteile neu sind glaube ich weniger an einen Defekt, daher bitte ich 
euch um Hilfe.

Das Problem ist folgendes. An einen Triac (Modell BT 138-500) schließe 
ich an die beiden Main Terminals einen über 3,6v betriebenen Laser an 
(DC). Halte ich nun eine 1,5v Batterie an das Gate zündet der Triac und 
alle Welt ist zu Frieden, sprich er ist intakt. Ich möchte jedoch das 
Gate an eine Platine anlöten, bei der dann dauerhaft ein Strom über das 
Gate fließt, der zum Zünden ausreicht. Da jedoch der Strom, der bei 
dieser Platine zum Zeitpunkt des gewollten Zündens ankommt größer ist 
habe ich einen Widerstand davor geschaltet. Nun zündet der Triac nur 
noch wenn erwünscht, jedoch glimmt der Laser mäßig schwach mit. Um das 
Verhalten zu testen habe ich den festen Widerstand durch einen 
regelbaren ersetzt und langsam den Wert reduziert. Beim Glimmen änderte 
sich die Helligkeit nur wenig bis zu dem Punkt, bei dem die Zündung 
erfolgte und der Laser hell aufleuchtete.

Es scheint also, dass der Triac Strom über die Main Terminals fließen 
lässt, wenn über das Gate Strom fließt, der jedoch zum Zünden nicht 
ausreichend ist. Wie kann man nun erreichen, dass man den Ausgang der 
Platine nutzt und der Laser entweder ganz aus oder an ist?
Ich habe einige Triacs durchprobiert, ebenso Transistoren (Modell BC 237 
und 238A), dort habe ich genau das Selbe Phänomen entdeckt.

Das Einzige was mir noch einfällt wäre einen Widerstand parallel und 
einen Weiteren vor das Gate zu schalten damit der Strom möglichst nicht 
über das Gate fließt, wenn nicht gezündet werden soll. Allerdings 
bezweifle ich, dass das gut funktionieren würde.

Vorschläge, Lösungen, Erklärungen? Bitte her damit, ich komme nicht 
weiter.. :(


Vielen Dank schon mal
Robert

Autor: g457 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Das Einzige was mir noch einfällt wäre einen Widerstand parallel und
> einen Weiteren vor das Gate zu schalten damit der Strom möglichst nicht
> über das Gate fließt, wenn nicht gezündet werden soll.

Wie wärs mit 'Strom durchs Gate abschalten'? Sollte sich am einfachsten 
erreichen lassen indem Du das Gate auf das Potential von A1 legst.

HTH

Autor: Robert R. (robertr)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für deinen Beitrag.
Wenn ich das jetzt richtig verstanden habe soll ich am Gate auch 3,6v 
anschließen, stimmt das so? Jedoch darf laut Datenblatt das Gate mit nur 
rund 1,5v betrieben werden. Der Triac allerdings ist für bis zu 500v 
ausgelegt. Jedoch habe ich auch bereits mit 3,6V aus dem gleichen 
Stromkreis gezündet, problemlos und der Triac arbeitet weiterhin.

Wenn das nun so stimmt wäre es eventuell sinnvoll einen Transistor 
vorzuschalten und dessen Gate mit der selben Spannung wie am Collector 
und Emitter zu betreiben und damit dann den Triac antzsteuern. Wenn ich 
mich nicht Irre habe ich dies bereits versucht, erfolglos. Werde es aber 
morgen nochmals testen.


Derzeit ist wie gefolgt angeschlossen (da ja mit Gleichstrom betrieben):

A1: -3,6v
A2: +3,6v, -1,5v
Gate: +1,5v

Gruß
Robert

Autor: Gaast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich weiss nicht ob ich dich jetzt richtig verstanden habe, aber:

Die maximale Gate-Spannung laut Datenblatt ist natürlich immer auf einen 
der Hauptanschlüsse bezogen.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> bei der dann dauerhaft ein Strom über das Gate fließt,
Wo fließt der Strom dann hin?

> Nun zündet der Triac nur noch wenn erwünscht,
> jedoch glimmt der Laser mäßig schwach mit.
Fliesst der ständige geringe Gatestrom evtl. über den Laser?
Hast du mal einen Schaltplan zum Thema?

Autor: Robert R. (robertr)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

im Anhang der Schaltplan.


Die Batterie (V1) vertritt die beiden Ausgänge auf der Platine.

Da der Triac sonst zünden würde wurde ein Widerstand (R1) 
davorgeschaltet. Die Größe des Widerstands muss nur ausreichend sein 
damit der Triac nicht zündet, kann also variiert werden. In der 
Schaltung wurde daher der Standardwert von 1K symbolisch beibehalten.

Der Schalter S1 simuliert einen höheren Strom der von der Platine im 
Falle einer gewollten Zündung kommen würde, weshalb hier der Einfachheit 
halber der Widerstand überbrückt wird.

Das Problem ist nun, dass der Laser (im Schaltplan die Lampe L1) leicht 
glimmt, obwohl der Triac nicht gezündet ist.

Ich hoffe, ich konnte den Schaltplan detailliert genug darstellen und 
die Problematik wurde ersichtlich.

Gruß
Robert

Autor: Flow (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein TRIAC in einer Gleichspannungversorgung !

Das Bauteil kann nicht von alleine abschalten, wenn es denn mal 
eingeschaltet hat/gezündet wurde....... vermute ich.

Autor: g457 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1. Warum eine extra Stromversorung fürs Gate? Zapf die doch von den 
+3.6V (aka von A2 des Triacs) ab.

2. Warum liegt der Schalter ★parallel★ zum Gate-Widerstand?? Wundert 
mich gar nicht, dass da immer ein Strom fließt.

3. Wie Flow schon geschrieben hat: Gleichstrom und Triac ist i.d.R. 
nicht ganz einfach. Der Haltestrom von Deinem Triac liegt bei etwa 6mA. 
D.h. wenn Du den Laser ausschalten willst, dann brauchst Du einen 
Zeitpunkt wo weniger als 6mA fließen. Schafft Dein Lasermodul das?

4. Warum überhaupt ein Triac? Sollte doch mit einem Transistor ebenso 
einfach (wenn nicht sogar einfacher) gehen.

HTH

Autor: Robert R. (robertr)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
g457 schrieb:
> 1. Warum eine extra Stromversorung fürs Gate? Zapf die doch von den
> +3.6V (aka von A2 des Triacs) ab.

Das schrieb ich bereits. Ich möchte mit einer Platine diesen Triac 
ansteuern und den Laser mit einer 2. Stromquelle betreiben da der Strom 
von der Platine nicht ausreicht.

g457 schrieb:
> 2. Warum liegt der Schalter ★parallel★ zum Gate-Widerstand?? Wundert
> mich gar nicht, dass da immer ein Strom fließt.

Schrieb ich ebenfalls bereits. An den Ausgängen auf der Platine fließt 
im Ruhezustand immer Strom wenn man etwas anschließt, ist nun mal so und 
kann ich nicht ändern. Allerdings fließt eindeutig mehr Strom über den 
Ausgang wenn gezündet werden soll. Daher wird in meiner Skizze einfach 
der Widerstand überbrückt beim gewollten Zünden, ergo mehr Strom. Dies 
soll das Verhalten der Platine einfach simulieren.

g457 schrieb:
> 3. Wie Flow schon geschrieben hat: Gleichstrom und Triac ist i.d.R.
> nicht ganz einfach. Der Haltestrom von Deinem Triac liegt bei etwa 6mA.
> D.h. wenn Du den Laser ausschalten willst, dann brauchst Du einen
> Zeitpunkt wo weniger als 6mA fließen. Schafft Dein Lasermodul das?

Ich glaube nicht dass das Ausschalten des Lasers in irgend einer Weise 
Teil meiner Frage war... Der bleibt an so lange bis ich ihn von der 
Stromquelle trenne.

g457 schrieb:
> 4. Warum überhaupt ein Triac? Sollte doch mit einem Transistor ebenso
> einfach (wenn nicht sogar einfacher) gehen.

Ein Transistor lässt nun mal nicht wie ein Triac oder Thyristor offen 
wenn er ein mal Strom über das Gate bekam. Da ich das jedoch wünsche 
muss ich einen Triac oder Thyristor verwenden, da ich allerdings derzeit 
nur Triacs habe verwende ich einen Triac.
Allerdings möchte ich, wie auch bereits geschrieben, nochmals 
hinzufügen: das gleiche Phänomen, nämlich dass der Laser glimmt wenn am 
Gate zu wenig Strom fließt um den Triac zu zünden habe ich auch bei 
einem ganz normalen Transistor. In sofern hat das Problem wohl nicht mit 
meinen Triacs direkt zu tun.


Die Frage bleibt also bestehen: wie kann ich erreichen, dass ich einen 
größeren Strom mittels Triac eindeutig schalten kann (ganz an oder ganz 
aus) wenn am Gate im Ruhezustand immer ein minimaler Strom fließt, 
welcher zum Zünden jedoch nicht ausreicht?

Gruß
Robert

Autor: Flow (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Diese Werte stecken in den Eingangskennlinien des eingesetzten 
Schalters, es werden darin 3 Bereiche unterschieden:
-Bereich des sicheren Nichtzündens
-Bereich des möglichen Zündens
-Bereich des sicheren Zündens
und
in einer Tabelle für den Steuerkreis:
-oberer Zündstrom
-nichtzündender Steuerstrom
-höchster zulässiger Steuerstrom (Scheitel/Effektiv)
-höchste zulässige Steuerverluste

I_FG als Funktion von V_FG   bei U_

Wie soll das gehen mit deiner +Gatespannung mit Bezug zur Anode?

Autor: Dirk J. (dirk-cebu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Triac ist verkehrt herum angeschlossen!

Autor: Robert R. (robertr)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Flow schrieb:
> I_FG als Funktion von V_FG   bei U_

Meinst du Figur 10 in folgendem Datenblatt?
http://pdf1.alldatasheet.com/datasheet-pdf/view/16...

Das Problem ist, ich habe den Triac in allen möglichen Varianten 
angeschlossen. Schließe ich ihn anders als wie genannt an glimmt der 
Laser viel weniger, es wird jedoch gar nicht gezündet. Daher glaube ich, 
dass es so irgendwie stimmen muss.


Nur wie erreiche ich nun den Triac dazu zu bringen ein eindeutiges 
Signal zu erzeugen? Sollte dies nicht möglich sein, welche anderen 
Bauteile muss ich wie anordnen um dies zu erreichen?

Ich habe dieses Problem sogar bei einem Fototransistor letztens bemerkt, 
bei wenig Licht glimmt der Laser mehr oder weniger, je nachdem wie viel 
Licht auf den Fototransistor auftrifft, irgendwann zündet er dann wenn 
man ihn mit mehr Licht bestrahlt. Die Problematik ist wohl genau die 
selbe.

Vielen Dank,
Robert

Autor: Ulf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im Datenblatt steht folgendes:

ID off-state leakage current VD = VDRM(max); min- typ0.1 max0.5 mA

Vielleicht verursacht der vorhandene Leckstrom das Problem. An einer 
Reihe von BTA16 und BTA26 habe ich 10- 12 mA gemessen(Gate an T1, 12 V 
Gleichspannung).
Überhaupt erscheint mir ein Triac mit 500V10A etwas übertrieben, oder 
ist Dein Laser eine Kanone? Wenn das Teil bei so geringen Strömen schon 
anspringt, solltest Du evtl. einen kleinen Lastwiderstand zum Laser 
parallelschalten. Den Triac wirst Du damit nicht überlasten...

ulf.

Autor: Robert R. (robertr)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ID off-state leakage current, da würde ich vermuten dass es um den Strom 
geht der fließt wenn der Triac sperrt und eigentlich nichts fließen 
dürfte, richtig? Wenn dies so ist dann ist es nicht das Problem, denn 
der Laser ist definitiv aus wenn nichts am Gate angeschlossen ist. Das 
Problem tritt erst dann auf wenn über das Gate Strom fließt welcher zum 
Zünden des Triacs nicht ausreicht.

Natürlich ist der Triac für diesen Laser überdimensioniert, das ist 
klar. Allerdings habe ich nur dieses eine Modell was Triacs betrifft und 
der Laser ist nur zum richtigen Aufbau der Schaltung gedacht. 
Funktioniert diese soll eine Sirene mit 12V angeschlossen werden, 
eventuell noch mehr 12V Verbraucher. Daher sollte der Triac schon 
richtig sein, lieber überdimensioniert als dass mir das Teil überhitzt 
und durchbrennt.


Allerdings sind wir beim eigentlichen Problem noch immer nicht weiter. 
Da es wie geschrieben auch bei meinen Transistoren sowie 
Fototransistoren passiert müsste es dafür doch irgend eine Lösung geben 
um ein eindeutiges Signal erzeugen zu können. Kann man mit Widerständen, 
Kondensatoren etc. nicht irgend etwas machen?

Gruß
Robert

Autor: Randy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie hoch ist der Strom der aus der Steuerung fließt? Du könntest einen 
Widerstand zwischen Gate und der Anode schalten an der der Minuspol der 
1,5V liegen. Größe so gewählt dass der Dauerstrom aus der Steuerung nur 
0,4 oder 0,5V Spannung am Widerstand erzeugt. Dass fließt der Strom 
durch den R und nicht durch den Gate.
Was ist das überhaupt für eine seltsame Ansteuerung die einen kleinen 
Strom über das Gate fließen lässt wenn der Laser aus sein soll? Schreib 
doch mal näheres über die Steuerung.

Triac vs. MOSFET: Dir ist schon klar dass an einem Triac im 
eingeschaltetem Zustand wesentlich mehr Spannung abfällt (die dann am 
Laser fehlt) als bei einem MOSFET? Das kann bei 3,6V Betriebsspannung 
durchaus merklich sein.

HTH
Randy

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.