mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Warum schwingt Quarz nicht an


Autor: Christian Schifferle (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Forumsgemeinde

Bei beiliegenden Miniprojekt möchte ich 5 Halogenlampen ein/aus
schalten und dimmen.
Wenn ich den AVR in meinem Testboard einsetzte funktioniert die
Schaltung astrein.
Im Zielboard scheint der Quarz nicht anzuschwingen. Ich habe es bereits
mit 33pF und 47pF Kondensatoren versucht, mit dem gleichen
(Miss-)Erfolg.
Die 5V-Versorgung am AVR ist ok.

Was habe ich übersehen? Hat jemand eine Idee?
Schaltplan und Boardlayout liegen bei.

Gruss
Christian

Autor: Jens123 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gleicher µC?? evtl fuse bits... villeicht ist auch der Quarz hin


gruss Jens

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bist du dir sicher, daß der Quarz nicht schwingt? Gemessen mit Scope?
Mein Verdacht ist der Reset-Bereich. Das sieht nicht gut aus. Zumindest
eine RC-Kombination. Aber bei den alten Classik-Bausteinen empfehle ich
einen Spannungsmonitor (wie Dallas DS1813-XX).
Michael

Autor: Christian Schifferle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Jens

Gleicher uC läuft auf dem Experimentierboard!
Der Quarz ist neu (OK, keine Garantie dass er auch funktionieren
muss).

@Michael
Auf dem Experiemtierboard kann ich mit dem Oszi an Pin 4 die
Schwingungskurve darstellen.
In der Zielschaltung geht lediglich die Spannung am Pin auf etwa 2 Volt
(ebenso an Pin 5).
Sollte wirklich der Quarz defekt sein? Gibt es sowas überhaupt? Ist die
Erde wirklich eine Kugel?

Gruss
Christian

Autor: Peter Löschnig (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo

+5V direkt auf Reset, über Jumper auf VCC ??
für Reset muss VCC schon anliegen (und stabil sein)
Reset darf erst nach VCC high werden !!

besser (richtiger) Widerstand von Resetpin 10 k nach +5V und Kerko
100nF nach GND

Peter

Autor: chrissy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ganz schön anarchisches Layout g. Du hälst dich aber auch echt nicht
die Bohne an -nicht umsonst existente- Grundregeln.
Ich weiß nicht wie sensibel der Oszillator von den AVRs ist. Aber mach
doch den Quarz mal direkt an die Pins und die Massenrückführung über ne
massive Massenfläche. Oder wenigstens nicht 20m Leitung incl.
Stichleitungen.
Funktioniert der Spannungsregler? Vcc i.O.?
Und benutze für den Reset die von Michael angeregte Verzögerung.
Könnte auch sein, daß die Versorgung des Controllers was niederohmiger
sein sollte - versuche noch einen tantal an Vcc.

Kaputten Quarz glaub ich eher nicht. Wenn du den nicht wirklich richtig
heftig gegrillt hast beim einlöten.

Autor: Christian Schifferle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Quarz ist i.O. Habe ihn im Experimentierboard eingesetzt mit besagtem uC
zusammen und siehe da, es funzt.

Die Leitungen zwischen Quarz und uC können bei gegebenem Layout wohl
kaum noch kürzer gelegt werden.
Ich habe jetzt mal versuchsweise den Quarz direkt auf die Lötpunkte des
IC-Sockels verlötet mit dem genau gleichen Resultat.

Der Spannungsregler ist auch i.O. An Vcc liegen saubere 5V an.

Die Resetbeschaltung müsste auch funktionieren. Die verwendet Atmel
nämlich auch selber (siehe Application Note AVR400).

Autor: chrissy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Doch das geht bestimmt. ;-)

Konkret sieht das aber so aus, daß du den Quarz kurzschließt an dem
linken c. Am besten du machst noch mal den Anschluss das Quarzes
anders.

Autor: Thorsten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat jetzt nicht direkt was mit deinem Oszillatorproblem zu tun. Aber
wäre es nicht besser, jeweils vom Gate deiner Transistoren noch ein
Widerstand gegen Masse zu schalten ? Beim Flashen sind die die Portpins
doch High-Z und dann kann viel Müll passieren. Oder kann (darf) man das
vernachlässigen ?

Thorsten

Autor: Peter Löschnig (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo

beim Bord einen ERC machen, das schliesst Fehler (wie von chrissy
erkannt) aus

Autor: Peter Löschnig (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
meinte natürlich DRC !!

Autor: klack (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Wie chrissy schon gesagt hat dein Quarz ist Kurzgeschlossen.
Trenne die Leiterbahn in deinem Layout die ich im Anhang rot
markiert habe dann muss es Funktionieren
klack

Autor: Uwe Nagel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Quarz ist Kurzgeschlossen. Kratz mal die Leiterbahn zwischen dem
oberen Pin vom Quarz und dem oberen Pin von C1 durch, dann sollte es
gehen. Die anderen Kritikpunkte solltest Du dir aber auch zu Herzen
nehmen. Masseführung ist beim Layout sehr wichtig. Auch wenn solche
wilden Layouts erfahrungsgemäss laufen, der sicherlich ähnlich wilde
Aufbau auf dem Steckbrett läuft schliesslich auch, bekommt man
spätestens im Zusammenhang mit Analogtechnik (A/D) Probleme. Und mit
der EMV wahrscheinlich auch...

Autor: Christian Schifferle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ihr habt völlig recht. Den Kurzschluss habe ich tatsächlich übersehen.
Ist wohl beim manuell routen passiert.

Das Layout ist deswegen etwas wild weil ich versuche, mit möglichst
wenig Drahtbrücken auszukommen und ich möchte eigentlich auch keine
doppelseitigen Platinen verwenden.
Ich habe auch lange geübt, bis ich die Anordnung der Bauteile so
hingekriegt habe dass ich mit einer einzigen Drahtbrücke auskomme :-)

Danke für eure Hilfe
Christian

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.