mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik USB ISP Programmer / Bascom will nicht


Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo an alle,

ich habe ein Problem und komme nicht weiter.

Ich habe mir früher ein Parallel MYAVR Board gekauft, ging super mit 
Bascom.
Den Computer musste ich leider entfernen und verwende jetzt ein 
Notebook.
Daher habe ich mir diesen Brenner gekauft:

http://cgi.ebay.at/ws/eBayISAPI.dll?ViewItem&item=...

Habe ihn installiert mittels der .inf Datei und Windows erkennt ihn 
auch.

Leider kann ich meinen M32 nicht programmieren.

Zuerst fehlt bei mir mal in Bascom die Einstellung unter Programmer 
STK500 native driver, bei mir gibts nur stk500 oder stk500 extendes. AVR 
Studio 4.18 ist installiert.

Jetzt sehe ich zum Beispiel im Geräte Manager, dass der Programmer auf 
COM11 ist. Ok, bei Bascom STK500 extended eingestellt, bei COM habe ich 
11 eingegeben, den Link für das STK500 und dann steht noch USB da. Da 
habe ich auch 11 eingegeben. Stimmt das? In Bascom habe ich noch 
57600baud eingegeben, im Gerätemanager auch.

Nur kommt leider immer eine Fehlermeldung:

"Could not connect to AVRISP mkII on USB:11"

Was mache ich falsch?

Vielen Dank
Peter

Autor: Charly B. (charly)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Peter,

ich meine was gelesen zu haben das du einen com-port unter 8 oder sogar 
unter 4 haben musst, versuch das mal

viel erfolg & vlg
Charly

Autor: Jakob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,

ich hab mir den hier 
http://shop.myavr.de/Programmer/mySmartUSB%20light... 
geholt und soweit ich das sehe ist der genauso wie deiner ein STK500v2 
kompatibler Programmer... der funzt mei mir mit Bascom problemlos und 
meine Einstellungen in Bascom sind folgende:

- STK500 nativ driver
- COM4
- 115200 baud

vielleicht hilft das ja :/

Grüße

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Hatte das selbe Problem hab bei Communication den Com Port vom progr. 
und die Baudrate eingestellt.
Und unter Programmer STK500 native driver, wieder den Com Port vom 
progr.,  Clock 1000000 und timeout 100 eingestellt.

Hoffe es hilft.
Grüße

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.