mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Infineon Starter Kit XE166 Debugging Problem


Autor: Slevin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich verwende das Easy-Kit der XE166 Familie von Infineon und µVision3, 
der µC wird über USB an den Pc angeschlossen. Als USB Treiber habe ich 
das Programm DAS. Die DIP-Schalter auf dem Board müssten richtig gesetzt 
sein (off,off,off,off,on).
Beim Debugging erscheint der Fehler: Target DLL has been cancelled. In 
den Optionen -> Debug -> Settings taucht der richtige Controller auf, 
aber unter Device steht: Unknow device. Er scheint ihn nicht richtig zu 
erkennen.
Außerdem wird das Board auch im Gerätemanager richtig aufgelistet.
Wo könnte das Problem liegen?

MfG
Slevin

Autor: ??? (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
DAS besteht aus mehreren Teilen. Der Server muss gestartet werden und 
das richtige Device ausgewählt werden. Man erhält dann eine Rückmeldung 
für die bestehende Verbindung.

???

Autor: Slevin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
µVision startet automatisch DAS.
Wenn ich DAS manuell starte (Server erstellen...) erscheint ebenfalls 
Unknown Device.
Ist die Baudrate in Windows (ComX) mit 9600 richtig eingestellt?

Autor: ??? (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bin gerade nicht am Basteltisch. Ich schau aber gleich mal nach, ob ich 
das Ding irgendwo finde. Melde mich dann, wie es bei mir läuft.

???

Autor: ??? (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also, wollte das Ding auf dem Laptop meiner Freundin installieren und, 
und, und, ... klappt nicht.

Ist Windows 7 als 64 Bit drauf und dafür liegt kein Treiber bei. :=(((((

Welches BS hast Du?

???

Autor: Slevin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab WinXP SP2! In Windows wird bei mir der Controller richtig erkannt.

Wie führt man den Debugging-Modus "richtig" aus (Resetknopf 
drücken/halten, DIP-Schalter, Jumper setzten, ...)? Welche Einstellungen 
in µVision muss man setzten?
Hab schon fast alles ausprobiert und in der Easy-Kit Manual steht auch 
nichts weiter drin!

Autor: ??? (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jetzt sehe ich es. Du schreibst ganz oben, daß das Device richtig 
erkannt wurde. Da kann ich dir heute nicht mehr helfen. Bei infineon.com 
gibt es vielleicht was.

???

Autor: Slevin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja, werd mal schauen was ich noch so für Infos über das Easy-Kit 
auftreiben kann. Vielleicht find ich ja doch noch was brauchbares. Dank 
Dir erstmal für deine Antwort!

Autor: Slevin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo nochmal,

ich habe es immer noch nicht geschafft eine richtige Verbindung 
herzustellen und langsam glaube ich, dass das Board fehlerhaft ist.
Gibt es vielleicht eine andere einfache Möglichkeit den µC zu proggen, 
ohne USB?

MfG
Slevin

Autor: CamilloN (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo erstmal,
Ich bin auf dem Gebiet totaler Neuling und hab tierische Probleme die 
Verbindung mittels DAS zum laufen zu bekommen. Gibt es da vielleicht 
eine gute Anleitung. Die Manuals auf der mitgelieferten CD bringen mich 
irgendwie auch nicht weiter. Ich wäre schonmal viel weiter wenigstens 
eines der Beispiele zum laufen zu bekommen.

Vielleicht weiß einer von euch eine gute Anleitung.
Vielen Dank im vorraus.
Internette Grüße
Vincenzo

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.