mikrocontroller.net

Forum: Compiler & IDEs Probleme mit PonyProg und ATTiny13


Autor: Bernd M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, habe ein Problem mit PonyProg 2.07c und einem ATTiny13.

Der µC befindet sich auf einem Evaluationsboard von Pollin und ich kann 
ihn nicht auslesen oder brennen. Habe PP schon neu gestartet und mal auf 
"AVR Auto" gestellt, aber es ist nichts zu finden. Nicht mal Fuses! Das 
Ganze mit vier verschiedenen ATTinys.

Wenn ich anstelle des 13er einen 2313er oder einen ATmega16 einstecke 
werden diese gefunden, gelesen und gebrannt.

Wo liegt mein Denkfehler?

Danke

Autor: Stefan B. (stefan) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Attiny13 ist für den Sockel IC2 vorgesehen, während die anderen von 
dir genannten AVRs in andere Sockeln gesteckt werden. Deshalb würde ich 
als erstes den Sockel und dessen Lötstellen und dessen Leiterbahnen 
unter die sprichwörtliche Lupe nehmen, besonders wenn das Board selbst 
zusammengelötet wurde. Zusätzlich zur Lupe ist ein Multimeter nützlich. 
Damit kann man die µC-lose Platine die ISP Verbindungen von Sockel zu 
Sockel durchpiepsen (ich habe z.B. ein Pollin Funk Board bei dem eine 
Leiterbahn fehlt(e)). Und man kann nach Anlegen der Versorgungsspannung 
am Sockel prüfen, ob RESET und VCC +V haben und die anderen Pins ca. 0V. 
Alternativ kannst du auch mit einem Adapterplatinchen für die 
funktionierenden Sockeln oder den ISP-Anschluss experimentieren.

Nieder mit den Bugs!

Autor: Bernd M. (adventureman1972)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Witz an der ganzen Geschichte ist, dass ich vor längere Zeit schon 
mal mehrere 13er gebrannt habe. Leider weiß ich die Enstellungen nicht 
mehr.
Es kann eigentlich nicht an der selbst gelöteten PLatine liegen.

Man sollte dabei sagen, dass ich mit einem Adapter auf dem 20iger 
IC-Sockel für den 2313 arbeite, weil der ATTiny13 im Originalen nicht 
auf der PLatine PLatz findet. Dieser ist 1 zu 1 durchkontaktiert. 
Ausnahme: Pin4. Der ist auf Pin 10 (GND) umgeleitet. Alle anderen passen 
soweit.

Leider habe ich auch heute kein Erfolg gehabt und suche weite nach dem 
Problem...

Bernd

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.