mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik angefressene PWM - Grund?


Autor: ping (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe folgendes Setup:
Fullbridge IC (VNH3SP30) an einem uController.
Die Fullbridge hat 2 enable, 2 input und einen PWM Pin.
Das PWM Signal vor der FB ist sauber und hat 50% duty cycle.
Hinter FB mit einem Motor dran habe ich am getakteten Ausgang eine 
angefressene PWM (50% DC) wie im Bild zu sehen. Woran liegt das und was 
kann ich dagegen tun?

Danke für Hilfe!

Autor: ping (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry, hab das Bild versehentlich zweimal angehängt.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Hinter FB mit einem Motor dran habe ich am getakteten Ausgang eine
> angefressene PWM (50% DC) wie im Bild zu sehen.
An welchem Ausgang? Eine FB hat 2 ...
Welche Frequenz darf man sich zu dem Bild vorstellen?
Zeig doch trotz der schönen Beschreibung mal einen Schaltplan(-auszug) 
incl. Versorgung.

Autor: ping (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Versorgungsspannung der Schaltung ist ein externes 24V Netzteil. Die FB 
häng direkt an den 24V und hat zwischen VCC und GND vor der FB einen 
1000uF Elko.
Die FB taktet die low side Seite. Am anderen Ausgang sind die 24V. 
Gemessen habe ich an der getakteten Seite.
Der Controller läuft mit 5V und hat einen Schaltregler um die 5V zu 
erzeugen.
Extra Freilaufdioden habe ich nicht.
Schaltplan des Schaltwandler im Bild.

Autor: ping (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach ja, PWM Frequenz sind 200Hz.

Autor: ping (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
push

Hat keiner ne Idee?

Autor: Bernhard Mayer (bernhard84)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
schau dir mal deine Versorgungsspannung am VNH3SP30 an. Vielleicht 
bricht die ja ein. oder der VNH3SP30 geht in eine art 
temperaturbegrenzung. wie heiß wird er denn?

Bernhard

Autor: ping (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Versorgungsspannung muss ich mir mal ansehen.
Die Temperatur ist zwischen 80 und 100°C.
Was mir noch aufgefallen ist: bei einem kleinen duty cycle von ca. <12% 
tritt der Effekt nicht auf.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Schaltplan des Schaltwandler im Bild.
Ähm, da fehlt der Rest...

Wie sieht eigentlich zum selben Zeitpunkt die Spannung am anderen Zweig 
der H-Brücke aus? Wie sieht das Layout aus?

Autor: GGaasstt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vermutlich Strombegrenzung oder ähnliches. Versuch mal den Strom zu 
messen.

Autor: thisamplifierisloud (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mir fallen spontan 3 Möglichkeiten ein :

- Netzteil zu schwach
- Ladeelko vom Netzteil zu klein
- Leitungen zu dünn

Autor: ping (Gast)
Datum:
Angehängte Dateien:
  • preview image for FB.PNG
    FB.PNG
    13,8 KB, 172 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Hm, das Netzteil kann 20A und der Treiber 30A, da glaube ich nicht, dass 
er in die Strombegrenzung geht. Gefahren wird ein Zylinder, gemessen 
hatte ich mal 13A als er gegen den Anschlag gefahren ist. Sonst braucht 
er deutlich weniger (ca. 4A). Das PWM-Signal sieht auch so komisch aus, 
wenn der Treiber noch kalt ist und normal gefahren wird.

Anbei mal das Layout vom Treiber. Die Platine hat 70u. Die 24V Zuleitung 
ist über Top und Bottom Layer geführt und jeweils 2,3mm breit.

Autor: Bong (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Kuvenform (exponentiell) nach zu urteilen (Die ist aber wohl 
stilisiert?) bricht die Spannung an einem Stützelko ein. Warum das nicht 
schon vorher einbricht ist schwer zu sagen.

Autor: ping (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mir gerade nochmal das PWM Signal vor der FB und am Ausgang 
gleichzeitig angeguckt. Wenn das PWM-Signal vor der FB high ist, dann 
wird der low side Switch geschaltet und die PWM am Ausgang ist zum 
selben Zeitpunkt low. Da wo also die PWM am Ausgang high ist und ich die 
komischen Ecken sehe, ist also derder low side Switch offen.
Könnte das nicht also vom Generatorbetrieb des Motors kommen? Zuerst 
fließt noch der Strom über die Freilaufdiode, danach sinkt die Spannung 
weil nur noch der Motor als Generator schiebt.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.