mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Induktion - Problem bei Resonanz


Autor: Michi M. (mutzmutz)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo miteinander

Ich hab eine Frage zu einer Induktionsanwendung. Vorab, ich hab das
Forum durchsucht und auch Beiträge gefunden, jedoch leider keine Antwort
auf meine Frage gefunden, auch weil einfach zu viel Material zu finden
ist, deshalb ein neuer Beitrag.

Der Schaltplan hab ich gleich angehängt, den hab ich so auch mal
aufgebaut und die Funktioniert auch ganz gut. Mein Problem ist nun, dass
wenn ich über die Induktionsspule ein Verbraucher bringe (Pfanne oder
ähnliches) und den Schwingkreis auf Resonanz betreibe (ca 22kHz), die
Pfanne dann entferne wird sofort der Half-Bridge Driver zerstört. Wenn
ich auf 23 kHz arbeite, die pfanne entferne sinkt der strom (was ja auch
ganz richtig so ist). Meine Frage: Mach ich was falsch oder ist das
wirklich so extrem, dass bei Resonanzfrequenz ohne verbraucher der
Treiber getötet wird?
Noch ein paar sachen zum schaltungsaufbau: Die Hochspannung "HV_DC"
beziehe ich momentan von einem Netzgerät (30V, max. 3A), die Drossel L1
ist nicht bestückt (ist die nötig, wenn ja was genau bewirkt diese ?).
Der Stromtrafo T1 ist ebenfalls nicht aufgebaut, anstelle diesem hab ich
einen 0.1Ohm shunt drin.

Hoffe das alle Angaben vorhanden sind und ich freu mich auf jeden
Kommentar und Hilfe !

Autor: Raimund Rabe (corvuscorax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kein Wunder, das der Treiber in die ewigen Jagdgründe geht, wenn der 
LC-Kreis in Resonanz geht.
Was passiert wohl bei einem Parallel/Serien-Schwingkreis in Resonanz?
Während bei einem (idealen) Parallelschwingkreis der Strom ins 
unendliche Steigt, wird er bei einem Serienresonanzkreis wohl was 
machen?
Richtig - die Spannungen steigen ins unermessliche. Da aber i.A. nichts 
ideal ist, wird sich das auf ein endlichen Wert einstellen, der aber bei 
weitem größer sein kann als der Treiberbaustein an seinem VOUT-Pin (Pin 
6) verträgt. Häng doch mal ein Oszi an Pin 6 nach GND und siehe selbst. 
Starte weit weg von der Resonanz und nähere Dich dann gaaaanz langsam 
der Resonanz. Latürnich solltest Du spätestens dort stoppen, wo die max. 
zulässige Spannung an Pin 6 erreicht ist.

Autor: Mandrake (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Spannung an Pin6 klettert bis auf HV_DC dort wird sie durch die 
Inversedioden des IGBTs festgeclamped. Nichtsdestotrotz wird das zuviel 
sein für Pin6. Versuch doch mal HV_DC auf 15V (Versorgung des Treibers) 
abzusenken. Wahrscheinlich geht der dann nicht mehr kaputt.

Gruß

Mandrake

Autor: Michi M. (mutzmutz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Raimund Rabe
Deine Erklärung macht Sinn, hab somit auch mal die Spannung zwischen 
Pin6 und GND gemessen und hab mich mit der Frequenz richtung Resonanz 
angetastet. Hat wunderbar funktioniert, auch mit dem entfernen der 
Pfanne.

@Mandrake
Hab die Messung mit verschiedenen HV_DC - Spannungen durchgeführt :

Bei HV_DC = 100V fliesst ein Strom (mit Pfanne) von ca. 2 Ampere, ohne 
Pfanne rund 0.5 Ampere ! Die IGBT's werden unglaublich heiss (max 
Messung 125° mit Kühlrippen).
Es war mir schon klar, dass die IGBT's warm werden, jedoch nicht so 
warm, vorallem kann ich somit auch nicht höher als 100V gehen da die 
IGBT's sonst den Hitzetod finden.
Kann mir jemand sagen, warum die so extrem warm werden? Klar, die 
Verlustleistung ist da, wenn nicht direkt bei resonanzfrequenz 
gearbeitet wird, aber so extrem? Ist es möglich, dass die Parasitären 
elemente (durch kabel vom laboraufbau derart grosse auswirkungen haben 
?), oder hab ich noch ein fehler in der Schaltung ?

Autor: Michael O. (mischu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ähem - die IGBTs kenne ich nicht (Datenblatt).

23kHz ist schon relativ viel für IGBTs, da der Tailstrom recht lange 
fließt.

Die 33nF Snubber finde ich etwas zu drastisch. Die Ladungsmenge muss bei 
jedem Schaltvorgang mit umgeladen werden.
Im Idealfall solltest Du quasi stromlos umschalten können, da deine 
Resonanzkreis umschwingt. Dadurch kann dein L die Kondensatoren der 
Halbbrücke umladen.  Wenn Dein Schalter allerdings zum völlig falschen 
Zeitpunkt schaltet, dann fallen die Verluste der Umladevorgänge in den 
IGBTs an.

APROPOS Messung, die 0,5 A und 2 A hast Du vermutlich am Eingang (bei 
100V) gemessen.  Die Phasenströme können aber dramatisch viel höher 
sein. Die 0,5 .. 2A sind nur die Ströme zum decken der Verluste (100V x 
2A = 200W).
Miss mal den Phasenstrom.


EDIT:
Die 100nF für den Bootstrap-Schalter könnten eventuell etwas zu niedrig 
sein. Schalte mal 1uF parallel. Deine Steuerung darf natürlich nie lange 
einen Testgrad von über 95% stellen.

Autor: Michael O. (mischu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schau mal ins Datenblatt:
http://www.promelec.ru/UPLOAD/xml/pdfbase/FGP7N60RUFD.pdf

Ets Total Switching Loss
Typ: 0,3mJ
Max: 0,5mJ

Das ist der komplette Energieverlust für einen Ein- und 
Ausschaltvorgang.
Bei 23kHz hast du 23.000 Schaltvorgänge pro Sekunde:

Pv,schalt = 23.000/s x 0,5mJ = 11,5W    Schaltverluste max mit einem 
IGBT im hartschaltenden Fall. Du hast zwei IGBTs also max 23W 
Schaltverluste.
Wenn Du entlastet einschalten würdest, dann könntest du 0,23mJ (typ) 
sparen.


EDIT:
Dein IGBT kann nur 7A verkraften - das ist aus meinem Gefühl deutlich zu 
wenig!!!

Nimm am Besten einen guten MOSFET (CoolMOS) von Infineon. Die schalten 
schneller insbesondere schneller.

Autor: Michi M. (mutzmutz)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
also ich hab mal ein paar messungen gemacht:

Strommessung im schwingkreis (HV_DC_30V.png ), grün ist die spannung 
über shunt (0.1 Ohm). mein ziel ist es nicht, einen riesigen strom durch 
den schwingkreis fliessen zu lassen (wie bei üblichen 
induktionskochfeldern), sondern auf ca 5 A zu begrenzen, jedoch mit 
einer spannung HV_DC von 300V, damit die gleichgerichtete Netzspannung 
verwendet werden kann (regelung per PWM-duty)
Snubber variiert (snubber_1_220nF_sn2_33nF.png  und 
beide_snubber_4.7nF..png), die Messungen wurden immer über drain-source 
beider schalter gemacht.
der boot- kondensator hab ich auch mal ein wenig variiert, konnte aber 
keine drastischen unterschiede erkennen.

Leider hab ich gerade keine anderen IGBT's oder MOSFET's zur hand, aber 
denkt ihr, dass die riesigen verluste wirklich "nur" vom richtigen 
schalter abhängen? Kennt sich jemand gut mit dem half-bridge-driver 
(L6384) aus ? Habe nämlich zusätzlich den verdacht, dass durch den 
Laboraufbau parasitäre Induktivitäten eine grosse Rolle Spielen 
(beschrieben im dokument     *   igbt_driver_Tipps.pdf auf Seiten 6 - 
10)

Autor: Michael O. (mischu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn Du dazu eine Einschätzung haben möchtest - GLASKUGELAN - "Die 
parasitären Komponenten hängen natürlich vom Aufbau ab" - 
"GLASKUGELAUS".

Sollte es noch genauer sein, dann bitte ein Foto vom Aufbau posten.

Allerdings glaube ich nicht, dass die Verluste stark von den parasitären 
Ls abhängen. Du hast im Wesentlichen die zwei Mechanismen "Durchlass-" 
und "Schalt-" Verluste.
Aus Sicht des Gatetreibers hängen die Durchlassverluste von der 
Gatespannung und die Schaltverluste vom Treiberstrom ab. Den 
Treiberstrom begrenzt/reduziert man normalerweise noch durch einen 
Widerstand.
Wenn der Aufbau wirklich schlecht ist, dann wirst Du durch parasitäre 
Induktivitäten eher Überspannungen erhalten und die Bauteile den 
Überspannungstod sterben. Du kannst ja mal messen, denn parasitäre L's 
in der Gateansteuerung müssten (ähnlich wie dein Kochfeld mit den 
Kapazitäten) einen Resonanzkreis bilden. Masse vom Oszi direkt an GND 
vom lowside IGBT und Tastkopfspitze an das Gate.

Einen IGBT setzt man niemals für Schaltfrequenzen von 100kHz ein, das 
schaffen nur MOSFETs. Im Bereich um 20kHz kommt es stark auf den 
konkreten Typen an, wer die Nase vorne hat.
Fakt ist, dass ein IGBT nach dem Abschalten eine ganze Weile braucht, 
bis er tatsächlich vollständig ausgeschaltet hat (Tailstrom).
Dein konkreter Typ hat z.B. bei steigender Temperatur einen zunehmenden 
Ausschaltverlust, die Verluste steigen mit steigender Temperatur....


Bezüglich deiner Schaltstrategie...
Leider kann man in dem Screenshot 1 den Stromnulldurchgang nicht genau 
erkennen. Bitte leg die Nullinie mal auf das Raster und zieh den Bereich 
mal auf. Aber soweit ich das sehe, schaltest Du zu spät um!!
Damit deine Schalter weich schalten können, musst du etwas früher die 
Halbbrücken umschalten (etwas überresonant anregen). Damit kann der 
kleine Reststrom schon mal die Arbeit des Umladens erledigen und die 
IGBTs können dann quasi stromlos anschalten.

Autor: Mandrake (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das IGBTs GENERELL nicht bei Schaltfrequenzen über 20kHz einsetzbar 
sind, ist schlicht falsch.
Ich setzte hier zum Beispiel den HGTG20N60B3D ein. Der kommt unter 
bestimmten Bedingungen bis ~220kHz hoch (siehe DB Figure 13). Diese 
Bedingung lautet stromloses Schalten ZCS. Es muss also in den 
Stromnulldurchgängen geschaltet werden. Vermutlich sind da viele IGBTs 
ähnlich.
FAZIT:
IGBTs sind bei hartem Schalten nur für kleine Frequenzen geeignet.
Bei ZCS erweitern sich die Möglichkeiten in Bezug auf die Frequenz.

Autor: Michael O. (mischu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Mandrake
Respekt, 220kHz ist schon verdammt viel!

Aber es ist auch so, dass bei 220kHz die maximale Verlustleistung (165W) 
des Chip erreicht ist während der Baustein nur mit knapp 12% seines 
maximalen Stroms läuft.
Das ist schnell, aber aus Sicht der Verluste nicht mehr sinnvoll!

Schaltleistung(220kHz, 50% Duty, 480V, 5A): 0,5 x 5A x 480V = 1200 W
Verlustleistung: 165W

Das bedeutet, dass gut 10% der Verluste nur im IGBT anfallen und Du 
einen Typen nehmen musst, der für 5 - 7kW ausgelegt ist aber nur auf 
1-2kW betreiben kannst.

Autor: Mandrake (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich betreibe das Bauteil hier in einer Vollbrücke, die einen 
Serienresonanzkreis mit 120V= beaufschlagt. Per PLL und einigen 
Phasenschiebern mache ich dann ZCS (Umschaltverluste ~0W). Die IGBTs 
wurden so um die 40° warm (durch die leitend Verluste [Inversdiode 
inbegriffen]) .
Gleichstrom am Eingang ca 4A aber der Blindstrom im Resonanzkreis sollte 
das weit übersteigen. Das ist das was ich noch erinnere.
Wenn ich das Gerät nochmal aufbaue messe ich nochmal genauer. Das 
interessiert mich jetzt auch.

Gruß

Mandrake

P.S.: Es handelt sich bei der Anwendung um einen Teslatransformator.

Autor: Michael O. (mischu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alles klar, Du hast die Betriebsspannung von 480V aus Figure 13 auf 120V 
in der Brücke reduziert, also nur ein viertel der Spannung. Damit 
reduzieren sich auch die Verluste beim Ein/Ausschalten drastisch, da 
hier sowohl Strom und Spannung eingehen.
Der Tailstrom führt dann auch nur zu einem viertel der Verluste, wie bei 
einem Aufbau mit 480V.

Autor: Michi M. (mutzmutz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok danke euch für die vielen inputs. leider kann ich erst am montag 
weitere messungen machen, und andere IGBT's bzw Mosfets muss ich auch 
zuerst bestellen.
wie kann ich eine ZCS realisieren, nur mit dem variieren der Frequenz? 
(kann jemand bitte eine explizite schaltung hier reistellen , finde 
nichts schlaues im internet)  weiss jemand warum zb dieses Problem nicht 
im Datenblatt bzw zusatzdatenblatt des Treibers angesprochen wird? 
sollte dass "allgemeinwissen" sein :-) ?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.