mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik PicooZ Fernsteuerung für Eigenbau?


Autor: Valentin Buck (nitnelav) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
nach der Zerlegung einiger PicooZ Helis, um an die Rotoren zu kommen, 
habe ich noch die Fernsteuerungen und die Empfängermodule übrig.
Nun würde ich gerne diese IR-Fernsteuerung weiterbenutzen.
Die Module haben jeweils ein Litzenpaar für den Hauptrotor und ein 
Litzenpaar für den Nebenrotor. Davon liegt immer eine Litze auf VCC, 
also der Akkuspannung, und die andere wird über einen kleinen Transistor 
auf VCC gezogen. Obgleich die Hebel an der Fernsteuerung etwas anderes 
andeuten, scheint der Hauptrotor nur AN oder AUS geschaltet werden zu 
können.
Bei der Lenkung ist ständig ein Potential vorhanden (damit sich der Heli 
nicht in der Luft dreht) das dann erhöht oder verniedrigt wird.
Nun möchte ich damit eine Fernsteuerung bauen, zum Anfang erstmal so, 
dass jeweils eine LED für Vollgas und jeweils eine LED für Links und 
Rechts aufleuchten, wenn die Hebel in die entsprechende Position 
gebracht werden.
Also habe ich einfach mal ein Pullup über 1kOhm an die 
OpenCollector-Ausgänge der Steuerkanäle zu dem Pluspol des Akkus 
gezogen.
Nun bekomme ich da ein Signal, das der Steuerposition entspricht, nur 
leider invertiert.
Dann habe ich versucht, mit OpAmps (LM324) die Signale durch 
Komparatoren zu trennen. Bei dem Gashebel klappt das auch ganz 
wunderbar, nur bei der Lenkung komme ich nicht weiter.
Ich habe eine Akkuspannung von 4V, davon kommen konstant etwa 2.2V aus 
dem Lenkausgang mit Pullup raus, wenn ich Vollgas gebe. Wenn ich nun den 
Lenkhebel bewege, steigt oder sinkt die Spannung um bis zu 0.5V.
Ich habe also versucht mit einem Komparator da ein 0V/4V Signal draus zu 
machen, jedenfalls für eine Richtung. Allerdings leuchtet die LED nur 
unterschiedlich hell, und das auch, wenn ich in die "falsche" Richtung 
lenke. Dabei stelle ich den Spannungsteiler immer so ein, dass der 
Komparator bei der erhöhten Lenkspannung (2.2V + 0.5V) eigentlich HIGH 
ausgeben müsste.
Weiß jemand was ich falsch mache?
Sind 4V überhaupt genug für den LM324, denn ich speise ihn im Augenblick 
direkt aus dem Akku des Empfängers (50mAh LiPo)?
Mit freundlichen Grüßen,
Valentin Buck

Autor: Stefan P. (form)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Motorausgänge sind PWM-Moduliert (nur an/aus, aber mit 
unterschiedlichem Timing). Um das analog Auswerten zu können musst Du 
nach deinem Pull-Up erstmal noch z.B. ein R-C Tiefpass bilden. (oder 
gleich digital auswerten mit einem µC - vielleicht reicht auch ein 
Monoflop)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.