mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik MPP Tracker, Dimensionierung von Spule und Kondensator


Autor: Ingolf B. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo liebe Forengemeinde!

Ich möchte einen MPP-Tracker aufbauen.
Habe mir dazu folgende Schaltung überlegt sowie aufgebaut.
Die Schaltung soll bei einem Solarmodul eingesetzt werden mit folgenden 
Daten:
U=26,4V; I=4,8A

Ich habe folgendes Problem.
Wenn mein Laststrom größer wie 500mA wird, dann beginnt mein Spannung 
sehr zu schwanken. Wie muss ich die Spule L1 und den Kondensator C1 
dimensionieren damit meine Ausgangsspannung Konstant gehalten wird?
Oder gibt es noch andere Möglichkeiten diese Schwankungen zu verhindern?

Vielen Dank schon mal im Vorraus!

MfG
Ingo

Autor: Ingolf B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die verwendete Frequenz zum schalten der Mosfets beträgt übrigens 40 kHz

würde mich über jede Hilfe freuen.

Autor: Zwölf Mal Acht (hacky)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aaaaahhh, 7805 & 7812 auf einer Leiterplatte ... der ist hart. Die 
Ausgangsspannung wird wo gemessen ? Ich erwarte einen Spannungsteiler 
von IO3.

Autor: Ingolf B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oh ja der spannungsteiler ist noch falsch eingezeichnet.
sollte eigentlich natürlich parallel zur Last liegen und nicht wie hier 
noch hinter io4....(ist aber richtig verlötet)

Autor: Axel R. (axelr) Flattr this
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
MPP Tracker, evtl. hilfts. Habe ich mal irgentwo im Netz gefunden.

Autor: Ingolf B. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Morgen zusammen!

Hier ist die Schaltung mal etwas vereinfacht dargestellt!

Autor: avion23 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schaltplan ist nicht verstehbar.

Autor: Ingolf B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was ist denn nicht verständlich?

Autor: Marti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Axel Rühl (axelr)

Das geht aber auch kleiner - man kann die Werte noch erkennen.

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Wenn mein Laststrom größer wie 500mA wird, dann beginnt mein Spannung
> sehr zu schwanken.


Die Regelung macht dein uC. Der ist schuld. Bzw. dessen Programm.

C1 bringt natürlich nichts, wenn kein Akku dran ist, er wird nicht mal 
die mehreren A durchlassenkönne ohne zu explodieren. Du müsstest schon 
1000de uF haben, damit die Spannung ohne Akku nicht in jedem Impuls 
'schwankt'.

Übrigens ist es normal bei MPP, daß die Spannung mit Absicht schwankt, 
wie sollte er sonst auch den MPP finden können um dorthin nachzuregeln?

10mH find ich jetzt heftig, zumal der Strom bei 5A liegt. Ist nicht mehr 
handelsüblich ist nicht mehr billig, und bei 40kHz gnadenlos 
überdimensioniert.

Autor: Ingolf B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nee der mikrocontroller ist sicherlich nicht schuld. bzw. dessen 
programm.
also spannung kommt fast ein sinus raus das meinte ich mit 
schwanken...(halt nur bei Belastung)
also habe ich einen Widerstand als Last angeschlossen und daher lebt 
mein C1 auch noch.
Ich möchte keinen Akku laden sondern einen Motor betreiben(Solarboot).

Mit der Spule hast du recht. Aber das war ja auch die eigentliche Frage 
wie groß diese dimensioniert werden muss damit die Ausgangsspannung 
relativ glatt ist.

ich habe jetzt einen wert errechnet von ca. 250 mikro Henry.
wo bekomme ich jetzt passende speicherdrosseln her? oder halt 
ferritkerne die passend wären?

mfg

Autor: ... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wo hat denn dein 5V Regler den Masse-Bezug?

Autor: Ingolf B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
achso sorry das fehlt noch auf dem schaltplan aber ist auf Platine 
richtig verlötet und funktioniert auch einwandfrei. bis auf meine 
genannten probleme.
aber trotzdem danke

Autor: Zwölf Mal Acht (hacky)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aha. Ich sehen, dazu gibt es kein Layout. Das ist ein Steckbrettaufbau. 
Steckbrettaufbauten sollte man mit Schaltnetzteilen seinlassen. Da sind 
die Stoerungen weder kontrollierbar, noch reproduzierbar. Ich wuerd mal 
sagen, ohne ein vernuenftiges Layout wird eh nichts.

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> nee der mikrocontroller ist sicherlich nicht schuld.
> bzw. dessen programm.
> also habe ich einen Widerstand als Last angeschlossen
> und daher lebt mein C1 auch noch.
> Ich möchte keinen Akku laden sondern einen Motor
> betreiben(Solarboot).

Das ist doch alles Käse.

Ein Motor an einem MPP ? Ist doch hirnrissig.



> also spannung kommt fast ein sinus raus das

Pro 40kHz Puls oder schwankend über mehrere Pulse hinweg ?
Letztes ist SICHER eine Folge des Programms.

> ich habe jetzt einen wert errechnet von ca. 250 mikro Henry.

Sehr schön, und, was machst du jetzt mit deiner hundert Euro
teuren 10mH/5A Spule ? Und warum täten es 100uH nicht auch ?
http://schmidt-walter.eit.h-da.de/smps/abw_smps.html
Man kann auch 1mH berechnen.

Autor: Ingolf B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ist wirklich kein fehler des programms ja pro 40 khz impuls.
es ist ein solarboot das mit einem motor angetrieben wird.

ist auch nur mein projektauftrag und nicht umbedingt kompletter 
hirnriss.

die spule ist halt falsch dimensioniert und ich brauche eine 
speicherdrossel.
die 10 mH war nämlich keine. daher auch nur ca 3 euro und nicht 
hundert....

möchte eigentlich jetzt nur noch wissen wo ich solche spulen möglichst 
schnell herbekomme. bzw. passende ferritkerne.

vielen dank schonmal

Autor: Roy H. (roy01)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann das sein, das bei deinem Versuchsaufbau die Eingangsspannung 
zusammenbricht?
Du mußt bei deiner Regelung darauf achten das dies nicht passiert.
Die Spannung der Solarzelle muß daher ebenfalls mit in Deine Regelung
einbezogen werden und darf nicht unter ein bestimmtes Minimum abfallen.
Achso, tausche bitte die Bezeichnugen deiner Anschlüsse IO1 usw. mit 
einem eindeutigen Plus und Minus Zeichen, dann wird das auch 
verständlicher.
Dein Spannungsteiler ist nähmlich am falschen Ausgang eingezeichnet und
kann daher garnicht richtig Messen.

Autor: Ingolf B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nein meine eingangsspannung bricht erst bei größeren belastungen 
zusammen..

das mit den anschlüssen habe ich schon festgestellt. die platine ist 
aber richtig verlötet.

ich bin mir sehr sehr sicher das der fehler an der falschen spule liegt. 
wie gesagt.

aber trotzdem danke

Autor: Roy H. (roy01)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich kann mir nicht vorstellen, das eine zu große Spule solche 
Auswirkungen hat.
Die gerät wenigstens nicht gleich in die Sättigung.
Der Kondensator müsste meiner Ansicht nach wesentlich größer sein.
Nimm doch einfach mal einen 1000µF Elko.
An Deiner stelle würde ich mir nicht gleich 100%ig sicher sein, das die 
Software fehlerfrei ist.
Es kann da vom falsch eingelesenen AD-Wandler bis zum fehlerhaften 
Regler alles dabei sein.

Autor: Ingolf B. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier mal mein aktualisierter Plan mit Eagle!
Habe mit einem Oszilloskop die Ausgangsspannung am Lastwiderstand 
gemessen!
Wenn nur ein ein kleiner Strom bis 500 mA fließt ist das Signal noch 
sauber an der Last! Fließt jedoch ein höherer Strom dann verzerrt sich 
mein Ausgangssignal!!!
Hinter den Mosfet´s ist mein Ausgangssignal noch in Ordnung, jedoch 
nicht mehr hinter der Spule!
Den gößeren Kondensator werde ich jedoch mal einbauen da dieser ziemlich 
klein dimensioniert ist!

Autor: Roy H. (roy01)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Etwas ist da aber seltsam. Dein AD-Wandler nimmt die Messwerte ja auch 
hinter der Spule auf. Wenn dort kein Sauberes Signal oberhalb von 500mA 
ist,
dann kann die Reglung für die FETs doch weiterhin kein suaberes Singnal 
liefern. Oder?

Autor: ... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ingolf B. schrieb:
> Hier mal mein aktualisierter Plan mit Eagle!

Öhm, da kann man noch weniger drauf erkennen....
Oder sollen wir uns jetzt die Pinbelegung der Bauteile selbst aus den 
Datenblättern ziehen?

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie baut ihr eioentlich solche Schaltungen ?
Mit der Schippe in die Restekiste mit Bauteilen,
dann auskippen zu zusammenlöten?
Das beginnt schon bei der ungewöhnlichen Verteilung
der Abblockkondensatoren an den 78xx Reglern, die
so in keinem Datenblatt stehen.

Erst hat C2 6800pF, dann 6.8uF, dabei wären 6800uF wohl
passender. Denn keiner der Kondensatoren verträgt die
mindestens 3A Lade/Entladestrom, die dort entstehen.

Bei dir reicht es auch, wenn ein Widerstand einen
Widerstandwert hat, die Leistung ist egal, oder was ?
Kondensatoren sind doch nicht anders.

Und die Spule, mit 10mH und mindestens 5A,
hat bei 40kHz welche Güte ?
Andersrum gesagt, wie viel von den 40kHz kommen dank
Koppelkapazität durch die Spule durch ohne dass sie
ihre induktive Wirkung entfalten kann ?
http://www.produktinfo.conrad.com/datenblaetter/52...
wäre eher für 20Hz.
Oder ist es gar ein Eisenklotz ?
http://www.tube-town.net/ttstore/product_info.php/...
der taugt für eher 100Hz.

Wenn du mit dem Oszilloskop eine saubere Spannung links der Spule 
siehst,
also wohl ein 40kHz Rechteck von 26V,
aber rechts der Spule einen 40kHz Sinus, dann schau noch mal genau hin, 
ob dieser Sinus nicht ein Dreieck ist, der durch deine derzeit ohm'sche 
Last (steigende Spannung bewirkt steigenden Strom also mehr Belastung) 
abplattet. Denn normalerweise sind die Störungen eher kleine 
Nadelimpulse an den Umschaltpunkten. Natürlich kann es auch Klingeln 
geben, also Ausschwingvorgänge die ein abklingender Sinus sind, der hat 
dann aber mehr also 40kHz, eher 400kHz. Nur hab ich irgendwie Zweifel, 
daß die Resonanzen bei deinem Aufbau so hoch sind, wenn ich schon die 
Bauteilwerte höre.

Autor: Zwölf Mal Acht (hacky)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Spule saettigt mit dem Strom.

Autor: Ingolf B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja ich geh raus in den garten und gucke mal was für widerstände, 
kondensatoren usw rumliegen.

ja es ist ein 40kHz Rechteck von 26V.
nee leider kein dreieck.

und ihr solltet eigentlich auch nicht meine komplette schaltung 
analysieren.
ist zwar sicherlich gut gemeint aber....

meine frage war wie ich spule + ausgangskondensator dimensionieren 
sollte. das wars schon.

Autor: mischu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ähem,

Du hast nach einem MPP - Tracker gefragt.

Mit deiner Spannungs- UND Strommessung misst Du für einen MPP-Tracker 
aber an den falschen Stellen!!
MPP versucht einen Arbeitspunkt der Solarzelle zu finden, an dem der 
Wirkungsgrad maximal wird. Dazu müssen Strom und Spannung der 
SOLARZELLE und nicht des Ausgangs gemessen werden!!

Wenn Du kein MPP_Tracker aufbauen möchtest, dann schreibe es bitte auch 
nicht hin.
Sollte Dir nicht klar sein wie ein MPP-Tracker funktioniert, dann 
informiere dich bitte.

Autor: Ingolf B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
achso mmh....
beim gleichstromsteller ist nur leider P1 gleich P2!
also wenn ich am ausgang die maximale leistung habe, habe ich sie somit 
auch am eingang oder????

Autor: Zwölf Mal Acht (hacky)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
aehem.... Das Maximum an Power kann man entweder am Eingang oder am 
Ausgang messen. Denn die Pulsbreite wo Eingangsspannung mal 
Eingangsstrom maximal ist, sollte auch Ausgangsstrom mal 
Ausgangsspannung maximal sein, wenn wir mal den Eigenverbrauch 
weglassen.

Autor: Axel R. (axelr) Flattr this
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Marti schrieb:
> @Axel Rühl (axelr)
>
> Das geht aber auch kleiner - man kann die Werte noch erkennen.

Ich habe das Dokument nun doch noch auf meinem alten Rechner gefunden...
ist von 1998

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.