mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik mµAVR mk3 + Bascom-Einstellungen Hilfe


Autor: Michael L. (looser13)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Forum,

habe ein Problem mit dem mk3 von mµAVR und Bascom.

Habe den neusten Treiber installiert, Com5 zeigt Windows an.

Habe unter Bascom (neueste Version 1.11.9.8) schon einige 
Prommereinstellungen probiert, komme aber nicht weiter.
Die Hotline von mµAVR hat mir auch zu allgemeine Tipps gegeben.

Weil ich schon gelesen habe, das die "Stk500 native"- 
Prommereinstellungen funktionieren sollen, habe ich es auch mit dieser 
probiert, aber ohne Erfolg.

Im Anhang Bilder der Prommereinstellungen und die Fehlermeldung von 
Bascom.



Wer kann mir da weiterhelfen??????

Die Schaltung, die programmiert werden soll, ist ohne Quarz und hängt 
direkt am mµAVR. Dort soll nur eine LED blinken.
Fusebits habe ich natürlich auch noch nicht setzen können!! Kann ich die 
eigentlich dann auch mit Bascom setzen??? Im Moment geht das natürlich 
nicht, da der Chip ja gar nicht erkannt wird!!!!!


Hier noch das Programm:

$regfile = "ATtiny13.dat"
$crystal = 9600000
$hwstack = 0
$swstack = 0
$framesize = 0
Config Portb.4 = Output
Do
  Toggle Portb.4
  Waitms 500
Loop
End


Hilfe, ich komme nicht mehr weiter!!
Danke im voraus.

mfg
looser13

Autor: Stefan B. (stefan) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael L. schrieb:

> habe ein Problem mit dem mk3 von mµAVR und Bascom.

Das da?

myAVR Board MK3 / 64, equipped
http://shop.myavr.com/Systemboards/myAVR%20Board%2...

Oder das da?

mySmartUSB MK3, equipped
http://shop.myavr.com/index.php?sp=article.sp.php&...

Bei dem mySmartUSB MK3 musst du ja deinen AVR Attiny13 in einer eigenen 
Schaltung aufbauen. Wie hast du das genau gemacht?

Mit Fusebits einstellen etc. würde ich so lange warten bis im ersten 
Bild links oben das Autodetekt kein ??? mehr bringt sondern dort korrekt 
Attiny13 steht...

Autor: Michael L. (looser13)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Stefan,

ich habe nur den Prommer:
http://shop.myavr.com/index.php?sp=article.sp.php&...

Daran habe ich die Schaltung hängen, eine 2mA LED über 1,5k Widerstand 
gegen 5V, 1x IO-Pin als Anschluß rausgefüht, da hängt aber nichts dran.

Kein Quarz!

Aber soweit komme ich ja gar nicht.

Mit dem Fusebit war mir das schon fast klar, danke schon mal für den 
Tipp.

Aber was nun???

Michael

Autor: Stefan B. (stefan) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Leuchtet D1?

Wie groß ist R1? Er sollte 4K7 bis 10K sein.

Wer liefert die 5V, externes Steckernetzteil oder der mySmartUSB MK3? 
Wie ist der Jumper bei der Spannungskonfiguration beim mySmartUSB MK3 
gesteckt?

welche Statusled auf dem mySmartUSB MK3 leuchten, wenn du deine 
Programmiersoftware startest?

Autor: Michael L. (looser13)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Stefan,

R1 ist 10k groß.

Die Spannungsversorgung kommt von dem mk3, der Jumper ist in 
Defaultstellung, sprich auf 5V!


Jetzt sehe ich da die mittlere Jumperstellung "ext", muß die etwa 
gejumpert sein????


Statusled´s sind an:
E = aus
1 = gelb
2 = grün
3 = aus

Soll stk-500-Modus sein!!

Gruß
Michael

Autor: Stefan B. (stefan) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Weiss ich nicht, weil die Doku (techn.Beschreibung) über diesen Punkt 
schweigt.

Wenn D1 leuchtet, liefert der MK3 wohl Vcc, also Jumper so lassen. Zur 
Sicherheit kannst du aber auch den ISP stecker abziehen und die Spannung 
zwischen dessen Pins Vcc und GND messen.

Diese Diskussionen kennst du bestimmt:
http://www.myavr.biz/myForum/viewtopic.php?t=2680
http://www.myavr.biz/myForum/viewtopic.php?t=2456

Autor: Michael L. (looser13)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jupiehh,

es geht.

Habe noch mal mit der Hotline telefoniert.

Die haben sich da noch mal reingekniet und jetzt geht es.

Also:

am Prommer muß der mµ-Modus aktiviert werden
--
Bascom:
Optionen, Simulator:
Comport auswählen,
"use integrated Simulator" aus,
"run Simulaor after compilation" - an
unter "Programm" den Verweis zum Programm Progtools (downloaden bei 
mµAVR)

Optionen,Programmer:
Programmer: "USBprog Programmer / AVR ISP mkII"
Comport auswählen,

Wenn ein Programm unter Bascom geschrieben ist, "F7" für kompilieren, 
Bascom kompiliert und es öffnet sich das Progtool. Dort unter dem Reiter 
"brennen" "Flash brennen" den Haken setzen und den Pfad zu der hex-Datei 
von Bascom eingeben. Unten den Button "brennen" klicken - fertig.

Hört sich alles wild an, aber das meiste sind nur Einmal-Einstellungen. 
Wenn die gemacht sind, hat man fix sein Programm drin. Die Übertragung 
ist eigentlich auch schnell.

Viel Spaß noch allen mit dem mk3!!!

Michael

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.