mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR USB Lab Eclipse Verbindungsfehler


Autor: kyrel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

nach laengerer Zeit habe ich doch ein USB-Progger mir zugelegt, um die 
parallele Anbindung loszuwerden.

Nun, ich arbeite mit Eclipse und dem AVR-PlugIn, bis jetzt immer mit 
make und PonyProg erfolgreich alles erstellen und flashen koennen.

Nu den AVR USB Lab ausgepackt, Quarz geloetet und auch die AVRISPmkII 
Firmware installiert, aber Eclipse bzw. AVRDude in Eclipse meckert, dass
a) der Port blockiert sei und
b) die Datei nicht gefunden werden konnte!

Hab schon auf der seite von ulliHome gesucht, im Netz und natuerlich 
auch hier, aber keine Abhilfe!

Aso, ohne was an irgendwelchen ports etc. zu drehen, funzt das Flashen 
mit AVR Studio.

hat Jmd. ne Idee, was los sein koennte ?!

Autor: Christian U. (z0m3ie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Versuch das ganze mal als root, wenn das klappt musst du deine Rechte 
verbiegen. Standartmässig darf unter Linux nicht jeder auf USB Geräte 
zugreifen.

lg
Christian

Autor: kyrel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Christian,

danke fuer den Tipp, aber bin mit WinXP unterwegs, und auch 
"standardmaessig" als admin unterwegs :)

schoenen Gruß

Autor: Christian U. (z0m3ie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ahh Eclipse->Linux ;) blöde Vorurteile...
Unter Windows findet avrdude glaub ich nur libusb geräte d.h.
entweder du nimmst die USBasp Firmware oder du installierst nen 
alternativen Treiber der auf libusb aufsetzt fliegt auch hier irgendwo 
im Forum rum ich hab leider keine Position mehr 100%ig im Kopf wo der zu 
finden war.
Oder aber du installierst mit meinem USB AVR Lab Tool den Filtertreiber 
mit, dann sollt avrdude den auch finden. Aber der ist leicht mit 
vorsicht zu geniessen auf so 10% der Systeme funktioniert nach der 
installation von dem Ding kein USB Gerät mehr, in dem Fall keine Panik 
einfach das Tool kurz deinstallieren dabei entfernts den auch sauber 
wieder aus dem System.

lg
Christian

Autor: kyrel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Christian,

tatsaechlich, es lag am "libusb", hab einfach dannach gegoogelt und dann 
gleich unter
http://libusb-win32.sourceforge.net/#downloads
den triber gleich runtergeladen und installiert.

Zuvor habe ich diese Filtertreiber-Variante ebenfalls versucht, jedoch 
erfolglos.

Anbei moechte ich erwaehnen, dass das Flashen nur mit dem Paramter: 
"-Pusb" und nicht "-PUSB" (Schreibweise) funktioniert!

An dieser Stelle besten Dank!

Habe zwar die Doku etc. gelesen, jedoch den Hinweis direkt in dem 
Prog-Tool ueberlesen ! :(

Jetzt funtzt zu mindest....bei Gelegenheit teste ich den gleich auch am 
MAC.


Angenehme Nachtruhe
kyrel

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die LibUsb Treiber sind auch im WinAVR Verzeichnis ;)

Autor: kyrel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Simon,

ja ist richtig, habe ich vergessen zu eraehnen, das wolle bei mir nicht 
funzeln....der heruntergeladene treiber schon ?!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.