mikrocontroller.net

Forum: Platinen Gleiches Symbol, anderer Name, aber wie ?


Autor: Hans Imglück (obiwahn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo
Nun ist es soweit. Meine Schaltung ist soweit ausgetestet. Jetzt gehts 
an die Platine. Eagle macht mir allerdings an allen Ecken und Kanten 
probleme !

Ich fang mal mit was "einfachem" an.
Ich habe in meiner Schaltung mehrere Leitungen, die ich mit einem 
"Supply-Symbol" versehen möchte. Da die Schaltung nicht auf ein Blatt 
passt ist das glaube ich sinnvoll.

Ich habe dazu aus der Supply2.lib das Symbol V+ ausgesucht und im 
Schaltplan an 3 verschiedene Netze gekoppelt. Die Symbole (Value) und 
die dazugehörigen Netze habe ich in Ub1,Ub2,Ub3 umbenannt.
Beim ERC krieg ich allerdings immer die Fehlermeldung "SUPPLY-Pin V+ mit 
mehr als einem Signal (Ub1,Ub2,UB3) überschrieben"

Sieht im Schaltplan zwar gut aus, aber Eagle weiss wohl nicht was ich 
will :(

Ok. Dann eben anders.
Ich mach mir 3 neue Symbole, die ich gleich mit Ub1,Ub2,Ub3 benenne.
Auch Fehlanzeige. Dachte ich könnte das Symbol einfach kopieren, 
umbenennen und in die vorhandene "Supply2.lib" eintragen.
Aber irgendwie geht hier garnichs so wie ich es von Windows her gewohnt 
bin.

Kann mir da jemand helfen. Krieg schon langsam graue Haare :(

Autor: Leo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

versuch mal das erste supplysymbol einzufügen, zu verbinden und dann dem 
Netz einen Namen zu geben z.B. VCC oder so. Wenn du jetzt die anderen 
Supplysymbole gleichen typs einfügst müsste das damitverbundene Netz 
eigentlich den gleichen Namen haben (und damit am gleichen Potential 
hängen).

Autor: Hans Imglück (obiwahn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist nicht das was ich vorhatte.
Ich möchte im Schaltplan rein optisch das gleiche Symbol für 3 
verschiedene Stromversorgungen haben. Die sind untereinander also nicht 
verbunden. Die brauchen nur 3 verschiedene Namen. Ub1 - Ub3

Autor: Hans Mayer (hansilein)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich glaube das gleiche Symbol für verschiedene Netze ist keine gute 
Idee.

Autor: Hans Imglück (obiwahn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es soll doch nur rein optisch gleich aussehen. Anhand des Namens sollte 
doch dann klar werden das es nicht die gleiche Leitung ist.

Wenn ich 3 Spannungen habe, die über mehrere Schaltplanblätter verteilt 
werden kann ich doch wohl 3 optisch gleiche Pfeile mit unterschiedlichen 
Beschriftungen verwenden. Oder muss ich etwa ein Pfeil , einen Kreis und 
ein Quadrat nehmen ?

Autor: TrippleX (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du musst das Symbol kopieren.
Du nimmst das "Schematic" von den alten Symbol, legst ein neues
"Schematic" an und kopierst es darein und dann benennst du den 
Anschlusspin
mit einen neuen Namen.

Dann legst du ein neues "Device" an, klickst links aud "Add" und fügst
dein "Schematic" von deinen neuen Symbol was du erstellt&unbenannt hast 
ein.
Voila! - Fertig dein neues Supply Symbol :)

Autor: Hans Imglück (obiwahn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kannst du mir mal Schritt für Schritt erklären wie ich das machen muss.
Bei Eagle funktioniert aber auch überhaupt nichts so wie ich es von 
anderen Windows Programmen her kenne. Kopieren ,Umbenennen, Einfügen 
etc.
Noch komplizierter konnten die das wohl nicht machen.

Wenn ich den Bibliotheks Editor öffne und das Symbol V+ lade, auf Copy 
klicke, dann "Neu" ist der Editor wieder leer. Einen "Einfügen-Befehl" 
gibts dann aber nicht. Ich blick da nicht durch :(

Autor: Hans Imglück (obiwahn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jetzt hab ich damit etwas rumgespielt. In meiner Library hab ich nun 
Symbole die Ub1,Ub2,Ub3 heissen. Wenn ich die aber in den Schaltplan 
einfüge heisst das angeschlossene Netz trotzdem noch V+.

Löschen kann ich den Müll auch nicht mehr.

Ich glaub ich machs lieber auf Lochraster. Dann ist es morgen abend 
fertig.

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Wenn ich die aber in den Schaltplan einfüge heisst das angeschlossene Netz
> trotzdem noch V+.
Das liegt daran, dass der PIN immer noch nicht V+, sondern VCC, etc. 
oder wasauchimmer heisst :)

Ralf

Autor: Michael M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hans Imglück schrieb:
> Ich glaub ich machs lieber auf Lochraster. Dann ist es morgen abend
> fertig.

oder du liest mal das handbuch?
gewagter schritt, ich weiß...

Autor: Mitleser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Wollte eben genau das Gleiche wie's glückliche Hänschen machen...
Da ich auf Ahieb nicht wusste wo das im Handbuch zu finden wäre, 
schwupps das Internet bemüht.
Und siehe da, mir wurde geholfen, dank diesem Forum ;-)

Ein großes Danke an die hilfsbereiten Nutzer hier!
Das Handbuch bleibt dann noch etwas länger neu ;-))

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.