mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Rauschen Keramik-Kondensatoren?


Autor: Anel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Frohe Ostern allen zusammen!

Ich arbeite an meiner Masterarbeit, inder ich eine Messschaltung 
aufgebaut habe, die Spannungen in 100uV Schritten misst.
In der Schaltung sitzt ein 16-Bit ADC, der von einen MC ausgelesen wird, 
der die Spannungswerte an einen PC sendet. 1-Bit entspricht etwa 10uV.
Bevor der analoge Wert in den ADC geht, wird mit einem OPV (LT6230) ein 
Offset aufaddiert. Die Offsetspannung kommt von einem DAC AD5667.
Dabei ist mir etwas Merkwürdiges aufgefallen. Ich hatte vergessen, einen 
100nF Kondensator (0805), der die Ausgangsspannung des DAC stützen 
sollte, aufzulöten. Das Rauschen lag unter 70uV, errechnet sollten es 
weniger als 30uV sein, aber das ist egal, ich will nur 100uV aufösen. 
Nach dem Einlöten des 100nF Kondensators, irgendein Standardteil mit 
X7R-Dielektrikum, hatte ich ein Rauschen, dass 5 bis 10 mal größer war.
Können Keramikkondensatoren so stark Rauschen? Bringt ein Typ anderem 
Dielektrikum eine Verbesserung?

Autor: Ulrich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das direkte Rauschen wird weniger das Problem sein. Die Kondensatoren 
der Reihe X7R und ähnlich sind aber etwas Piezoelektisch und wirken so 
etwa wie ein Mikrofon das Körperschall einfangen kann.

Autor: Zwölf Mal Acht (hacky)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Rauschen ? Nein, allenfalls mikrophonie. Das wuerde dann Einsteuung im 
audiobereich verursachen. Dagegen koennte man anstelle von X7R einen NPO 
typen nehmen. Ist es moeglich ein Spektrum des Rauschens zu bestimmen ? 
Die Speisung ist linear, ohne Switcher nehm ich an.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Ausgang dieses DACs verträgt nur 1nF laut Datenblatt.
Hast du etwa die 100nF direkt an den Ausgang des Verstärkers angelötet?
Falls ja, dann besteht die Gefahr, dass der Verstärker im DAC schwingt.

Autor: Anja (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eventuell ist auch der Massepunkt an dem der 100nF angeschlossen ist
durch digitale Störströme "verseucht".
Ansonsten: Folienkondensatoren haben keinen so ausgeprägten 
Mikrofonie-Effekt.

Gruß Anja

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ohne Schaltplan läßt sich natürlich nicht so viel sagen.

Ersetze den X7R-Typ doch mal durch einen MKS2-Typ, oder schnippe mit dem 
Finger auf die Platine, dann siehst du ja schnell, ob es Mikrofonie ist.

Ich hatte in der Anfangszeit der SMD-Technik mal ein Problem mit einem 
keramischen 1206 Kondensator, den ich aus Unwissenheit beim Löten 
überhitzt habe. Der hatte dann ein Kontaktproblem im Inneren, das auf 
dem Oszi wie tieffrequentes Rauschen aussah. Erst als ich die Platine 
mit beiden Händen durchgebogen habe, war das Rauschen weg (und das 
Nutzsignal auch...).

Kai Klaas

Autor: Anel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>Ohne Schaltplan läßt sich natürlich nicht so viel sagen.
Denn kann ich leider nicht veröffentlichen.

>>Ist es moeglich ein Spektrum des Rauschens zu bestimmen ?
Soweit ist die Software noch nicht, es sieht recht weiß aus.
Es ist erkennbar, wenn ich die Samplefrequenz auf 400K Samples erhöhe 
und mir die dezimalen Werte anschaue.
Es hat auch einen Anteil im Bereich über 100 KHz.

>>Die Speisung ist linear, ohne Switcher nehm ich an.
Jein, ein Induktiver Wandler erzeugt die Vorspannung, die durch einen 
niederohmigen Tiefpass in einen low-noise Linearregler eingespeißt wird. 
Die Versorgung hat ein Rauschen, das unter einem mV liegen muss, 
jedenfalls ist auf einem analogen Hameg, als auch auf einem digitalen 
Tek im 10mV-Bereich nichts zu erkennen.

>>Ersetze den X7R-Typ doch mal durch einen MKS2-Typ, oder schnippe mit dem
>>Finger auf die Platine, dann siehst du ja schnell, ob es Mikrofonie ist.
Ich werde nächste Woche mal den NPO und MKS2 probieren, falls ich sowas 
im Labor finde. Ich habe zwar die Schaltung hier, aber kein Sortiment an 
Kondensatoren.

Es muss irgendwas mit dem Kondensator und/oder dem DAC zu tun haben, 
weil der ADC zwei Kanäle gleichzeitig sampelt und die beiden OPs an den 
Eingängen im gleichen Gehäuse sitzen. Auch die Verstärkungsfaktoren sind 
etwa gleich, nur wird der eine Eingang um den Offset vom DAC angehoben 
und der andere nicht. Das der DAC ein Rauschen hat, kann ich deutlich 
sehen. Kanal 1 (ohne Offset) hat ein Rauschen von unter 10 (dezimal), 
Kanal 2 von unter 70 (ohne Kondensator) und über 500 mit Kondensator.


Die Genauigkeit ist für mich gut genug, mich interessiert nur der Grund, 
warum sich das Rauschen so verstärkt, wenn ein kleiner 100nF dran ist.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Anel,
Hast du diese Frage übersehen?

> Der Ausgang dieses DACs verträgt nur 1nF laut Datenblatt.
> Hast du etwa die 100nF direkt an den Ausgang des Verstärkers vom DAC angelötet?
> Falls ja, dann besteht die Gefahr, dass der Verstärker im DAC schwingt.

Autor: Anel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>Hast du diese Frage übersehen?
Ja, habe ich tatsächlich, war nicht bös gemeint!

Ich verstehe das Datenblatt so, dass das für den dynamischen Betrieb 
gilt.
Das ist bei mir nicht so. Ich stelle einmal eine Spanung ein und das war 
es dann. Warum sollte ein OP schwingen, wenn ich einen kleinen 
Kondensator dranhänge? Es ist keine Induktivität vorhanden und die paar 
nH von der Leiterbahn sollten das auch nicht bringen. Ich verlangsame 
damit die Anstiegszeit, aber mehr auch nicht(?) Das musst du mir jetzt 
erklären...

Autor: Helmut S. (helmuts)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier mal ein Beispiel was bei einem realen Opamp passiert. Beachte den 
Peak in der Verstärkung. Genauso wird dein Rauschen ge"peak"t.

Mit der .asc-Datei kannst du das mit LTspice simulieren.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Warum sollte ein OP schwingen, wenn ich einen kleinen Kondensator
>dranhänge? Es ist keine Induktivität vorhanden und die paar nH von der
>Leiterbahn sollten das auch nicht bringen.

Aber du erzeugst am invertierenden Eingang eine Phasendrehung (phase 
lag), die den OPamp instabil macht. Helmut hat völlig Recht. Du darfst 
nicht einfach einen 100nF Kondensator direkt an den Ausgang eines 
Operationsverstärkers hängen! Schalte wenigstens einen Widerstand von 
größer 50R (genauer Mindestwert hängt vom OPamp ab) dazwischen. Dieser 
Widerstand hilft dir übrigens zur zusätzlichen Filterung des Rauschens 
und ist schon von daher zu empfehlen.

>Denn kann ich leider nicht veröffentlichen.

Das verstehe ich. Aber wenn ein Fehler vorliegt, ist er sowieso nichts 
wert. Jetzt können wir dir nur Tips geben, aber kaum wirklich dein 
Problem lösen.

Kai Klaas

Autor: Anel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen!

@Helmut: Das die Dinger so reagieren können, hätte ich nicht gedacht, 
danke für die Simulation.

Den Tiefpass einbauen kann ich nicht mehr, aber ich kann einen Jumper 
durch eine kleine Spule ersetzen. Das probiere ich morgen mal aus.

>>...aber kaum wirklich dein Problem lösen.
Ich habe kein wirkliches Problem, mich interessierte, wie oben gesagt, 
nur das "warum".

Ich bedanke mich bei euch und wünsche einen schönen zweiten Ostertag!

Autor: Helmut S. (helmuts)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Die Idee mit der Spule ist nicht gut. Da macht sich ein kleiner 
Serienwiderstand schon besser.

Autor: T. C. (tripplex)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe aber schon Applikationen gesehen da hat TI einen Kondensator 
über 1µF  ( waren glaube ich 4.7µF )direkt, ohne über einen Widerstand 
entkoppelt am Ausgang des OPV gekoppelt.
Hat jemand eine erklärung dazu, würde mich interessieren.
Ist aber ein wenig blöde da ich die Applikation nicht finde ich weiß 
aber
noch das es um einen Low Noise Spannungsregler ging.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Man könnte natürlich einen normalen Elko (>=10uF) mit mindestens 1 Ohm 
Serienwiderstand(ESR) verwenden. Keine Sorge, das ist nur ein Bauteil. 
Der ESR ist "eingebaut". Vielleicht gibt es ja auch einen schlechten 
Tantal mit >= 1Ohm ESR.

Autor: Helmut S. (helmuts)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Im Anhang sind die Simulationen mit Elko 10uF, 47uF mit 2Ohm ESR.

Autor: Anel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich glaube Helmut hat mich falsch verstanden. Ich baue eine Spule, 
besser eine Ferritperle, sofern ich eine finde, in Serie ein, den 
Kondensator muss ich weglassen, weil der einfach nicht reinpasst. Einen 
bedrahteten Kondensator will ich nicht einlöten, weil ich dann eine 
Schleife hätte, die wahrscheinlich mehr Rauschen von der 
Schaltreglerspule einfängt als eliminiert wird.

Autor: Anel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Jumperkontakt, wo die Spule rein soll liegt hinter den Pads für den 
100nF. Darum geht nicht beides.

Autor: Dieter Werner (dds5)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier ein Ausschnitt aus dem ADS1251 Datenblatt von TI mit einemm 
Vorschlag der Referenzspannungserzeugung.

Der Ausgang des OP wird massiv kapazitiv belastet, es besteht aber 
offenbar trotzdem keine Schwingneigung.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für den Tipp mit dem OPA350. Der ist an sich schon rauscharm und 
scheint in der Tat besonders gutmütig zu sein bezüglich kapazitäter 
Last.
Aus dessen Datenblatt:
In unity gain, OPA350 series op amps perform well with
very large capacitive loads. Increasing gain enhances
the amplifier’s ability to drive more capacitance. The
typical characteristic Small-Signal Overshoot vs
Capacitive Load shows performance with a 1kΩ
resistive load. Increasing load resistance improves
capacitive load drive capability.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ich habe aber schon Applikationen gesehen da hat TI einen Kondensator
>über 1µF  ( waren glaube ich 4.7µF )direkt, ohne über einen Widerstand
>entkoppelt am Ausgang des OPV gekoppelt.
>Hat jemand eine erklärung dazu, würde mich interessieren.

Es gibt spezielle OPamps, die große Kapazitäten am Ausgang vertragen.

Auch normale OPamps können scheinbar gutmütig auf sehr große Kapazitäten 
am Ausgang reagieren. Das kommt so: Die Kapazität sorgt zusammen mit der 
endlichen Ausgangsimpedanz nicht nur für eine destabilisierende 
Phasendrehung in der Gegenkopplung, sondern auch für eine kräftige 
Absenkung der Schleifenverstärkung, sodaß die Schleife nicht mehr auf 
die Mindestverstärkung von V=1 zum Aufbau einer Schwingung kommt, trotz 
gefährlicher Phasendrehung von insgesamt 360°. Solche Situationen findet 
man beispielsweise, wenn man mit einem LM324 aus einer Single Supply 
Spannungsversorgung einen Virtual Ground Generator bastelt und dazu 
direkt vom Ausgang zu den beiden Supply Rails jeweils einen Elko von 
47µF schaltet.

Ein solcher OPamp verfügt dann aber über fast überhaupt keine 
funktionierende Gegenkopplung mehr, sondern ist praktisch tot. Er 
kriecht DC-mäßig zu dem Pegel, den die Gegenkopplung ihm diktiert, kann 
aber auf schnelle Störungen nicht mehr wirklich regelnd eingreifen. Sein 
Ausgang wird schon für niedrige Frequenzen durch den Kondensator 
kurzgeschlossen, was sich dann so auswirkt, als ob man bei einem Auto 
gleichzeitig Vollgas gibt und wie ein gestörter auf die Bremse tritt.

Solche Schaltungen sind hochgradig gefährlich, weil sie nicht mehr 
linear funktionieren und jederzeit Unfug treiben können.

Außerdem, täusche dich nicht, nur weil du das bei Texas Instruments 
gefunden hast, muß das noch lange nicht richtig sein. Auch dort gibt es 
jede Menge Pfuscher, die keine Ahnung haben...

Kai Klaas

Autor: T. C. (tripplex)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schrott in Applikation Notes finde ich unter aller Sau, schlecht für den 
Entwickler darauf vertraut und ist auch richtig schlechte Werbung für 
einen Hersteller. Wobei der Entwickler selber schuld ist wenn er blind 
vertraut :D
---


Erinnert mich an "Test Pin" welche auf fester Spannung gelegt werden 
müssen
aber nirgendswo steht was man wirklich mit den Testpin anfangen kann und
somit den µC oder etc hacken kann. Wenn es dann auch noch eine 
Applikation im Sicherheitsbereich ist, wird's erst recht ekelig.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.