mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Reset bleibt nach Programmieren auf Null


Autor: gm f (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe das auf
http://www.avr-asm-tutorial.net/avr_de/beginner/index.html vorgestellte
Experimetierboard(AT90S2313) nachgebaut, möchte es aber mit dem
Parallelport-ISP von http://www.mikrocontroller.com/ und PonyProg
programmieren. Leider muss ich nach dem Download immer den Stecker aus
dem Port ziehen bevor das Programm abläuft, weil der Reset nicht auf Hi
geht. Wenn ich in PonyProg auf Reset drücke, geht der Resetausgang am
ISP kurz auf Hi, fällt aber gleich wieder ab. Kann mir jemand weiter
helfen? Danke im vorraus

Autor: Thomas Burkhardt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

deine Schaltung hat einen Pull-Up am Resetpin? Mmmh, laut Schaltplan
schon. Ich hatte auch mal eine Zeitlang Probleme mit dem Pony, aber ich
weiss nicht mehr, was ich dagegen getan habe... Ausser vielleicht auf
SP12 zu wechseln :-D

Autor: Benedikt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du villeicht einen Drucker am PC hängen, bzw. einen Druckertreiber
installiert ?

Autor: gm f (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eigentlich hängt mein Drucker am USB-Port. Im Geräte-Manager steht aber
schon "...Druckerport-Treiber" oder so ähnlich. Ich hab auch schon
versucht hier den Port als Kommunikationsport zu installieren, funtst
aber nicht. Ich frag mich ja nur, warum der Resetausgang vom ISP, wenn
ich in PonyProg auf "Reset" drücke, nach einem kurzen Hi-Signal
wieder auf Low geht? Erwartet PonyProg irgendein Bestätigungs-
signal von einem der anderen Pins, andernfalls kann es doch nur an
LapTop(Windows oder PonyProg) liegen, oder?

Autor: Tobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
pony erwartet keine bestätigung. hast du mal gesmessen, was an dem
druckerport für ein pegel anliegt und was an dem uC genau anliegt
(wieviel volt)

Autor: gm f (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein, ich hab ihn jez leider auch nicht zur Hand. Als Stromversorgung
nehme ich drei Mignon Bat. also U=4,8V. Zwischen GND und dem Reset-Pin
waren immer so 200mV, denk ich.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.