mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Keine Verbindung zum ATmega 2561 mit MK3 Programmer


Autor: Christoph (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
der Programmer erzählt mir immer das er keine Verbindung findet und den 
Controller nicht erkennt, ich habe schon mal probiert nach dem Speed zu 
scannen, dies ergibt in jeder geschwindigkeit einen Error.

Jedoch zu dem Orginalen Board was ich habe (MK2 mit ATmega8) bekomme ich 
eine Verbindung...

Zur Beschaltung:
Habe am µC einen Quarz mit 16MHz (von Conrad) und 2 22pF Kondensatoren, 
der Resetwiderstand ist mit 10k gegen VCC geschaltet der Reset zum 
Programmer direkt verbunden.
SCK MISO... sind Verbunden.
Leider erkennt das AVR Studio oder Sisy nicht den µC der Programmer 
jedoch wird erkannt....

Falls ich etwas doppelt poste oder einen Dummen Anfängerfehler gemacht 
habe tut es mir leid, für hilfe wäre ich sehr dankbar!


MFG Christoph

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>SCK MISO... sind Verbunden.

Falsch. Der ATmega2561 wird nicht über MISO/MOSI programmiert, sondern 
über TXD0/RXD0.

MfG Spess

Autor: Christoph (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ohha also doch nen Anfäger fehler
wie muss ich das von meinem MK3 Programmer dann anschießen?
Habe mal die beschaltung vom Programmer mit angehängt.

Schon mal in vorraus vielen dank!!!

MFG Christoph

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Siehe Datenblatt ATMega2681:

Memory Programming->Serial Downloading->Serial Programming Pin Mapping.

MfG Spess

Autor: Christoph (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hab zwar was gefunden nur wie schieße ich das jetzt an?
Welchen Programming Mode brauche ich?!

Hab mal einen Ausschnitt aus dem Datenblatt angehängt

Danke!

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>Welchen Programming Mode brauche ich?!

Programming Mode wovon?

MOSI -> PDI
MISO -> PDO

MfG Spess

Autor: Christoph (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke!!!,
werde ich zuhause gleich nach der Schule testen!
Hoffe es klappt dann!

Autor: Christoph (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Super das hat funktioniert,
jetzt habe ich ein anderes Problem wenn ich den Programmer (MK3) 
Abstecke fängt die Schaltung an zu "zicken" oder hängt sich auf!
Hat da noch jemand eine Idee woran es liegen könnte?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.