mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit Atmega128


Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!
Ich versuche gerade eine Schaltung mit einem neuen Atmega128 zu bauen 
aber leider schaffe ich es nicht diesen Mikrocontroller mit avrdude 
anzusprechen...
Ich habe bereits daran gedacht Anstelle MISO/MOSI PDO/PDI zu nutzen, 
\Reset liegt zusätzlich über 10k an VCC, SCK ist SCK, \PEN ist 
unbeschaltet...

Weitere Beschaltung als die normalerweise minimal nötigste zum 
Programmieren habe ich nicht dran (außer VCC und GND versteht sich)

Betriebsspannung ist 5V und kein Quarz angeschlossen (standardmäßig ist 
doch der interne Oszillator mit 1MHz aktiviert?)

getestet habe ich die Verbindung mittels STK200 und usbasp und das 
Ergebnis ist jedesmal das gleiche, absolut keine Raktion vom 
Atmega128...
Mit meinen Attiny13 und Atmega8 Schaltungen funktionieren diese 
tadellos...

Stromverbrauch des Megas liegt bei ca 12mA. ist das in Ordnung oder 
müsste das weniger sein? nicht das der kaputt ist...

Hatte jemand schonmal ähnliche Probleme und hat einen Tip für mich?

Gruß Frank

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Ich habe bereits daran gedacht Anstelle MISO/MOSI PDO/PDI zu nutzen,
\Reset liegt zusätzlich über 10k an VCC, SCK ist SCK, \PEN ist
unbeschaltet...

MISO/MOSI ist falsch. PDO/PDI ist richtig.

MfG Spess

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hab ich schon, das meinte ich ja mit dem "Anstelle" von...

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du alle Vcc und GND-Anschlüsse an 5V und Masse angeschlossen und 
mit 100nF abgeblockt?

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja, habe ich... allerdings sind die 100nF hinter ca. 5cm Kabel direkt 
beim 7805...
...andersrum wäre sicherlich optimaler, gab aber dadurch noch nie 
Probleme

Autor: Volker R. (pcl86)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

gönne /PEN mal einen Widerstand von ca. 10k nach VCC.

Hatte ähnliche Probleme am Anfang, mit dem Widerstand lief´s dann aber.

Gruß
Volker

Autor: Winfried J. (Firma: Nisch-Aufzüge) (winne)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
\PEN kann frei bleiben

zum Programmieren müssen PDI und PDO  benutzt werden

PDI ist der Programmiereingang entspricht somit MOSI der sonst üblichen 
ISP
PDO ist der Programmierausgang Entspricht somit MISO der sonst üblichen 
ISP

SCK ist SCK

Reset muss über 10K an VCC und wärend des Programmierens auf low gezogen 
werden

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe nochmal getestet PEN mit 10k auf VCC zu ziehen, hat nichts 
geändert...

wie gesagt meine Programmierkabel funktionieren an meinen anderen 
Schaltungen  wunderbar, nur eben nicht an dieser...
und es ist definiv korrekt angeschlossen an SCK, RESET, PDO, PDI, VCC 
und GND...das habe ich schon mehr als 10x nachgemessen.

gibt es möglichkeiten zu testen ob ein neuer, leerer Mikrocontroller iO 
oder defekt ist?

gruß Frank

Autor: Winfried J. (Firma: Nisch-Aufzüge) (winne)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mh es könnte noch an der cklockrate liegen? Wie sieht dein 
Programmieradapter aus?
Hoffentlich nicht Parallelport, da gibt es gern Schwierigkeiten

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mir ist noch kein defekter, neuer AVR untergekommen.

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Mach mal ein Bild von deinem Aufbau.

MfG Spess

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.