mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik SFH 5110-36 Probleme


Autor: Bastler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Abend!

Ich habe einige Tests mit Infrarot in letzter Zeit unternommen!
Jetzt wollte ich mich an die Klassische IR-Kollisions messung für 
Roboter wagen.
Ich habe als Sende-Diode eine SFH415 die mit der Frequenz von 36kHz mit 
einem NE555 betrieben wird (Diode mit Vorwiderstand direkt am Ausgang 
des NE555)
Als Empfänger hab ich den SFH 5110-36, der auf die Frequenz von den 
36kHz abgestimmt ist! Den hatte ich noch da, drum hab ich den genommen 
;-)

Jetzt hab ich den Ausgang des Empfänger an die Basis eines BC547 (NPN) 
gehängt, die dann eine LED schaltet!

Die IR Sachen stehen sich mit ca. 4 cm Abstand genau gegenüber, also 
nicht wie beim Roboter später. Aber wenn ich am Ausgang des Empfängers 
mess, dann mess ich hier IMMER 0,7V, was ja bekanntlich für ein LOW 
spricht.
Der Empfänger arbeitet auch mit aktiv low!
Jetzt meine Frage, wann wechselt der Ausgang auf High oder wie mach ich, 
dass der Transistor nicht schaltet, denn mit den 0,7V schaltet der ja 
-.-

Weitere Überlegungen ergaben bei mit, dass der SFH 5110-36 eher selten 
als Abstandsmesser benutzt wird, öfter seh ich hier den TOSP1736.

Mit freundlichen Grüßen
Bastler

Autor: David (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du solltest einen PNP Transistor nehmen. Der Pullup im SFH ist ev.zu 
groß um einen NPN Transistor durchzuschalten (SFH = Low-Aktiv).

Du solltest mal an den Ausgang des Empfängers ein Oszi halten und 
schauen, was da ab geht.

Der TOSP1736 ist eine neuere
Generation des SFHs (zb Philips, Osram) und funkt gut (zB bei dem großen 
C).


Schöne Grüße David

Autor: Michael M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
die 0,7V, die du misst, sind die BE-spannung deines transistors.

wie sicher bist du dir denn mit der frequenz deines oszillators?
lass doch mal ein bisschen schaltung sehen.

Autor: twitter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wie sieht das aus, hast sonst noch andere foren bemüht?
das dir ja geholfen wird!
http://www.roboternetz.de/phpBB2/viewtopic.php?t=54234

Autor: twitter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich darf dann mal den autor zitiren aus dem andern forum:

>Bin jetzt auch etwas weiter, ich hab jetzt schon mal den Fehler gefunden, >ich 
hatte ne falsche Pinbelegung, jetzt mit der neuen geht es!

somit muss sich hier also nieman mehr gedanken machen da das problem ja 
schon lange gelöst ist.

aber erst mal in 2-3 foren sein probleme schildern so das team a 
unabhängig von team b arbeitet und du, weil ja schlau bist, die dir am 
besten gefallende antwort nimmst.
was in dem falle ja gar nicht so weit gekommen ist da du ja nicht mal 
die verkabelung hinbekommen hast.

SCNR

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.