mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Edisen Ee301P


Autor: Johannes M. (johannes_m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe folgende Frage:

In welchem Bereich sollte ich die Widerstände (R_F, R_C) und den 
Kondensator (C_F) dimensionieren (Sind bei den Sensorflächen vor dem 
Eingang zum IC):

Anbei noch einmal das Datenblatt, auf dem auch der Anschlussplan zu 
sehen ist...
http://www.edisen.de/cms/download_user/977_Datenbl...

Wäre für Hilfe dankbar...weil alle Versuche die ich bisher hatte, haben 
irgendwie nicht funktioniert....habe alles von 100 bis 1M Ohm 
ausprobiert gehabt und auch verschieden Kondensatoren...aber dann hab 
ich am Ausgang immer nur die komplette Spannung anliegen....ich verstehs 
ned so ganz...des Signal wie im Datenblatt beschrieben, bekomm ich 
einfach nicht raus....

Bitte helft mir...

Autor: Lehrmann Michael (ubimbo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Poste mal deinen Schaltplan rein - ich kann mir nicht vorstellen, dass 
es an den R & C liegt wenn du schon soviel probiert hast.

Autor: Johannes M. (johannes_m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ähm Schaltplan ist in der PDf drin auf Seite 3

http://www.edisen.de/cms/download_user/977_Datenbl...


habs so aufgebaut ... mir fehlt nur noch die beschaltung der 
messelektroden zu ground...ist auch so was wie beschrieben, wei mans 
macht auf der Seite aber ich bin etwas davon verwirrt....

Was ist zb. Cinx? ansosnten Formeln einsetzen kann ich ja....nur 
irgendwie fehlen mir ein paar Werte dazu...oder steh ich bloß aufm 
Schlauch?

Autor: Johannes M. (johannes_m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi, ich hab jetzt mal ein bisschen mit verschiedenen Modifikationen 
rumprobiert aber bisher hab ich immer noch keinen Erfolg, dass der 
Sensor funktioniert:

Hat irgendjemand eine Idee in welcher Größe Rf , Rc und Cf sein müssen?

Bisher hab ich Cf im Picobereich (10pF) , Rc und Rf eher im 
Megaohmbreich gewählt...

Meine einzigen erfolge bisher sind bei Berühren, dass die 
Ausgangsspannung um 5 mV nach unten geht, da ich aber einen 
Annäherungssensor machen möchte, ist das noch nicht zufriedend 
stellen...

Hat einer bessere Vorschläge, wie ich das dimensionieren kann?

Habe kürzlich auch die Wider stände im KiloOhm Bereich gewählt und dann 
ist die Spannung einfach nur langsam angestiegen bis zum Maximalwert und 
nichts weiter passiert.....

Hoffe mir antwortet jmd der den Sensor schon erfolgreich im Einsatz hat, 
würde mich sehr freuen^^

Vielen Dank im Vorraus

Autor: Hendi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich
habe den Ee102p erfolgreich im Einsatz. Das dürfte so ziemlich das 
gleiche sein, nur das es halt nur ein Sensorkanal hat. Die Widerstände 
die da am Sensor hängen, habe ich damals komplett weggelassen, da es mit 
denen bei mir auch nicht funktioniert hat. Geht also auch ohne. Habe 
zwei von den Schaltungen im Dauereinsatz (Lichtschalter) und 
funktioniert tadelos. Ich habe die komplette Beschaltung aus einem PDF, 
das ich bei google gefunden habe, da ich am Anfang relativ wenig Erfolg 
mit den Sensoren hatte. Bei Bedarf kann ich es gerne posten.

Autor: Johannes M. (johannes_m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oh das ist cool bitte poste das unbedingt mal wies du aufgebaut hast...

Autor: Hendi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Also hier hab ich das PDF mal in den Anhang. Es beinhaltet eine relativ 
genaue Beschreibung wie die Methode von Edisen funktioniert und wie die 
Schaltung aufgebaut ist. Der obere Teil des Schaltplans ist für dich 
denke ich mal nicht wichtig, da dieser nur zur Spannungsaufbereitung o.ä 
gedacht ist. Interessant dürften für dich die Kondensatoren und 
Widerstände sein. Du kannst ja mal mit den Widerstandswerten probieren. 
Wenns nicht geht lass die W. zum testen mal weg. Achja die Widerstände 
sind soweit ich weiß auch von der Größe deiner Sensorfläche abhängig, da 
müsste im Datenblatt eine Formel sein um diese auszurechen. Lese mal den 
Text im PDf da ist das alles ausführlich beschrieben. Viel Spaß damit!

Autor: Johannes M. (johannes_m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmmm also ich hab die Beschaltung genauso gemacht, aber irgendwie funzt 
es nicht richtig....

Man sollte ja am Ausgang so was wie eine Spannung bekonmmen, die für die 
gemessene Kapazität steht?

Und laut Datenblatt soll die Spannugn ja hochgehen, wenn man sich 
annähert...bei mir passiert aber genaus das Gegenteil...I'm confused...

Irgendwas funktioniert da nicht.....

Autor: Hendi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Häng nochmal en Widerstand und ein Transistor an den Ausgang muss nicht 
der  gleiche wie in der PDF sein. Hast du die Widerstände am Eingang 
dran oder nicht? Zeig doch mal dei Aufbau
Gruß, Hendi

Autor: Johannes M. (johannes_m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jup hab die Widerstände am Eingan dran, wenn ich se weglass und auch den 
Kondensator reagiert der Sensor bloß, wenn man direkt den Pin 
berührt...also nix mit Annäherung und so....und der sensor ist dann auch 
so was von träge im ansprechverhalten...

Warum soll ich denn den Transistor hinten dran schalten? Ich will ja 
eben nicht nur nen Schalter umlegen, sondern ich will danmit 
unterschiedliche Kapazitätsstufen messen (Füllstand)

Und mein Aufbau: Übrigens hab ich den Ee 301P aber müsste ja das gleiche 
sein:
Habs wie im Datenblatt gemaacht:

http://www.edisen.de/cms/download_user/977_Datenbl...

Seite 6 --> da ist die Beschaltung...

Hoffe du kannst mir helfen...

Autor: Hendi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mhm das is seltsam. Bei mir funktioniert das ganze durch 6mm Plexiglas 
und er reagiert auch sofort, wenn ich meinen Finger leicht auf dieses 
leg. Hast du genau die Kondensatorwerte aus dem PDF? Wie das bei 
Füllstandsanzeigen mit dem Auswerten usw. geht davon hab ich leider 
keine Ahnung aber ich glaube, dass ich hier schonmal einen Thread dazu 
gesehen habe. Aber es wird ja hier bestimmt noch mehr Leute geben, die 
sich mal damit befasst haben außer uns zwei :D

Autor: Johannes M. (johannes_m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Beschaltung wie im Datenblat....ja....es funzt bisher eigentlich gar 
nicht....

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.