mikrocontroller.net

Forum: Compiler & IDEs AVR Studio 4.18 Einstellungen speichern


Autor: Alf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Etwas OT:

Wenn ich im AVR Studio ein Projekt öffne, werden sofort alle 
dazugehörigen Dateien, Header usw. in dem Editorfenster geöffnet.

Wie kann man das unterbinden? Ich will max. die zuletzt bearbeitete 
gleich geöffnet haben, möglichst auch noch maximiert. Selbst wenn ich 
alle zu mache und dann das Projekt neu speichere, sind sie beim nächsten 
starten wieder alle offen.

Autor: Grübler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Fenster werden doch beim Öffnen
übereinandergelegt. Du brauchst nur einen
Klick auf Maximieren bei dem von dir
gewünschten Fenster.

Ein Klick: "Schaffst du schon"

Autor: Michael B. (planlessmichi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also das Maximieren geht über die Optionen 
(Tools-->Options-->Workspace-->Maximize); aber das mit der Anzahl der 
geöffneten Dateien weiß ich jetzt auch nicht. Das ist bei mir jedesmal 
anders. Manchmal werden nur ein paar, manchmal auch mehr geöffnet...

Autor: Matthias K. (matthiask)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich glaube es ist so, dass alle Dateien automatisch geöffnet werden, die 
man irgendwann selber mal geöffnet hat. Auch wenn man die wieder 
schließt werden sie beim nächsten Start wieder geöffnet. Betrifft auch 
die Externals, was ein ziemliches Fensterchaos verursacht.

Gefällt mir auch nicht, war früher nicht so. Konnte es bisher nicht 
unterbinden.

Autor: Grübler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei mir klappt folgendes:
Fenster die man nicht mehr braucht schließen.
Dann im Menu    File -> Save All  klicken.

Beim nächste Start gehen nur die Fenster auf,
die zuletzt geöffnet waren.

Vielleicht liegt es auch hier dran:

Ich nutze das AVR Studio 4.18 unter Win 7 Home Prof. 32Bit.
Da mir Courier nicht gefällt, habe ich eine andere
nichtprop. Schrift auf meinem Rechner gewählt.
(Menu: Edit -> Fond and Color...)

Nach dem Neustart des Studios war aber wieder Courier
eingestellt. Diese Problem habe ich nur dadurch lösen
könne, dass ich das AVRStudio einmal, direkt nach der
Installation(!), mit Administratorrechten gestartet habe.

Rechte Maustaste auf das AVRStudio-Icon und dann "Als Admin ausführen"

Obwohl ich als User Adminrechte habe, ist das wohl noch
ein Unterschied.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.