mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik USBProg vid=0000 und pid=0000


Autor: Ronald Fiedler (juedler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo liebe Gemeinde ich benötige mal wieder einen kleinen Hinweis.

Ich habe mir nach dem Schaltplan von Benedikt Sauter den USBProg so weit 
möglich ohne SMD auf eine Platine gebaut. Als Prozessor kommt der 
ATMEGA32-16PU (DIL) zum Einsatz. Ich habe den Mikrocontroller geflasht 
und die Fuses nach Anleitung gesetzt. Leider habe ich ein Problem mit 
dem USB.

Mein WinXP zeigt als vid und pid nur nullen an. Daher ist auch keine 
Treiberinstallation möglich.

Die gn LED leuchtet ständig und die rt macht 2x kurz an - Pause - 2x 
kurz an - Pause ....

Wo liegt mein Problem? Ist es der USBN9604 oder der ATMEGA? Von welchem 
kommen die vid und pid's? Auch Linux konnte mir nicht mehr helfen. 
Vielleicht kennt ihr das Problem. Ist vielleicht ein Chip hin?

Vielen Dank!

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Wo liegt mein Problem?

Falsch aufgebaut. So einfach ist das. So, jetzt such mal weiter.
Ich hab zwei davon nachgebaut. Funktionieren.

>Von welchem kommen die vid und pid's?

Vom ATMega durch den USBN durch an USB.

Autor: Ronald Fiedler (juedler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falsch aufgebaut würde ich gern ausschließen, da ich vom original 
Eagle-Schaltplan das Board habe ätzen lassen. Gibt es denn vielleicht 
Unterschiede zw. der SMD und DIL Variante des ATMEGA32?

Autor: Vlad Tepesch (vlad_tepesch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
du hast irgendwo einen fehler in der Schaltung.
Mess noch mal alles durch und such auch nach kurzschlüssen auf den 
Datenleitungen.

Das von dir beschriebenen Phänomen (vid =0 pid=0)kenn ich auch. Da war 
bisher immer ein Schaltungsfehler schuld

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.