mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LCD Hintergrundbeleuchtung


Autor: olli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen,

habe mir gerade ein 16 x 2 LCD angeschlossen und mußte feststellen, dass 
ich die Hintergrundbeleuchtung irgendwie nicht anbekomme.
Nach dem Datenblatt ist die Hintergrundbeleuchtung an die Pins 15 und 16 
des LCD anzuschliessen. (Pin 15 A/Vee, 4,2v for LED/negative Voltage 
output.....Pin 16 K, Power supply for B/L (0V))
Habe nun 5 V an Pin 15 und Masse an Pin 16 angeklemmt, aber es geht 
nicht.

Kann mir jemand sagen, wie man das Ding anschliessen soll?

Olli

Autor: A.Füßer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Habe nun 5 V an Pin 15 und Masse an Pin 16 angeklemmt, aber es geht nicht.
Auch nicht 1x gaaanz kurz? :-)
LED-Vorwiderstand nicht vergessen: (5V-4.2V)/20mA=40Ohm -> 47Ohm passen 
schon.
Also +5V---R(47 Ohm)---Pin15       Pin16---GND.
Evtl. sind die LEDs schon durchgebrannt.

Falls du auf die Idee kommen solltest die Hintergrundbeleuchtung per AVR 
ein/auszuschalten...:
http://www.CANathome.de/Dokumentation/Kapitel2.htm...

André.

--
CAN@home - http://www.CANathome.de - Hausautomation mit AVR + CAN

Autor: olli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habs gerade nochmal mit einem ganz neuen Display probiert. Geht leider 
nicht...nicht mal gaaaaanz kurz :-)

Da sind noch rechts zwei Lötpins dran. Steht A bzw. K davor. Könnte es 
damit was zu tun haben?


Olli

Autor: olli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe nochmal mir das LCD angeschaut, welches problemlos geht. Da sind 
die beiden oben erwähnten Lötpins A und K mit einem weißen dünnen 
plättchen verbunden, wo noch 5V aufgedruckt ist. Was ist denn das?

Olli

Autor: Holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
A heißt aller Wahrscheinlichkeit nach Anode, K Kathode. Vermutlich sind 
genau das die Anschlüsse der Hintergrund-LED (A ist plus, K ist Minus). 
Sonst hat André Recht: Keinesfalls ohne Vorwiderstand anschließen!

Autor: A.Füßer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und du bist dir sicher daß die LCDs auch eine Hintergrundbeleuchtung 
haben? Du erwähnst, daß du bei dem mit der funktionierenden Beleuchtung 
die weiße Plättchen siehst, die die anderen nicht haben, deshalb die 
Frage.
Ich habe hier welche mit dem weißen Plättchen (und 16Pins) mit 
LED-Beleuchtung und welche ohne dieses Plättchen (und 14Pins) ohne 
LED-Beleuchtung. Ich deute das weiße Plättchen als 
Rahmen/Halterung/Gehäuse der HintergrundLEDs.

Der Widerstand sollte wie oben beschrieben 47 ohm sein, nicht, wie man 
vielleicht in Eile lesen könnte, 470 ohm.

André.

--
CAN@home - http://www.CANathome.de - Hausautomation mit AVR + CAN

Autor: Ralf Hochhausen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Olli,

bei manchen LED's ist es notwendig ein paar Lötbrücken zu ändern. Diese 
sind notwendig um die Spannungsversorgung von den seitlichen Kontakten 
auf die Pins 15 und 16 umzulegen. Du mußt mal ins Datenblatt schauen, 
die genaue Änderung weiß ich im Moment auch nicht. Ich mußte diese 
Änderung aber schonmal auch der Arbeit durchführen, hatte dort das 
gleiche Problem. Die Pins wo A und K drauf steht sind normalerweise die 
richtigen Kontakte für die Beleuchtung. Dort kann man normalerweise auch 
noch Lötpins anbringen um die Beleuchtung von dort ohne Änderung zu 
betreiben.

Viele Grüße

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tach Olli,
nimm doch mal ein Ohmmeter. Den einem Pin ( A ) antippen und mit dem 
Anderen an Pin 15. Wenn Verbindung dann nochmal von Pin K na ch Pin 16 
messen. Wenn auch Verbindung, dann +Pol von Ohmmeter an A und -Pol von 
Ohmmeter an K, Kann man was Messen, so im Ohmbereich? Wenn ja +Pol des 
Ohmmeters an K und -Pol an A. Kann man auch hier was Messen? Wenn ja, 
Displaybeleuchtung kaputt (bei LED`s zur Beleuchtung).

Ist die Verbindung von A nach 15 und von K nach 16 nicht vorhanden, 
kannst du die Spannung über Vorwiderstand direkt an A und K anschließen.

Gruß,
Günter

Autor: olli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen,

vielen Dank für die vielen Zuschriften. Leider ist das Problem nicht 
gelöst.

Bin mir eigentlich sehr sicher, dass die LCD eine Hintergrundbeleuchtung 
haben, da sie einerseits mit 16 Lötpins bestückt sind, andererseits auch 
von mir extra mit Hintergrundbeleuchtung bestellt wurden.

Interessanter Weise habe ich ja ein funktionierendes (das Sagenumworbene 
mit dem weissen Plastik an A und K - von Conrad) Genau das gleiche habe 
ich auch noch einmal ohne Plättchen (gleiche Bestellung). Dann habe ich 
noch 2 Stück von Electronic Assembly. (16x2) Sollten auch mit 
Hintergrundbeleuchtung sein.

Hier kurz meine Resultate: Eine Verbindung von A nach Pin 15 bzw. K nach 
Pin 16 besteht nicht.
Habe daher direkt versucht, die Hintergrundbeleuchtung an A und k 
anzuklemmen. Hatte leider keinen 47 Ohm Widerstand. Habe so erstmal 
einen 100 Ohm Widerstand bzw. einen 33 Ohm Widerstand genommen. Aber, 
egal was ich gemacht habe, es rühte sich nichts.

In den jeweiligen Datenblättern ist leider fast nichts zum Thema 
Hintergrundbeleuchtung zu finden. Bei EA fand ich lediglich, dass die 
Beleuchtung mit einem Vorwiderstand anzuschliessen ist.

Vielleicht hat ja noch jemand ne Idee...

Olli

Autor: Rudolf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du die Polarität richtig herum? Vom PLUS des Netzteils zum 
Widerstand, vom Widerstand zu A, von K zum MINUS des Netzteils.
Das Netzteil sollte 5V liefern, Stromaufnahme je nach Displaygröße 
mehrere 100mA.

Gruß, Rudolf.

Rudolf Sosnowsky +++ LC Design
EPSON Technology Partner
Internet http://www.LC-Design.de

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was ist denn mit der Messung von A nach K geworden (und umgekehrt)?

Gruß,
Günter

Autor: ERDI - Soft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja, ich würde sagen, die Teile haben keine Hintergrundbeleuchtung.
Dass das Display 16 pins hat ist noch lange keine Angabe darüber, ob ne 
Hintergrundbeleuchtung vorhanden ist oder nicht.
Firmen stellen in der Regel nur eine "Universalplatine" für ein Display 
her, das ist billiger und spart Zeit. (D.h.: ein und die gleiche Platine 
für die Version mit Hintergrundbeleuchtung und die Version ohne.)
Das weiße "Plättchen" das du siehst ist entweder eine 
Elektrolumineszenz-Folie (äh, richtig geschrieben?) oder eine 
Plexiglasscheibe, die das Licht der LEDs unter dem Display gleichmäßig 
verteilt.
Wenn unter dem Display ein paar mm Platz sind, dann kann man mit 
Garantie sagen, dass das Teil keine Hintergrundbeleuchtung hat.

Bis denn, ERDI - Soft.

Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Mein Lcd hat auch so ein weißes plätchen mit A und K,hab da 5V 
draufgegeben und die Hintergrundbeleuchtung hat funktioniert.
Bei Pin 15 u. 16 funktioniert sie bei mir nicht steht aber auch A und K
daneben.

Martin

Autor: rene (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Wenn du Null Ohm oder einen unendlichen Widerstand misst, ist die 
Beleuchtung kaputt. Ansonsten: Plus an A und Minus an K und dann die 
Spannung ganz langsam hochregeln, macht man zwar nicht, aber wenn die 
Hintergrundbeleuchtung ganz langsam zu leuchten anfängt, dann sofort die 
Spannung runterregeln, und wissen dass sie in Ordnung ist. Dann kann man 
imernoch den superwichtigen Rv davorbasteln.

Ciao René

Autor: olli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, endlich wieder da...

Erstmal vielen Dank für die vielen Infos. Nachdem ich alle Sachen mal 
durchgetestet hatte, und es immer noch nicht leuchtete, hat mich die Wut 
gepackt und da habe ich das LCD einfach mal auseinander genommen.

Mein Erstaunen war nicht schlecht....es hat keine Hintergrundbeleuchtung 
:-(, obwohl es bei der Bestellung von mir so angegeben wurde und 
tatsächlich über 16 Pins verfügt.

Tja, muß mich da wohl bei allen entschuldigen, dass es mir nicht früher 
aufgefallen ist.

Aber nochmal vielen Dank!!
Olli

Autor: André Füßer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Tja, muß mich da wohl bei allen entschuldigen, dass es mir nicht früher 
aufgefallen ist.

Wieso? Deine Angaben waren doch treffend, einigermaßen vollständig, 
schlüssig, orthographisch und grammatikalisch nachvollziehbar 
formuliert. Daraus konnten dann einige Lösungsvorschläge abgeleitet 
werden. "Schön" finde ich, daß du am Ende die Ursache/Auslöser für dein 
Problem hier bekannt gegeben hast.

André.

--
CAN@home - http://www.CANathome.de - Hausautomation mit AVR + CAN

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, dem stimme ich zu denn das ist nämlich etwas ungewöhnlich.......



Gruß und bis denne,

Günter

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ihr sagtet, anode sei +, kathode sei -

is das nicht genau umgekehrt? ich meine, mir das mal gemerkt zu haben, 
dass kathode + ist, weil das t in kaThode wie ein + aussieht...

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
achne, leds werden ja in sperrichtung angeschlossen (oder?).

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Jonas,
es gibt schon schöne Eselsbrücken z.B.

Induktivitäten,
Ströme sich verspäten.

usw.

Aber das mit der Kathode ist mir neu. Und LED`s werden zu 
Iluminationszwecken auch nicht in Sperrichtung betrieben. Zener-Dioden 
in Stabilisierungsanwendungen schaltet man in Sperrichtung.

Gruß und schönes Wochenende,
Günter

Autor: olli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Halte es eigentlich für selbstverständlich, die Lösungen dann auch hier 
ins Forum zu schreiben. Gerade das ist doch eigentlich Sinn eines 
Forums, dass die Beiträge so sind, dass man den Prozess von Fehler, 
Finden der Ursache, Erarbeitung möglicher Lösungsversuche und 
schließlich die Lösung ansich in den Beiträge wiederfindet. Ich bin der 
Meinung, dass so die Allgemeinheit am meisten davon hat.
Hätte da noch einen Vorschlag zur Verbesserung des Forums:

Ich versuche im allgemeinen bei Problemen erst die Diskussionsbeiträge 
andere nachzulesen, um doppelte Fragen zu vermeiden. Es wäre recht 
komfortabel, wenn man Stichworte suchen lassen könnte, da die Anzahl der 
Beiträge hier im Forum doch recht groß ist und so die Suche ungemein 
erleichtert werden könnte.

Olli

Autor: A.Füßer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Halte es eigentlich für selbstverständlich...
Aber nicht alle tun das...

> Stichworte suchen lassen
so?
http://www.mikrocontroller.net/forum/search.php?f=1
("Suchen" steht immer ganz oben zwischen "gehe zu..." und "Log in".)
Gibts doch schon lange - manchmal sieht man die Bäume vor lauter Wald 
nicht.

Ich hoffe, daß ich dein Vorschlag so richtig verstanden habe.

André.

--
CAN@home - http://www.CANathome.de - Hausautomation mit AVR + CAN

Autor: olli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tatsache, da hatte ich wohl Tomaten auf den Augen....

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.