mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Offsetproblem beim Eingang vom AD Wandler


Autor: Stephan Müller (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hallo..

habe neulich schonmal das thema angesprochen, aber ich stehe gerade auf
dem schlauch:
habe einen 16bit AD Wandler (TLC4545) seriell mit meinem µC MC68HC12
verbunden.. ich habe vor mit diesem Wandler Audiosignale aufzunehmen
und diese dann in eine Wavdatei zu packen und danach wiederzugeben.
allerdings brauche ich am eingang des AD wandler signale zwischen 0 -
5V
d.h. ich muss den 0-offset auf 2,5V verschieben! habe deshalb einen
spannungsteiler am eingang des ADCs angeschlossen mit je 10kohm
Widerständen. solang am eingang, also an der buchse, nix angschlossen
ist, funktioniert der teiler ganz gut, fallen in etwa 2,46V am Eingang
ab. aber sobald ich den Ausgang meiner Soundkarte vom PC (SB Life) mit
dem Eingang meines ADCs verbinde, sinkt die Spannung sofort von ca.
2,5V auf 40mV runter, also nahezu 0. Ich habe im moment keine
vorstellung warum das so ist. Habe mit dem multimeter am klinkenkabel
von der Soundkarte kommend den Widerstand gemessen, ca. 12 Ohm.
Wenn die Leitung einen Offset von -2,5V hätte würde ichs ja verstehen,
aber der Ausgang der Soundkarte ist ja schon entkoppelt, messe auch 0V
DC. Aufnehmen kann ich.. ich erkenne beim wiedergeben sogar die
bassmelodie des lieds, aber das signal ist total verzerrt, was denke
ich dadurch kommt, dass die signal anteile zwischen -2,5V und 0V
komplett fehlen. habe zur sicherheit, damit der ADC nicht zuviel
spannung bekommt, eine z diode eingebaut.
kann mit jemand auf die sprünge helfen bzw. genau erklären, warum beim
anschließen die offset spannung abfällt?
kurze skizze im anhang..

mfg
Stephan

Autor: Thorsten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht weil der Ausgangswiderstand deiner Soundkarte sehr viel
kleiner ist als die 10kOhm deines Spannungsteilers?

Autor: Stephan Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also laut multimeter 12 ohm !
habe soeben einen 1µF koppelkondensator dazwischengeschaltet..
jetzt bleibt er auf seine 2,46V DC. Scheinbar wollte der Strom vom spg
teiler über den innenwiderstand der soundkarte abfließen...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.