mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik lm75


Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hat jemand Erfahrung mit dem Temperatursensor LM75?

Habe so ein Teil an einem AVR mit LCD-Ausgabe laufen, die 
Temperaturwerte werden alle 100 ms gelesen und gleich angezeigt (also 
kein Averaging o.ä.)
Die Werte schwanken aber sehr stark, bei 30°C RT von 20°C bis 40°C.
Ist das normal?
Ich habe aber den Sensor mal versehentlich falsch angeschlossen, dadurch 
ist er für ca. 5 s ein bisschen warm geworden (ca. Löttemperatur); kann 
es sein, dass ich dabei ein paar Schaltkreise verheizt habe?

Dangge schon mal,
Peter

Autor: A.Füßer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab schon so einen verbaut. Meiner zeigt immer konstant 4°C zu wenig 
an. Hab aber schon gelesen, daß manche Sensorenexemplare ihr Datenblatt 
nicht  verstanden haben... :-) Die Geschichte mit deinen Schwankungen 
hängt evtl. mit der nicht stabilen Versorgungsspannung zusammen. Hast du 
den obligatorischen 100nF Keramikkondensator zwischen VCC und GND nah 
am Sensor?

André.

--
CAN@home - http://www.CANathome.de - Hausautomation mit AVR + CAN

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo André,

nein, den Kondensator hab ich dem Sensor noch nicht spendiert, deswegen 
wird er wohl sauer sein ;-)
Muß ich gleich mal probieren.

Lese den Sensor statt alle 100 ms jetzt nur mehr jede Sekunde aus, die 
ausgegebene Temperatur schwankt jetzt nicht mehr so sehr, kommt ziemlich 
nah an die Datenblattangabe hin.

In welcher Anwendung werkelt denn Dein LM75?

Gruß,
Peter

Autor: A.Füßer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eigentlich sollte der LM75 sehr schnell auslesbar sein (d.h. mit 
maximaler I2C-Busgeschwindigkeit). Wenn er mit dem Wandeln nicht 
nachkommt unterbricht er den Vorgang und übergibt die alte Temperatur... 
vielleicht kommt es auch dadurch zu "Unruhen" auf der 
Versorgungsspannung, sodaß er dann zu schwingen beginnt.

> In welcher Anwendung werkelt denn Dein LM75?
siehe Signatur, oder Anhang (dort wo der orangene Pfeil ist, da sitzt 
der Sensor). :-)

André.

--
CAN@home - http://www.CANathome.de - Hausautomation mit AVR + CAN

Autor: Andreas Reich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mal ganz davon unabhängig würde ich mal behaupten, dass der Sensor, wenn 
er ganze fünf Sekunden so heiß geworden ist, ziemlich sicher Schaden 
genommen hat - wenn er trotzdem noch funktioniert, hast du großes Glück!

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Wo kann ich diesen Temperatursensor bestellen?


Gruß Matthias

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Beim Conrad,

Bestellnummer 165891

Peda

Autor: Gerd T. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

nachdem Ihr ja schon Erfahrungen mit dem LM75 gesammelt habt, könnt ihr 
mir bestimmt sagen warum ich ihn nicht in den Standby-Betrieb schalten 
kann. Dem Oszibild nach stimmen das Timing und die Daten. Nur ist die 
Stromaufnahme weiterhin bei ca. 160uA. Wenn ich das 
Konfigurationsregister auslese steht das Shutdown Bit auf '1'. Ausserdem 
kann ich, obwohl er eigentlich abgeschaltet sein müsste, weiterhin 
aktuelle Daten auslesen.

Hat jemand vielleicht eine vernünftige Application Note, ich habe bisher 
nur eine gefunden, und die ist nicht gerade das gelbe vom Ei.
Desweiteren bin ich vom Datenblatt etwas enttaüscht, ich habe keinen 
Verweis darauf gefunden das die SDA-Leitung einen Pullup braucht.

MfG
GT

Autor: mikki merten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@gerd
Wenn du das Datenblatt richtig gelesen hättest Seite 2 Pin Description 
SDA (open drain) ist ja auch klar bei I2C Bus.

Autor: Gerd T. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tatsache, ich nehme alles zurück. Wer lesen kann ist klar im Vorteil.

Aber das hätten sie auch in die "typical Applications" einzeichnen 
können.

Autor: Hallo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich will diesen alten thread nochmal herausholen.

Und zwar habe ich einen LM75 im Einsatz, nun möchte ich ihn 
"kalibrieren" jedoch kann ich ihn kaum mit der Platine ins Eiswasser 
werfen. Deswegen meine Frage wie mache ich das am besten?


Danke

Hallo

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Deswegen meine Frage wie mache ich das am besten?

Am besten in dem du ihn mit einem genaueren Sensor in ein Isothermes 
Gehaeuse zusammen setzt und dann die Abweichungen nach einiger Zeit 
misst und dann das ganze mit einer linearen Gleichung kalibrierst.

Gruss Helmi

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja für genaue Sachen ist der LM75 nichts. Da ist z.B. DS1820 o.ä. 
besser, allein schon wegen der besseren Auflösung. Unabhängig davon habe 
ich hier auch ein paar LM75 als Temperatursensoren im Einatz. Die 
Sensoren habe ich direkt mit einem flexiblen, vieradrigen Kabel 
angelötet. Ist ein bissel Gefrickel, mit etwas Übung klappt es aber ganz 
gut. Als Schutz mache ich ein Stück Schrumpfschlauch drüber. Wenn der 
Sensor im Freien eingesetzt wird, bekommt er vorher einen Überzug mit 
Schmelzkleber. Diese "Konstruktion" habe ich draußen in einem Eimer mit 
Wasser einfrieren lassen und sie geht noch. Ist eine Bastellösung, 
erfüllt aber ihren Zweck.

Autor: Hallo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die Antworten ich werde das mit dem einfrieren mal probieren

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Einfrieren war nicht beabsichtigt, ist jedoch ein gutes Zeichen, 
dass der Sensor halbwegs wasserdicht ist. Für normales Eiswasser sollte 
es auf jeden Fall reichen.

Autor: ich (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hallo
finde ich toll, dass ein so alter thread nochmal hochkommt.
deshalb moechte ich auch gleich meinen senf dazugeben.
ich habe einen ds75, der angeblich baugleich dem lm75
sein sollte, aber laut datenblatt, sind sie das garnicht.
hat da jemand erfahrung?
besten dank

Autor: Pete K. (pete77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Laut Datenblatt sind sie nur Software-kompatibel.

Autor: ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo pete
danke fuer deine antwort.
ich hatte den ds75 als austauschtypen fuer den lm75 in einer
tabelle gesehen, aber laut datenblatt, duerfte das ingendwie
schiefgehen. der ds75 ist nur fuer 3.7 also max. 4 v ausgelegt
und der lm75 fuer 5.5 v.
meinst du ich kann den ds75 trotzdem mit einem 5 v tty-signal
betreiben?

Autor: e is m c quadrat (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mit einem pegelwandler schon.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.