mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Nixieröhren Multiplex


Autor: Henning Wilhelm (Firma: privat) (_henning_)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich hab eine frage zum thema nixieröhren, spezieller zum ansteuern der 
röhren. und zwar hab ich auf meinem breadboard über einen km155id 4 
nixieröhren im multiplexbetrieb. der kathodentreiber und die 
anodentreiber werden über einen microcontroller gesteuert. das 
funktioniert auch wunderbar. nur leider seh ich in jeder einzelnen röhre 
einen schwachen umriss von der jeweiligen vorgängerröhre, der bei 
steigender frequenz stärker wird. momentan arbeitet die schaltung als 
uhr. das heißt also, dass ich bei den sekundeneiner die sekundenzehner, 
bei den sekundenzehner die minuteneiner usw seh... hat jemand erfahrung 
mit nixies und multiplexen? vielleicht dieses phänomen schonmal 
beobachtet und beseitigt? über anregungen würde ich mich sehr freuen.
lg henning

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> vielleicht dieses phänomen schonmal beobachtet und beseitigt?

Ja, das Thema war neulich hier schon mal dran (findet man natürlich mit 
der blöden Suchfunktion nicht, die zuerst jahrhundertealte Beiträge 
listet).

Einfach ordentlich programmieren, erst die Ziffer aus, dann das Digit 
umschalten, dann die (andere) Ziffer an.

Autor: andreas r. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sauberes Programmieren ist die Grundvoraussetzung,
reicht aber aus Erfahrung bei Nixies im Gegensatz zu 7-Seg. nicht.

Trotz sauberer Ansteuerung mit Wartezweit (bis zur Hälfte der 
Ansteuerdauer habe ich ausprobiert) haben bei mir die anderen Röhren 
etwas mitgeglimmt.

Geholfen hat letztenendes die Begrenzung der Spannung an den Kathoden 
der abgeschalteten Röhren: Von den Nixie-Kathoden (also insg 0-9 & evtl 
Punkt)  mit einer 1n4148 auf eine gemeinsame Spannungquelle mit etwa 
75V. Die "Spannunquelle" war in meinem Fall ein Spannungsteiler, der aus 
der Nixieversorgung (170V) die 75V generiert, dieser war noch mit 100nF 
gepuffert.
Was genau dabei passiert und warum diese Maßnahme funktioniert: keine 
Ahnung. Aber es half.
Der "orginale" nixie-Treiber-ic begrenzt die Spannung übrigens auch auf 
ca 70V.

Grüße
Andreas

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Deine Schaltkreise werden wohl die hohe Leerlaufspannung nicht ganz 
vertragen haben und als "Z-Dioden" wirken?

Autor: Henning Wilhelm (Firma: privat) (_henning_)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wartezeit ist ein gutes Stichwort, neben sauberem Programmieren ;).
Mit der Referenzspannung, um die Röhren unter die Brennspannung zu 
ziehen, ist natürlich auch gut, entfällt aber bei mir da ich einen 
Treiber nehme.
Warte ich ca. 350 Takte (bei ~4MHz) zwischen dem Ausschalten der Röhre 
und dem Ändern der Ziffer, bzw. dem dann folgenden Einschalten der 
Röhre, funktioniert es.
Vielen Dank!
LG Henning

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.