mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik LTspice opamp Einbinden Problem


Autor: Grübler (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen

Ja, ich habe die Beiträge in diesem Forum
aufmerksam gelesen. Auch das Handbuch zu LTspice.

Nun mein Problem.
Ich habe die beiden Dateien erstellt und in LTspice
in die richtigen Verzeichnisse kopiert.

Wenn ich mit dem TL072 einen einfachen Verstärker
mit sym. Speisung aufbaue und simulieren will,
kommt diese Fehlermeldung

Unknown subcircuit called in:
xu1 0 n002 +ub -ub tl072

Leider kann ich damit nichts anfangen.
Wer kann helfen?

: Verschoben durch Admin
Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Orginalname wurde ausgeklammert und durch einen neuen ersetzt. 
Könnte das Problem sein.

*.SUBCKT TL072    1 2 3 4 5
.SUBCKT TL072s 1 2 3 4 5out

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dein Symbol will einen TL072 aber deine Modell-Datei enthält einen 
TL072s.


Tipp: Du hättest auch das universelle Symbol "opamp2" nehmen können.

Autor: Grübler (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Super! Danke!
Genau das war's!

An der TL072.lib hab ich gar nichts verändert,
die habe ich 1:1 von TI übernommen.

Die Datei opamp2.asy habe ich kopiert
und nach einem Beitrag von "Dieter"
aus diesem Forum verändert.

Dank an euch und auch an Dieter.

Jetzt noch eine Frage:

Ich hab hier noch eine Modell-Datei
von einem TDA2030. Leider sind die
Anschlüsse in einer anderen Reihenfolge
wie beim TL072.

Soll ich die Zahlenposition in der mod-Datei
ändern oder wie soll ich die asy-Datei ändern?
Wer schön, wenn ihr mir noch mal helfen könnt.
Ich find das ganze echt umständlich und verwirrend ;-)

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich würde in der *.mod die Zeilen korrigieren in:
.SUBCKT TDA2030 3 2  7 4 6
* 3 2 7 4 6
* +in -in Vcc Vee out

Da ist es imho übersichtlicher und bleibt quasi kompatibel zu den OPAs.
Aber, auch die andere Variante ist möglich. Was ist dir sympathischer?

Autor: Grübler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Grundsätzlich funktioniert das Modell des TDA2030 jetzt.

Aber es kann nicht vom TDA2030 sein. Laut Datenblatt
liegt der max. Ausgangsstrom bei 3,5A. Belastet man
aber den opamp in LTspice mit mehr als ca. 50mA ist
die Ausgangsspannung stark verzerrt.

Hat einer eine Idee oder die richtige PSpice-Datei?
Im Internet und bei ST habe ich nichts gefunden.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.