mikrocontroller.net

Forum: PC Hard- und Software Excel Aufgabe


Autor: Tamagotchi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Ich versuche mich gerade in Excel mit folgender Aufgabenstellung:

Eine Liste mit Lottozahlen der vergangenen Jahre soll mit 6 
einzugebenden Nummern verglichen werden. Neben jedem Datensatz in der 
Liste soll dann jeweils stehen, ob und wie oft die Zahlen darin 
vorkommen. Ich hoffe ich hab mich einigermaßen verständlich ausgedrückt

Hat jemand einen Ansatz?

Autor: hdd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Angenommen, deine lange Liste mit Lottozahlen steht in A1:A1000 und 
deine 6 Nummern in B1:B6, dann schreibst du in die Zelle rechts neben B1
=ZÄHLENWENN($A$1:$A$1000; $B1)
Jetzt steht dort die Anzahl der Vorkommen der ersten Zahl.
Die Zelle klickst du jetzt an und kopierst sie in die restlichen Zellen 
rechts der Nummern (die Zelle kopieren, nicht den Inhalt, dann wird das 
$B1 automatisch angepasst zu $B2 usw.)

Autor: Tamagotchi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
danke schon mal

das funktioniert so aber nicht. Die Liste der Lottozahlen besteht aus 
jeweils 6 Zahlen...

Zusammengefasst: die Liste A1:F1000 soll mit den Zahlen N1:S1 verglichen 
werden. In der Spalte H sollte dann bei jedem Satz stehen, wie viele 
Treffer die Ziehung hatte.

Autor: Tamagotchi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok, hab jetzt in der Zelle die selbe Formel insgesamt 6 mal addiert mit 
Bezug zu den jeweils zu vergleichenden Zahlen. Auch wenns nicht so 
elegant ist, funktioniert es aber :)

Autor: Harald D (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mach das mal mit VBA. Das ist wohl am Einfachsten.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.