mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Programmieren aus Programmers Notepad heraus geht nicht mehr


Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo! Habe vorhin das neuste Atmel Studio installiert, welches mir
prompt vorgeschlagen hat, mein STK500 upzudaten. Gesagt, getan.

Jedoch kann ich nun aus meinem Programmers Notepad heraus keine µC's
mehr programmieren (Tools->[WinAVR] Program)

Folgende Meldung erscheint im Statusfenster:

avrdude -p atmega8 -P com1     -c stk500    -U flash:w:Test.hex
avrdude: stk500_getsync(): not in sync: resp=0x00
make.exe: *** [program] Error 1


Lade ich die Hexdatei aber ins Studio, kann ich dort programmieren.
Kaputt ist da also nichts.

Wer kann mir helfen?

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wahrscheinlich hat dein STK jetzt ein neueres protokoll. (oder es leigt
an falschen COMPORT einstellungen)

wenn der STK wirklich ein neues Protokol drauf hat, dann brauchst du
ein Update für AVRDUDE (keine ahnung ob es sowas gibt).

Autor: Stefan Seegel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Den "not in sync" Fehler habe ich auch immer bei meinem STK500 mit
avrdude. Wenn man aber einfach nochmal make program aufruft
funktioniert es, also einfach immer 2x drücken. Nervig aber geht...

Stefan

Autor: Tobias Tetzlaff (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

auch ich habe mein STK updaten müssen.

Ich habe PN 2.5.0.32

Allerdings hatte ich keinerlei probleme.

Gruß Toby

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm, Com1 ist richtig gesetzt, und 2x Make ausführen hilft auch nicht.

Habe die neusten Versionen von PN, WinAVR und Studio4 (von heute
nachmittag).


Kann ich mein Board irgendwie wieder "downgraden"?

Autor: Tobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja, schnapp dir die stk500.ebn datei vom alten avrstudio und mache damit
ein manuelles firmware 'upgrade'

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo! Hab mal bei AVR-Freaks geschaut und da besteht das selbe
Problem:

http://www.avrfreaks.net/index.php?name=PNphpBB2&f...

Werde also die alte Firmware wieder draufspielen.

Habe in meiner Not leider etwas an den Frequenzen im Studio gedreht und
ich weiß nichtmehr, wie die Standardwerte waren.

Kann mir jemand sagen, wie die Standard-ISP-Frequenz im Studio unter
Registerkarte "Board" lautet? Das war irgendwas mit 48 kHz, oder?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.