mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Filterproblem


Autor: Thomas (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, habe ein Problem mit meinem Filter (siehe Anhang). Ich habe ihn 
mit Aktivfilter 3 erstellen lassen und in Multisim simulieren lassen.
Sowohl AC als auch Transientsimulation sehen so aus wie sie aussehen 
sollen. Allerdings funktioniert der Filter aufgebaut nicht.

Habe ein Board mit Eagle erstellt und gelayoutet. Als DC 
Spannungsquellen habe ich benutze ich die Gleichspannungsregler 7812 
(+12V) und 7912 (-12V).
Koppelkondensatoren an deren ein und ausgängen sind vorhanden.
Ebenfalls nocheinmal 10µ und 100n direkt am AD8065 (OPV). DIe Polarität 
bei den 10µ wurde beachtet.

Groundplates sind ausreichend vorhanden. Als ein und ausgang wurden BNC 
Stecker verwendet.

Nun habe ich folgendes Problem. DIe ganze schaltung funktioniert einfach 
nicht. es kommt kein SIgnal am Ausgang an. Zum testen benutze ich einen 
Signalgenerator und ein Oszilloskop (beides von Agilent). Frequenzen bis 
30!!! Hz sehe ich am Ausgang... alles darüber nicht. Sieht jemand einen 
generellen Fehler in dem Schaltplan?
Der Eagle plan ist exakt der gleiche, das habe ich jetzt mehrfach 
überprüft.

Vielleicht sieht ja jemand einen Fehler...

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eingänge des OPamp vertauscht?

Kai Klaas

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auf den ersten Blick würde ich sagen, dass die Eingänge am OP vertauscht 
sind: Masse gehört auf den nicht invertierenden Eingang und das Signal 
auf den anderen.

Viel Glück

Autor: nerner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...wenn dein eingangssignal vor R3 sehr hochohmig eingekoppelt wird, 
funktioniert das filter auch nicht richtig

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Super das Problem war mit den vertauschten Polen, hab es geändert und 
jetzt geht es super...  aber warum zeigt mir die SImulation das nicht 
an?

Autor: Pole (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
tut es doch -> siehe Phasenlage

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja das wäre nicht das problem, aber mit vertauschten polen kommt am 
ausgang in der praxis immer 0V

Autor: Pole (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In dem Schematic, welches du oben angehängt hast, benutzt du zwei 
Spannungsquellen. Die beiden zum OP laufenden Anschlüsse dieser 
Spannungsquellen haben die gleiche Polarität. Jede der "langen Enden" 
dieser Spannunsquellen haben GLEICHES Potential. Vielleicht liegt es 
daran? Dreh mal die obere Spannungsquelle um 180°, damit deren Pluspol 
dann zum OP führt. Oder eben anders herum. Ich weiss nicht welcher 
Anschluss + oder - ist.

Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Pole

So wie es im ersten Bild eingezeichnet ist, ist es völlig richtig. Pin2 
ist -Vs und das liegt da auch an.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>So wie es im ersten Bild eingezeichnet ist, ist es völlig richtig. Pin2
>ist -Vs und das liegt da auch an.

Wenn du die Spannungsversorgung meinst, ja. Aber die beiden Eingänge des 
OPamp sind vertauscht!

Kai Klaas

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.