Forum: Mikrocontroller und Digitale Elektronik Analogmultiplexer_Rauschen


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Udo Kreuzer (Gast)


Angehängte Dateien:

Lesenswert?

Hallo Leute!
Hab den Multiplexer wie in der Schaltung die ich als Anhang dazugegeben
habe beschalten. Jedoch besteht das Problem, dass die Eingangsspannung
am Ausgang sehr verzerrt ist. Weiß jemand woran dass liegen könnte?
mfg

von Udo Kreuzer (Gast)


Lesenswert?

Aja: Die Eingangsspannung ist eine Mischspannung. also Gleich und
Wechselanteil

von Michael (ein anderer) (Gast)


Lesenswert?

Was soll das den werden??? Wo ist da der Multiplexer??? Was ist mit
dem Optokoppler???

von Udo Kreuzer (Gast)


Lesenswert?

Der Multiplexer ist ganz rechts in der Schaltung!!!! Es ist ein
CD4051BE. Die Optokoppler dienen nur zur galvanischen Trennung vom µC.
Aber ich will eigentlich nur wissen warum bei Aktivieren eines Kanals
folgendes passiert:

- Die Eingangsspannung wird verzerrt -es sieht am Oszi so aus als würde
die Eingangsspannung mit dem Rauschen überlagert werden.
Und die Ausgangsspannung des Multiplexers sieht so ähnlich aus.
Weiß jemand wie ich dieses Rauschen verhindern kann???? mfg

von Kai Markus Tegtmeier (Gast)


Lesenswert?

Da kann Dir nur jemand helfen, wenn Du die entscheidenden
Schaltungsteile mitpostest, nämlich Ein- und Ausgang. Die
Steuereingänge sind dafür (erstmal) irrelevant. Und dann
müßtest Du noch folgende Fragen beantworten:

- was für ein Eingangssignal (Amplitude, Form)?
- Was für ein Meßgerät? Wie (und vor allem wo) angeschlossen?

Also bitte, die komplette Schaltung posten, sonst kann
da keiner was sinnvolles zu sagen.

mfG
KMT

von Rufus T. Firefly (Gast)


Lesenswert?

Lass' doch erstmal den Optokoppler weg, um ausschließen zu können, daß
die Fehlerursache nicht vielleicht doch in dem liegen könnte.

Oder miss mal Dein Signal unmittelbar nach dem Optokoppler - kommt da
an, was Du erwartest?

von Kai Markus Tegtmeier (Gast)


Lesenswert?

Das Problem ist, daß das Signal, von dem er redet, gar nicht im
Schaltplan vorkommt. Der Optokoppler hängt nicht im Signalweg, sondern
nur an den Steuereingängen. Analog-Ein- und Ausgang
vom CD4051 sind hier leider nicht dargestellt...

KMT

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.