mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik AnalogmultiplexerCD4051BE


Autor: Udo Kreuzer (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute!
Hier ist nochmals die Schaltung!
Der Test bestand darin, an einem Eingang des Multiplexers ein
Sinussignal mit der Frequenz 100 Hz anzulegen und das Signal am Ausgang
zu betrachten. Am Ausgang folgt eine OPV -Verstärkerschaltung. Das
Problem war, dass das reine Eingangssignal am Ausgang sehr verzerrt
herauskam. Muss ich am Ausgang eine zusätzliche Beschaltung machen oder
wie muss ich den Multiplexer genau beschalten damit das Ausgangssignal
nicht verzerrt wird.
Als Messgerät wurde ein oszi verwendet!
mfg

Autor: Rufus T. Firefly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sag' mal, haben Dir die Antworten und Fragen im anderen Thread nicht
gereicht?

Welche Amplitude hat denn Dein Signal?

Autor: Kai Markus Tegtmeier (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also, normalerweise muß an den Ausgang keine spezielle Beschaltung hin.
Du kannst ja mal zum Testen einen OPV als Impedanzwandler mit
Verstärkung 1 beschalten und an den Ausgang hängen. Dazu noch einen
15kOhm vom Ausgang des CD gegen Masse, um die Zeitkonstante der
Ausgangskapazität in Grenzen zu halten. Normalerweise muß die Schaltung
so funktionieren. Ansonsten könnte ich mir vorstellen, daß
der CD4051 das Zeitliche gesegnet hat. Die Dinger sollen ja empfindlich
gegenüber statischer Aufladung sein. Hast Du schon mal einen anderen
CD4051 probiert? Sind die Versorgungsspannungen sauber? Nachgeschaltete
OPV-Schaltung sieht wie aus? Hat der OPV auch +/- 5V?

Was passiert denn am Eingang des CD, wenn Du den betreffenden Kanal
einschaltest? Wird das Signal dort dann auch verbeult? War es vor dem
Einschalten ok? Wenn ja, gehe ich stark davon aus, daß der CD einen
abbekommen hat.

KMT

Autor: Udo Kreuzer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Eingangssignal wird durch Einschalten des Kanals auch unsauber.
Vielleicht sollte ich mal einen anderen probieren.
Die positive Versorgung ist durch einen Spannungswandler gegeben der
eine Ausgangsspannung von 5V haben sollte. Jedoch beträgt diese 7V-der
Grund dafür ist mir nicht bekannt-vielleicht ist dieser auch kaputt.
Die negative Versorgung beträgt -5V.
zu Rufus T. Firefly:
Die Amplitude des Signals varriert. Die Schaltung sollte für alle
Amplituden funktionieren.
mfg

Autor: Kai Markus Tegtmeier (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann würde ich zunächst erst mal für eine saubere
Versorgungspannung sorgen, dann eventuell einen anderen CD4051
probieren. Weil, wenn selbst am Eingang schon das Signal verbeult wird,
dann ist was ernstlich faul in der Schaltung...

KMT

Autor: Rufus T. Firefly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Die Amplitude des Signals varriert. Die Schaltung sollte für alle
Amplituden funktionieren."

Für alle? Ich hoffe nicht, daß Du das ernstmeinst.

Die Signalamplitude sollte innerhalb des durch die Versorgungsspannung
gegebenen Rahmens bleiben, ein "rail-to-rail"-Betrieb wird auch nicht
möglich sein.

Daher wiederhole ich die nicht beantwortete Frage nach der Amplitude,
bei der das Signal verzerrt wird.

Autor: Udo Kreuzer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ausgetestet habe ich es mit 60mV (=1 Halbwelle). Die Spannungen die ich
erwarte werden maximal 500mV (=1 Halbwelle) sein und minimal so um die
5mV.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.