mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Problem mit Nicht-Invertierenden Verstärker


Autor: Lars Becker (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich habe ein Problem mit einem Nicht-Invertierenden Verstärker in
meiner Schaltung. Aufgebaut ist er wie im beigefügten Bild, zwischen R5
und R6 hängt ein NTC-Widerstand gegen GND und das um das ~19fache
Verstärkte Eingangssignal soll einem ADC-Eingang eines ATMega8
zugeführt werden. Der NTC erzeugt mit R5 und R6 eine Spannung von ca.
220mV @ 20°C bis 37mV @ 150°C.

Das Problem ist aber, dass der Ausgang des Op-Amps (741er) permanent
auf 4,4V steht und sich von keiner Eingangssignaländerung beeindrucken
lässt. Nichteinmal wenn ich den NTC kurzschließe - wenigstens dies
sollte den Ausgang doch auf 0 ziehen, oder?

Vielen Dank für jeglichen Hinweis, Grüße,

Lars Becker

Autor: ___ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die meisten OPs mögen direkt am Ausgang keine Kondensatoren.
Entferne mal C6 und Teste noch mal.

Autor: Lars Becker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nö, ändert leider nix.

Das ist voll zum Verzweifeln, eine Schaltung die man im 2. Lehrjahr in
Grundlagenelektronik lernt und in jeder Formelsammlung vetreten ist...
Könnte es vll. an der nichtsymetrischen Spannungsversorgung liegen?
Wobei das ja dem OP egal sein dürfte.

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das wird wohl daran liegen, dass dem 741 5V zwischen Pin4 und Pin7 nicht
reichen. Versuch mal einen OPA347 oder so. Und der Kondensator ist echt
fehl am Platz, max. 1nF dort, sonst schwingt das, wenn es denn geht.
Wenn Du sieben willst, ab Spannungsteiler einen Widerstand 10..100k zum
nichtinvert. Eingang, von dort einen kondensator gegen GND.

Sven

Autor: Kurt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Lars,

Der 741 ist natürlich nicht der "beste" hier, sollte aber trotzdem
funktionieren (er kann nicht höher als 4.4 V und auch nicht ganz nach
unten).
Es scheint so dass die Spannung am + Eingang zu hoch ist oder der
Gegenkopplungszweig zu hochohmig (am - Eingang wird nicht die
notwendige Spannung erreicht).
Sag uns mal wie die Spannungen sind (mit und ohne Sensor).

Gruss Kurt

Autor: Lars Becker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jetzt hab ich erst mal ein paar OPA347 bestellt. Schon alleine, um
weiter gegen Vcc und GND zu kommen.

Die Spannungen:
Ohne Sensor:
+ Eingang: 290mV
- Eingang: 220mV*

Mit Sensor bei RT:
+ Eingang: 230mV
- Eingang: 220mV*

Bei erhitzen des Sensors:
+ Eingang: ~150mV
- Eingang: 220mV*

*) jeweils resultierend aus dem Spannungsteiler 19kOhm zu 1kOhm und den
besagten 4,4V.

Autor: Kurt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei erhitzen des Sensors:
+ Eingang: ~150mV
- Eingang: 220mV*

hier müsste der 741 umschalten.

Soweit ich weiss schafft er die geringe Eingangsspannung nicht (der
Abstand von der neg-Versorgung ist zu gering.
Leg mal eine -Spannung am 4er pin  an (mind 3V) dann müsste es gehen.

Autor: Lars Becker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stimmt, dann gehts wie ich es gerne hätte. Bloß blöd, dass ich keine
negative Versorgungsspannung in der Anwendung hab...

Aber mit den besagten OPA347 sollte es doch dann eigentlich gehen oder
(Single Supply, Rail-to-Rail)? Oder hat der auch etwas gegen die
geringen Eingangsspannungen?

Autor: Kurt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Den OP kenn ich nicht, wenn er R to R auch am Eingang hat dann sollte es
 schon laufen.

Gruss Kurt

Autor: Lars Becker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, dann soweit Dankeschön.

Gruß, und schönen Abend noch,

Lars

Autor: Stefan Seegel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn du weit runter musst mit der Spannung, aber oben nicht unbedingt
bis zur Versorgungsspannung ist der LM324 der Klassiker, der kann bis
zur unteren Versorgungsspannung...
Gibt's überall und kostet fast nix.

Stefan

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.