mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik seltsames Verhalten vom AT90S2313


Autor: Roland Hutter (minitron)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

mit dem "Stange-ISP-Programmer" wollte ich einen AT90S2313 mittels 
AVR-Studio programmieren. Programmer wurde zwar ordnungsgemäß erkannt, 
aber der Chip nicht. Nächster Versuch mit einem selbstgebauten STK200 
unter Avrdude. Programmer wurde erkannt, aber keine Kommunikation mit 
dem Chip (Fehler rc=-1). Dann den Chip in einen "Leaper10" gesteckt, und 
Chip wurde klaglos programmiert. Dann noch ein Versuch mit dem TOP2004, 
ebenso problemlose Programmierung. Also habe ich alle noch vorhandenen 
AT90S2313 zusammengesucht und bei ausnahmslos allen das gleiche seltsame 
Phänomen festgestellt. Ein ATTINY13 oder ATTINY2313 z.B. werden sowohl 
mit dem Stange-Teil als auch mit dem STK200 unter identischen 
Bedingungen ohne Sschwierigkeiten programmiert. Wieso zicken Stange und 
STK200 ausschließlich beim AT90S2313? Was könnte hierfür die Ursache 
sein? Defekt sind die Chips definitiv nicht.

Besten dank schonmal für die Hilfe und viele Grüße

Roland

Autor: Max (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte so ein Problem mit dem Dragon und AVRs die vorher mit Ponyprog 
beschrieben wurden (egal ob fuses oder flash/eeprom), die Lösung war 
damals die Chips per Ponyprog eine Erase zu unterziehen und für ~ 5 
Minuten stromlos zu lassen (hat gedauert bis ich da drauf kommen bin), 
mit neuen gings aber eigtl. immer...
is dein 90S2313 neu (= nie beschrieben worden) ?

Autor: Roland Hutter (minitron)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Max,

ausnahmslos alle Chips waren von Reichelt und jungfräulich. Auch nach 
dem blank-check mit dem Leaper10 und TOP2004 wurden alle AT90S2313 vom 
Stange-Teil und STK200 nicht erkannt.

Autor: Max (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit welcher Software greift du auf die Progger zu ?

Autor: Roland Hutter (minitron)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Max

mit dem AVR-Studio 4.14 und avrdude 5.10. Ich frage mich halt nur, warum 
so uralte DOS-Software für den Leaper10 (parallelport) den Chip erkennt 
und auch der TOP2004 (USB), aber die "modernen" Programmer (bisher 
übrigens der einzige Test mit AT90S2313 sowie ATTINY13 und ATTINY2313) 
versagen....


...schlaf gut und viele Grüße

Roland

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.