mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Multiplexer_seltsam


Autor: Udo (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!
Folgendes Problem:
Verwende einen Analogmultiplexer CD4051BE. Angesteuert wird dieser mit
Hilfe vom PIC16f877 über eine galvanische Trennung usw., aber das ist
nicht das Problem. Gibt man an die Steuereingänge die entsprechenden
High bzw. Low -Pegel so schaltet der Multiplexer den entsprechenden
Kanal durch.
Versuchsaufbau:
Hab an einem Eingang erst mal eine Wechselspannung angelegt, den
entsprechenden Kanal durchgeschalten --> ergibt am Ausgang diesselbe
Wechselspannung -funktioniert wunderbar. Jedoch musste ich dafür die
nicht verwendeten Eingänge auf Masse legen, da ansonsten die
Versorgungsspannung des Multiplexers sich veränderte.
Nächster Versuch war, mehrere Spannungen an den Multiplexer anzulegen
und zu schauen ob diese zusätzlich angelegten Spannungen einen Einfluss
auf das Verhalten des Multiplexers haben, was ja theoretisch nicht der
Fall sein dürfte.
Jedoch verändert sich durch mehrere Eingangsspannungen die negative
Versorgungsspannung von -5V auf ca. -7V. Der ausgewählte Kanal wird
jedoch weiterhin einwandfrei durchgeschalten!
Frage: Hat jemand schon so ein ähnliches Problem gehabt???? mfg

Die im Bild blau strichlierte Linie existiert noch nicht, gehört aber
verbunden oder??? Als invertierer verwende ich eine einfache OPV
-Schaltung mit 2 Widerständen

Autor: Rufus T. Firefly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn sich durch irgendwelche irgendwie an den 4051 angelegten Signale
dessen Versorgungsspannung ändert, dann scheint Deine
Versorgungsspannungsquelle sehr eigenartig aufgebaut zu sein.

Leider ist das von Dir gepostete Bildchen nur sehr entfernt mit einem
Schaltplan verwandt, daher kann man noch nicht mal vermuten, wo da die
Fehlerquelle liegt.

Autor: Udo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Versorgung stammt jeweils von einem Festspannungsregler 1A. Ein
positiver für die 5V und ein negativer für die -5V. Am Eingang der
Festspannungsregler liegen +12V bzw. -12V an die von einem DCDC
-Wandler stammen.
ja das bild ist nicht das beste. mfg

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.