mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik SHT15 Sensor


Autor: Alexander (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Tag,

hat vieleicht schon mal wer mit einen SHTxx Sensor von SENSIRION zu tun
gehabt?

Ich habe folgendes Problem:

Ich habe vor Wochen schon ein kleines Programm zum auslesen dieser
Sensoren geschrieben und die Temperatur und Luftfeuchtewerte haben
ungefähr mit meinen z.B. Thermometer übereigestimmt.

Jetzt habe ich das Programm erweitert (in mein eigentliches Projekt
eingebungen) und jetzt steigt die temperatur um etwa 5 Grad an. Auch
die luftfeuchte sinkt:

Laut Datenblatt besitten die Sensoren ein internes Heizelement das
genau diesen Fehler verursachen könnte.

Ich habe dieses Heizelement laut Statusregister bereiz Ausgeschaltet,
aber das Problem ist noch immer da!?

Dann habe ich mir, auf verdacht eines Defektes, einen neuen Bestellt
und ads Problem ist noch immer da?? Jetzt weis ich nicht mehr weiter!

Ich habe das Datenblatt mal angehängt.

Hatte vieleicht schon mal wer das gleiche Problem??


M.f.G

Autor: Simon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Diese Teile sind echt gut, muss ich sagen. Ich habe einen SHT75
ausgelesen und hatte keine Probleme damit. Ich lass auch strikt die
finger von dem statusregiste. Braucht man in prinzip auch nicht.

Kann es vielleicht sein, das dein restlicher programmcode irgendwie
dazwischenfunkt. Muss ja so sein, wenn es mit dem anderen Programm
funktioniert hat.
wiso hast du dir einen neuen bestellt und nicht den alten sensor
nochmal mit der alten software ausprobiert ?


Gruß

Autor: Alexander (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

>Kann es vielleicht sein, das dein restlicher programmcode irgendwie
>dazwischenfunkt. Muss ja so sein, wenn es mit dem anderen Programm
>funktioniert hat.

das muß ja auch so sein. Mir kam es nur komisch vor, dass es beim
ersten auslesen die Temperatur ungefrähr stimmte und dan bei den
darauffolgenden auslesevorgängen immer um ein paar zehntel Grad anstieg
bis ca 5 Grad mehr.
Er hat sich also fast linear erwärmt.

>wiso hast du dir einen neuen bestellt und nicht den alten sensor
>nochmal mit der alten software ausprobiert ?

ich plane schon wieder für das nächste Projekt.

Gruß Alexander

Autor: Dominik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann es sein, dass du mehr als 3 Messungen pro Sekunde machst? Laut
Datenblatt erwärmt sich der Sensor dann.

Die "Heizung" des Sensors verursacht keinen Fehler. Man Schaltet sie
mit Absicht ein um, die Kondensation des Sensors in sehr feuchtem
Umgebungen zu vermeiden. Natürlich ist dann die gemessene Temperatur
höher als die ohne Heizung gemessene.

Gruß, Dominik

Autor: Simon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi. Im datenblatt steht auch, dass man den sensor nur ca. 10 % benutzen
soll um das messergebniss nicht zu verfälschen. Bei mir schwankt der
sensor auch um wenige Zehntel Grad (ca. 0,3). Aber der Sensor
garantiert ja auch nur eine Genauigkeit von 0,3 °C.

MfG

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie wäre es mit einer einfachen Messung der Stromaufnahme des Sensors ?
Ist die Heizung an liegt der deutlich höher als mit Heizung aus (siehe
Datenblatt).

Gruß Frank

Autor: Simon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach Ja: benutzt du CRCs ?

Autor: Simon (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi. Ich hab mal ca. 300 messungen gemacht und in einem diagramm
zusammengefasst.

Autor: Simon (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
und nochmal ein paar messungen. Bei dem knick habe ich das fenster für
ca. 10 sec geöffnet.
Also bei mir liefert der sensor relativ gute werte.
Sie meessungen sind im abstand von 5 sec gemacht worden.

MfG

Autor: Simon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
und noch ein bildchen. das die Temperaturschwankung gut zeigt.
Wie man auf dem Bild gut sieht liegt die abweichung im bereich ca. 0,2
°C.
Die Messung ist in einer zeit von ca. 10 minuten gemacht worden.
Also kann es auch gut sein, dass die temperatur vom sensor noch genauer
erfasst wurde.
MfG Simon

Autor: Simon (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
bild vergessen. hier ist es

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.