mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Scannernetzteil reparieren


Autor: C. Lechner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

mein Scanner streikt neuerdings (meistens) :-(.
Ich vermute, dass es das Netzteil ist, denn er "pfeift". Es pfeifen
nicht die Motoren, sondern wahrscheinlich eine Induktivität im
Netzteil, zumindest hört es sich so an (nicht all zu laut, mehrere
tausend Hertz Frequenz).

Beim Initialisieren scannt der Scanner eine Zone an der Unterseite der
Glasscheibe (Schwarze und weiße Striche) und nur wenn er scannt pfeift
es. Das Initialisieren schlägt fehl, er "sieht" also die Streifen
nicht.

Mein Tipp ist, dass ihm irgendeine Spannung für die CCD-Zeile fehlt,
aber ist wie gesagt nur ein Tipp.

Nach was muss ich im Netzteil suchen? Bisher würde ich v.a. nach
defekten Kondensatoren auf der Niederspannungsseite suchen (mit
Kältespray). Natürlich würde ich mit dem Einschalten warten, bis der
Spray verdampft ist :-). Die Seite mit der Netzspannung kanns IMHO
nicht sein, weil ja alles andere geht (Beleuchtung, Motoren,
Durchlichteinheit, SCSI-Interface) und diese Sachen brauchen weitaus
mehr Energie, als der Rest.

Nur für den Fall, dass jemand diesen Vorschlag machen will: Ich will
meinen Scanner NICHT wegschmeißen, weil er einfach gut ist: 2400x1200
dpi optisch, Durchlichteinheit, UW-SCSI Interface
Er ist nur schon zu alt, als dass der Hersteller was machen würde.

MfG
- C. Lechner

BTW: Mir ist bewußt, dass man in Netzteile auch nicht reinlangt bzw.
keine Messungen vornimmt, wenn sie über einen Trenntrafo mit dem
Stromnetz verbunden sind. Außerdem ist mir bewußt, dass die
Kondensatoren auch lange nach dem Ausschalten noch geladen sein können.
Also bitte keine Ermahnungen in diese Richtung :-)

Autor: Rufus T. Firefly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Stromversorgung der CCFL-Röhre befindet sich in der Regel auf einer
eigenen Platine, die Du durch Verfolgen der Anschlusskabel der
CCFL-Röhre leicht finden solltest. In der Regel ist diese Platine mit
auf dem bewegten Scanschlitten untergebracht.

Du könntest mal den kompletten Scanschlitten elektrisch von der
restlichen Scannerelektronik trennen (Flachbandkabel abziehen) und
überprüfen, ob das Pfeifen weiterhin auftritt.

Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hm schonmal alle Spannungen mit einem Multimeter nachgemessen?


Martin

Autor: C. Lechner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

danke für die schnellen Antworten!

Die CCFL-Röhre leuchtet nachwievor so hell wie sonst auch, also die ist
unschuldig :-)

Die Spannungen hab ich noch nicht nachgemessen, weil ich will den
Scanner so kurz wie möglich öffnen.

MFG
- C. Lechner

Autor: Rufus T. Firefly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bewegt der Scanner noch den Scanschlitten? Möglicherweise gibt es ja
Probleme bei der Ansteuerung des Schrittmotors, die -aufgrund von
überforderter Elektronik- zu den Pfeifgeräuschen führt; eventuell
ist's ja der Schrittmotor selber, der da pfeift.

Autor: Marko B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Jens123 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
eine ganz ganz bloede frage
evtl die Transportsicherung???

was meldet der PC?? Scanner gefunden und kannst du ihn ansprechen??

ich habe selbst einen SCSI Scanner nur streikt der mehr, als er sauber
funktioniert..


Gruss Jens

Autor: C. Lechner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Rufus T. Firefly:

Auch der Schrittmotor (der Schlitten) bewegt sich normal.

@Marko B.:
Der Großteil der "SAFETY TIPS" ist mir schon bekannt gewesen, aber
der Rest des Artikels ist natürlich auch sehr interessent.

Hab im Rahmen meiner Physik-Facharbeit Marx-Stages und Tesla-Trafo und
ähnliches gebaut, also 20kV mit Kondensatoren im µF-Bereich. Da ist
genug Ladung drauf um einen garantiert umzuhauen. Folglich lange ich
NIRGENDS wo mehr hin, außer ich habe mich vergewissert dass da nur
Spannungen unter 20V sind. Aber hast schon recht, die Sicherheitsregeln
kann man nicht oft genug lesen/wiederholen.

MfG
- cl

Autor: C. Lechner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Jens123:

Der SCSI-Bus ist sauber terminiert und die Transportsicherung ist raus
:-).

Der SCSI-Controller findet den Scanner und auch die Scan-Software
(xsane) findet ihn.

MfG
- cl

Autor: Jens123 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wie oben schon erwaehnt

musst rausfinden, woher es kommt und was es ist

Multimeter anklemmen und messen

scannversuch starten messen und schauen, ob irgendwo eine spannung in
der versorgung einbricht..


(... viel spass beim Glas Putzen also weisse Handschuhe nicht vergessen
=) )

Autor: Marko B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
C. Lechner: nach den Sicherheitstips gehts doch weiter ... scroll mal zu
"Sounds that SMPSs make".

Autor: C. Lechner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab das Dokument schon komplett durchgelesen. Vielleicht war's von
mir falsch formuliert weil ich geschrieben habe das der Rest auch sehr
interessant sei ...

Sind coole Tips drin. Ich werde den Scanner heute mal aufmachen und
reinschauen. Den Leistungsteil kann man als in Ordnung ansehen, weil ja
alles ganz normal ist, bis auf die Sache, dass er nix mit der CCD-Zeile
"sieht". Es fehlt also vielleicht eine Spannung oder so.

Darf man eigenlich ein Analog-Oszi an die Niederspannung dranhängen
oder spricht da was von wegen der Sicherheit dagegen?

MfG
- cl

Autor: Marko B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn Du ein Oszi hast, dann bau Dir einen ESR-Tester [1] und teste mal
alle Elkos durch. Tote Elkos sind die Ursache für 90% aller Fehler.

Oszi kannst Du an die Ausgangsspannung(en) dranhängen, da sie
galvanisch getrennt ist. Mußt trotzdem gut aufpassen wenn Du keinen
Trenntrafo hast.

[1] http://octopus.freeyellow.com/99.html

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.