mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Beschaltung MOC3043 / Triac


Autor: Sebastian F. (snake080)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe ein Problem mit dem Triac.
Ich hatte mal eine Schaltung (Terrarium Licht & Bewässerung) nach dem 
OBEREN Schaltplan gemacht. Die funktioniert auch heute noch.
Jetzt habe ich vor ein Thermostatventil für eine Fußbodenheizung 
anzusteuern. Also, schön nach Datenblatt (UNTERE Schaltung) die 
Beschaltung und nix geht... bzw. der Triac schaltet ein und dann nicht 
wieder aus.
Ich verstehe es nur nicht. Kann mir da jemand helfen? Mit einer Lampe 
klappt das ein- und ausschalten...

Autor: Peter R. (pnu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
-Zunächst einmal: Im Schaltplan ist in aller Unschuld Vcc eingetragen.
Ist das etwa eine Gleichspannung? Da funktioniert ein Thyri/Triac nicht, 
so etwas braucht zum Wiederabschalten einen Nulldurchgang des Stroms.

Autor: Sebastian F. (snake080)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein, keine Angst. Ich brauchte nur schnell ein Symbol um die Nets zu 
verbinden. Ich hätte es L1 nennen sollen :)
Es geht darum, bevor ich mir die Arbeit mache alles umzuändern, würde 
ich gerne wissen warum es nach Originalvorschlag nicht klappt, bzw. ob 
es bei dem anderen überhaupt klappen könnte.

Autor: sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gibt es für den MOC nicht zwei Schaltungsvorschläge (im Datenblatt) für 
ohmsche (wie deine Lampe) und induktive (Steuerventil) Lasten ?

Autor: Sebastian F. (snake080)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im Datenblatt haben die 30er und die 40er andere Widerstandswerte. Beim 
Snubber wird gesagt für hohe induktive Lasten soll man den Widerstand 
auf 360R, statt 39R erhöhen...

Wobei... ist eine Lampe nicht auch eine induktive Last?

Autor: Peter R. (pnu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Glühlampe ist ohmsche Last, praktisch nix induktives dabei.

welchen Strom schluckt das Thermostatventil überhaupt? wenn die Leistung 
gering ist, kann die Induktivität des Stellventils zu hohe Güte haben.

Vermutung:  Eventuell bildet der 10-nF-Kondensator mit dem L des Ventils 
einen Schwingkreis, der das Triac über den Nulldurchgang hinweg am 
Leiten hält oder den Nulldurchgangsdetektor des Kopplers durcheinander 
bringt.

Versuchsweise das L des Stellventils verschlechtern, indem ein 
Widerstand in Reihe zum Ventil geschaltet wird. Der Widerstand sollte 
dann so 30..50V vernichten. Die gleiche Wirkung haben auch die 390 Ohm 
im Snubber, vielleicht einmal an dieser Stelle ein Poti 1kOhm einsetzen 
und suchen. Eventuell auch das C von 10 nF auf 47nF erhöhen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.