mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR Studio findet ISP nicht


Autor: Georg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo liebe Leute,

seitdem ich Windows 7 installiert habe, funktioniert es nicht mehr. 
Zuerst habe ich WinAVR installiert und dann das AVR Studio. Programmer 
und Testboard sind diese hier: 
http://shop.embedded-projects.net/index.php?module...

Unter Windows XP konnte ich früher ein paar Projekte schreiben, indem 
ich beim verbinden den AVRISP mkII ausgewählt habe, aber das klappt 
nicht mehr. Kann mir jemand helfen?

Vielen Dank!

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schau mal ein wenig bei Google. Es gibt da unter Windows 7 eine Datei, 
die ausgetauscht werden muss. Ich weiß leider grad nicht wie das genau 
war, musste aber auch erst ein wenig im Internet Recherchieren.

Autor: Georg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für den Hinweis!

Also ich habe da etwas gefunden: Man soll die windrv6.sys Datei in 
windows/system32/drivers kopieren. Aber diese Datei ist bereits in 
diesem Ordner vorhanden und ich weiß gar nicht von wo ich sie kopieren 
soll!?

Der Windows Gerätemanager sagt übrigens, dass der Treiber korrekt 
installiert sei. Er erkennt auch, dass es ein mk2 Clone ist.

Eine andere Lösung soll sein, eine virtual Machine von XP laufen zu 
lassen. Das wäre mir unlieb aber ich lade mir gerade mal die nötigen 
Dateien bei Microsoft runter.

Hat sonst noch jemand eine Idee?

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Thema mit Win7 AVRISPmkII, WinAVR usw. würde hier paar Mal 
diskutiert, ich benutze ein AVRISPmkII mit Win7 64Bit WinAVR und AVRDUDE 
und alles funktioniert PERFEKT!

Der "USBprog" kenne ich nicht aber soviel ich gelesen habe der USBprog 
verhält sich wie ein AVRISPmkII d.h. er benutz der von AVRStudio 
mitgelieferter Jungo Treiber (vom Original AVRISPmkII), nun irgendwas 
ist nicht 100% identisch im Firmware des USBprog sowie beim USBAVRISP 
von Ulli (USB AVR Lab) da ab AVRStudio SP3 (oder SP2 weiss nicht mehr) 
unter AVRStudio nicht mehr geht!

Ich denke das hat mit Windows nichts zu tun sonder was im Firmware ok 
bei der 64Bit Version muß der Treiber Signiert sein aber wenn beide 
Proger der Jungo Treiber benutezn dann sollte auf alle Fälle mit 
AVRStudio funktionieren.

Gruß
Martin

Autor: Georg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also inzwischen habe ich die VM Ware und alles weitere installiert und 
natürlich funktioniert es auch nicht... Ich bin nun wirklich ratlos. Hat 
nicht noch jemand eine Idee was ich probieren könnte? Ich komme einfach 
nicht weiter.

Autor: Georg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

wer mal einen Blick auf das Datum geworfen hat, sieht, dass einige 
erfolglose Monate verstrichen sind. Das Problem konnte ich aber einfach 
nicht lösen. Nun habe ich aus lauter Verzweiflung einfach mal einen 
original AVRISP mk2 von Atmel gekauft. Und... die 40€ hätte ich mir 
sparen können. Immer noch wird kein Programmer erkannt. Bitte bitte 
helft mir!!!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.