mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Versuche Übertragung mit xbee in basic


Autor: CoxXxeR (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen;-)
Ich wollte mal frageen ob mir jemand bei meinem kleinen Problem helfen 
kann, ich verwende Bascom Basic und ein stk500 mit einem atmega 16 und 
versuche mit einem Kollegen eine verbindung zwischen den beiden 
controllern über xbee2 herzustellen. ich habe einen Code zum Senden und 
einen zum Empfangen aber irgendwie schreibt der Empfänger nur alle 10s 
mal irgendwas und am Sender sehe ich nur über meinen LCD was er über 
print sendet.
Der xbee wird mit 3,3V Versorgt und das DIN wird vom atmega mit einem 
Spannungsteiler auf 3,3V reduziert.Das DOUT habe habe ich direkt an den 
Atmega angeschlossen.
Hier meine sehr einfachen Programme:

Autor: CoxXxeR (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Der Empfänger noch sry

MfG CoxXxeR

Autor: Joe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Deine Schnittstelle muss richtig configuriert werden.

Das steht in der Anleitung !!!!!

Die In-Out-Pins sind intern festgelegt.

Config Portd.0 = Input, Config Portd.1 = Output

sind nicht erforderlich !!!!

Joe

Autor: Niklas C. (coxxxer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In welcher Anleitung?
könntest du mir nicht sagen wie ich die Schnittstelle richtig 
konfiguriere?
MfG CoxXxeR

Autor: Joe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Suche in der Hilfe $baud !!!

Einfacher geht es wirklich nicht.

Siehe auch

http://plischka.at/Funk_XBEE.html


Joe

Autor: muerzi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Soweit ich weiß, muss das xbee mit 5V versorgt werden.

Aber bei dir liegts womöglich an der config der Module.

Hast du sie per PC Programm (von Digi erhältlich) denn aufeinander 
abgestimmt?

lg

Autor: Niklas C. (coxxxer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Config Com1 = Dummy , Synchrone = 0 , Parity = None , Stopbits = 1 , 
Databits = 8 , Clockpol = 0

also meinst du das damit?
Ach müssen die abgestimmt werden??
ist das unbedingt notwendig?
Also im Datenblatt steht 3,3V 5V wäre für mich perfekt gewesen aber 
leider nicht:-(
Also ich habe die xbee's laut datenblatt mit den Mindestanforderungen 
angeschlossen also VCC = 3,3V GND DIN und DOUT mehr muss man laut 
datenblatt aber nicht.

LG CoxXxeR

Autor: Niklas C. (coxxxer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Keiner mehr eine Idee???:-(

Autor: Sebastian K. (sebastian_k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi. Habe selbst zwei 2.4GHz XBees und habe folgende Erfahrungen gemacht:

1. Die XBees müssen beide vor der ersten Benutzung mit der X-CTU 
Software auf die gewünschte Baudrate und PAN-ID konfiguriert werden.

2. Die Eingänge sind 5V-Tolerant. Das heißt du kannst den XBee direkt 
mit deinem ATMega verbinden, nur die 3,3V Versorgungsspannung sind 
natürlich einzuhalten.

3. Unbedingt den im XBee-Datenblatt angegebenen Kondensator möglichst 
nah an die Versorgungspins der XBees packen, ansonsten wird Müll oder 
garnichts übertragen.

Ansonsten habe ich die XBees als sehr unproblematisch kennengelernt. Die 
Teile funktionieren einfach klasse.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.